Mouse/Trackpad swipe gesture history back and forward



  • Is there a way to use Mac OS X gestures (swipe left and right) with magic mouse or trackpad to navigate back and forward in the history?



  • Yes, this is a must for OSX users!



  • You can swipe left/right over the browser navigation, status bar, or sidebar, but be careful not to do it over the tabs as that switches tabs.

    Overall, it's not really implemented yet, but kinda.



  • @TwisterMc:

    You can swipe left/right over the browser navigation, status bar, or sidebar, but be careful not to do it over the tabs as that switches tabs.

    Overall, it's not really implemented yet, but kinda.

    Ah, that works! It happened to me randomly and I wondered why for example it does work on the speed dial page but not on regular pages.

    The implementation looks sweet though I hope that those arrows will be customizable/hidden when it's implemented everywhere. For now I fixed the problem with BetterTouchTool :)



  • Are there any updates on this feature? It's probably the only thing I'm missing after the latest SS! (Well, perhaps also the dictionary lookup three-finger gesture, but that's just nit-picking.)



  • These are included in the latest release.



  • Hi - I still can't figure out how to swipe using Mac touchpad to go backward and forward in the history. I have the latest release.

    This feature works fine for me in Firefox, Chrome, etc.

    Any tips?

    Vivaldi 1.0.435.40 () (64-bit)
    Revision 575538bc320e213510be1e66f3521382e615129d
    OS Mac OS X
    Blink 537.36 (@575538bc320e213510be1e66f3521382e615129d)
    JavaScript V8 4.9.385.33
    Flash 21.0.0.197
    User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.110 Safari/537.36 Vivaldi/1.0.435.40
    Command Line /Applications/Vivaldi.app/Contents/MacOS/Vivaldi -psn_0_479349 –always-authorize-plugins --disable-translate --ppapi-flash-path=/Applications/Google Chrome.app/Contents/Versions/49.0.2623.110/Google Chrome Framework.framework/Internet Plug-Ins/PepperFlash/PepperFlashPlayer.plugin --enable-avfoundation --flag-switches-begin --flag-switches-end --disable-smooth-scrolling
    Executable Path /Applications/Vivaldi.app/Contents/MacOS/Vivaldi
    Profile Path /Users/ryanchanatry/Library/Application Support/Vivaldi/Default
    Variations 16e0dd70-3f4a17df
    b3888d8d-f9eb9ec4
    cf5ed6e1-3f4a17df
    775ebbd7-3d47f4f4
    f5dd6118-2f5721af
    4ea303a6-3f4a17df
    dbffab5d-f51b51
    c8b9b12d-d93a0620
    867c4c68-3f4a17df



  • I use Bettertouchtool to simulate 3-finger swipe on a regular mouse so I can use side buttons for back and forward and these don't work in Vivaldi 1.0 on 10.11.4 El Capitan.



  • This was fixed a few releases ago and I have no issues on my MacBook Pro.

    Do you have gestured enabled in the preferences? Maybe it has something to do with that.



  • Looks like it has nothing to do with those gesture settings. But I can confirm the 1.0 release of Vivaldi and latest Mac OS work fine for me.



  • I've tried with Gestures turned on and off and no difference.

    If I have "Swipe with three fingers" selected under More Gestures in Mac's Trackpad Settings, it will not work in Vivaldi. If I change it to "Swipe with two or three fingers" then I can navigate forward and backward in history using TWO fingers, but not THREE.

    Can others confirm that when you have the three finger option selected, you are able to use that in Vivaldi?

    Thanks!



  • Thanks for clarity, it's the three finder back/forward that's not working. I haven't tried that, but two finger works well.

    I think you can submit bugs here: https://vivaldi.com/bugreport/



  • Since Vivaldi is based on the Chromium browser, most solutions for Google Chrome also works on Vivaldi too. I took the answer from here and applied it to Vivaldi. Just had to find what Vivaldi's .plist file was and use that instead.

    Open Terminal and enter this to turn the swiping OFF

    defaults write com.vivaldi.Vivaldi.plist AppleEnableSwipeNavigateWithScrolls -bool FALSE
    

    or this to turn it ON

    defaults write com.vivaldi.Vivaldi.plist AppleEnableSwipeNavigateWithScrolls -bool TRUE
    

    Hope this helps, and the effects are applied immediate, so you won't need to restart to take effect.


  • Moderator

    Did you test that setting on your Mac, ant8672?

    I'm asking because it did not seem to have any effect on my rMBP 2013 (I quit Vivaldi before running the command and also verified with defaults read that it was properly set).



  • I haven't had any issues with swiping back and forth in the latest releases. Seems to be working out of the box for me.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.