How to set preferred language? (not interface language)



  • Hi to all old school Opera Fans! In Vivaldi is there a way to set a preferred language, i.e. not only for the interface but for the webpage content too? thx for listening


  • Moderator

    No easy ways. In Vivaldi setting you cant.
    Website mostly look at a special HTTP header sent by browser.
    You can (as a example) see these headers sent at http://echo.opera.com/

    My Vivaldis header is:

    Accept-Language: de-DE,de;q=0.8,en-US;q=0.6,en;q=0.4
    

    As you can see the weighted preference (by this q=NUMBER) is in order: German (de-DE,de), US-English (en-US) -> English (en)

    But you can change the HTTP header Accept-Language with some extension, i hope.
    Try it (i did not test):
    Quick Language Switcher https://chrome.google.com/webstore/detail/quick-language-switcher/pmjbhfmaphnpbehdanbjphdcniaelfie
    Yes, works!
    If you open Vivaldis Extensions page and select Options of extension "Quick Language Switcher", you add more languages, that can be set with the button.



  • Thank you, will try…
    cheers


  • Moderator

    Add the languages here:
    vivaldi://settings/languages



  • @Gwen-Dragon:

    No easy ways. In Vivaldi setting you cant.
    Website mostly look at a special HTTP header sent by browser.
    You can (as a example) see these headers sent at http://echo.opera.com/

    My Vivaldis header is:```
    Accept-Language: de-DE,de;q=0.8,en-US;q=0.6,en;q=0.4

    
    But you can change the HTTP header Accept-Language with some extension, i hope.
    Try it ~~(i did not test)~~:
    _Quick Language Switcher_ https://chrome.google.com/webstore/detail/quick-language-switcher/pmjbhfmaphnpbehdanbjphdcniaelfie
    Yes, works!
    If you open Vivaldis Extensions page and select Options of extension "Quick Language Switcher", you add more languages, that can be set with the button.
    

    Same problem here. There is no way in the Vivaldi settings to set your preferred website language, which for example causes redirects to localized Google, YouTube etc. pages. The Quick Language Switcher seems to change the whole interface language, which is not what I (neither apparently the thread starter) want.



  • I have Windows 10 64-bit version 1607 in US English.
    Unfortunately I am unable to add any additional languages in Windows 10.
    I tried everything, looked at all so called solutions from Microsoft and Forums, but I just can't get it done.
    From Firefox, I can download language packs for all available languages in the world and that works well.

    So now I have downloaded Firefox in the Dutch language on my US English Windows 10.
    If I had a native Dutch Windows 10 OS, the downloaded Firefox browser would automatically be in the Dutch language.
    I assume that when I download Vivaldi in a native Dutch Windows 10 (which I don't have at the moment) all text would also be in Dutch.

    So, unless someone gives me a solution for my problem, there is no way for me to get Vivaldi in the Dutch language?
    Or will there be a Dutch language pack available soon?


  • Vivaldi Translator

    @Dietrich
    The interface language?

    It's in settings, first section "Startup" & "Change User Interface Language" drop down.
    In your case, just scroll to "Nederlands - Dutch".



  • @dLeon

    Thanks for the advice, but I already tried everything.
    The problem is, that the update cannot be installed, which is a Windows 10 problem after a Windows update. No working solution found on Google yet.
    I will probably just install a newer version of Windows, see how that goes.

    5_1488449214456_2017-03-02_17-57-12.jpg 4_1488449214456_2017-03-02_17-56-29.jpg 3_1488449214456_2017-03-02_17-55-42.jpg 2_1488449214455_2017-03-02_17-54-56.jpg 1_1488449214455_2017-03-02_17-53-38.jpg 0_1488449214455_2017-03-02_17-50-27.jpg



  • @dLeon

    I installed a new version of Windows 10 and immediately after that I added the Dutch language and that went very well.
    So it must have been a Windows Update that caused the problem. :astonished:


  • Vivaldi Translator

    @Dietrich
    Nice. :smile:

    Probably the regional install (LanguagePack) register new things in registry.

    It's weird, why need to do all of that in first place. Dutch is part of iso-8859-1 & iso-8859-15 environment. Standard Windows fonts suppose to be could just show any iso-8859-1 to iso-8859-16 characters.
    It's more & more complicated just to do simple thing.



  • @Dietrich said in How to set preferred language? (not interface language):

    @dLeon

    I installed a new version of Windows 10 and immediately after that I added the Dutch language and that went very well.
    So it must have been a Windows Update that caused the problem. :astonished:

    Updates in Windows randomly breaking things...? Why, I've never heard of such a shocking accusation! ;)

    On point - once again my home laptop and main PC have both stopped "finding" software when I type in the start menu. Back to using shortcuts on the Total Commander button bar until I dig up that registry hack to fix it...



  • @mossman

    Windows zuigt! (letterlijk vertaald)
    Try this excellent software. It will find everything!

    https://www.voidtools.com



  • @Dietrich Thanks, but it's about pressing the Windows key and typing e.g. [v][i]... to get Vivaldi to open. For some reason, the list of installed software sometimes gets corrupted after updates.

    Last time it happened I found links to a registry file which forced Windows to rebuild its index - so I'm not the only one with this problem. But it can't be very common or you'd hear more people complaining.

    It was both our home PCs this time - so it could be my fault somehow... because I'm using CCleaner or O&O Shut Up 10, maybe?



  • @mossman Oh yeah, forgot to mention that Total Commander can also work with that "Everything" tool now! But I don't need to have constant indexing of my drive - TC does a good enough job when I send it to look for things.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.