Movie Sites Won't Play



  • I just discovered Vivaldi browser after reading a Linux Blog and being a user of Opera, I am glad to see this project moving forward. I'm running Ubuntu Linux, 15.04, 64 bit. I D/L'd and installed Vivaldi, but when I try to test on Netflix, or Hulu, or Crackle, The video does not play. I have version 1.0.219.50 (Developer Build) (64-bit) of the Vivaldi Linux build. Testing these sites on other Linux browsers, Opera, or Chrome, or Firefox, I have no issues at all. Being a development build, I expected some issues but not this. Do I need to link to a flash player plugin from another browser or is this a known Linux version issue? When looking at what plugins are installed in Vivaldi, I have Adobe Flash and Chromium PDF Viewer installed, which I assume is by default. Any direction is appreciated.



  • I am curious, can you watch this video?
    http://www.ted.com/talks/alan_eustace_i_leapt_from_the_stratosphere_here_s_how_i_did_it
    I can't, just like you Flash is in my plugins, but it doesn't work on TED.
    It does work on MLB.TV
    I remember years ago something similar happened with Opera, Flash content was not working on certain websites.



  • Well, first, update your installation of Vivaldi to the most recent snapshot. Because you're on TP4, which is several versions behind.



  • The TED link played for me with no issues.



  • Thanks for the build link, I used the install link from the main Vivaldi web page. I'll try this and report back.



  • OK, Vivaldi reports I have 1.0.264.3 (Developer Build) dev (64-bit) installed.

    Enclosed is a screenshot from HULU, I'm in the USA and tried several "non subscription" links from HULU with the same result.

    I tried this link on CRACKLE and the Flash status bar just spins: http://www.crackle.com/class-of-snl/2488441

    When I sign into NETFLIX, get the same error as before. Screenshot also enclosed.

    As noted previously the TED link that TalGarik proved worked fine, so does Youtube and other sites, but those are the 3 main ones I use for watching movies.

    Again, any direction is appreciated.
    Attachments:
    ,



  • I use Hulu, and I recognize that error all too well. I don't know exactly what the cause is, or whether Adobe or Hulu is to blame.

    What I do know is that Hulu has stated that they're looking into it. I've been using Firefox for Hulu ever since. I hope this issue gets resolved soon, but there's nothing we can do but wait.

    As for Netflix and Crackle, I don't know what's causing your issues there. Could be the problems are all related, in which case, Adobe messed something up. However, assuming that Flash only doesn't like Hulu in Chromium browsers,

    I don't use Netflix, so I can't do any testing on my end to see if I can reproduce your issue. I can't even get the Crackle website to load at all for me.

    Something you can try, and this is eventually what I ended up recommending to TalGarik in another thread: Launch Vivaldi from the terminal, visit those websites, and see if any the console outputs any errors.



  • Thank you for investing your time for my issue.

    This is my terminal output. It did throw an error and the results are the same if I launch from a terminal:

    [email protected]:~$ vivaldi
    [WARNING:flash/platform/pepper/pep_module.cpp(63)] SANDBOXED
    [1:1:0906/114616:ERROR:render_media_log.cc(20)] MediaEvent: PIPELINE_ERROR demuxer: could not parse



  • I'm afraid I've never seen this specific error before, and that I probably won't be of much help to you.

    I Googled the pipeline error, but was unable to find anything relevant. Does Netflix and Crackle work correctly in other browsers?



  • Yes all other browsers I have installed work correctly on HULU, CRACKLE, and NETFLIX, which is why I'm so puzzled.

    I don't have a 64-bit Windows machine to test whether Vivaldi 64 bit on Windows works with these sites then it could be narrowed down to a Linux version only issue.

    Thanks again for the time investment. For curiosity's sake if someone is running 64 bit Windows (7, 8x, or 10), I'd be interested in knowing if the have the same issue. I'll just hang in there and test/report on new Linux builds. I really loved the old Opera browser because the rest of the browsers seemed to follow your lead with implementing new features and I want this browser to be more successful because I know it can be. I like the features your team already have implemented.



  • Hulu and Crackle both work for me on my Windows machine running Windows 7 64-bit with a 32-bit installation of Vivaldi.

    This further suggests to me that it's Adobe's fault due to their general apathy and lack of support toward Linux customers.



  • as I understand it Netflix on chrome is now in html5 not flash and the codec is not in vivaldi, yet



  • I know this thread has been inactive for a couple of days, but I swapped distros last night and ran into Hulu not working for me anymore. I was directed to this article on How-to Geek about installing something called Hal. After doing so, I was able to just refresh the page and the video started playing.

    I don't know that we're experiencing the same problem, though, so it's possible this won't work for you. But, on a Debian / Ubuntu distro, you just need to enter this in the terminal to install Hal:

    sudo add-apt-repository ppa:mjblenner/ppa-hal
    sudo apt-get update
    sudo apt-get install hal
    
    


  • Not Good!

    I installed the HAL ppa and it muxed up my system. Now no browser works on HULU or CRACKLE (Opera , Chrome, or Firefox) . FYI for you Linux users. I'll purge the PPA and use another browser until this project matures a bit for Linux and/or the movie sites themselves change their API.

    Appreciate everyone's willingness to help.



  • Arch user here running TP4 Vivaldi. The link to the Ted Video works just fine for me, but Hulu does not. Netflix doesn't work either, but that's to be expected. As far as I know, Netflix has started moving to html5 and the only ways to use Netflix on Linux is either Chrome, Chromium with the widevine plugin, or (maybe?) Firefox using the super old official flash plugin from adobe. This is because of the crappy DRM that Netflix is forced to use by the companies that they get content from. I have not figured out a way to install widevine on Vivaldi, but if there is a way, that would make Netflix work. I'm somewhat new to Linux, so I can't be much more help than that. Sorry.



  • @Tiamarth:

    I know this thread has been inactive for a couple of days, but I swapped distros last night and ran into Hulu not working for me anymore.

    The beautiful world of linux distros: I swapped distro (not that much of a swap, from Manjaro Gnome Community Edition to Manjaro Net-install) and now I am playing a TED video :)



  • @Stevedude:

    I installed the HAL ppa and it muxed up my system. Now no browser works on HULU or CRACKLE (Opera , Chrome, or Firefox)

    I'm sorry to hear that, but I think it might just confirm we're not having the same issue. Several months ago, I was unable to play Hulu videos while using Ubuntu. But, with Firefox, I was able to play ads before the videos - and if I clicked the gear in the player's controls and selected "pop-out" before the ad finished playing, the video would play successfully in the new window. A few weeks after that started happening, I swapped to Linux Mint and Hulu worked in Firefox out of the box with no issues. It still wouldn't work in Vivaldi or other Chromium browsers, but that wasn't a huge deal to me. Two nights ago I swapped to Linux Lite (which is based on Ubuntu) and ran into Hulu not working for me again. So I Googled workarounds and came across this thread on Linux Questions which is where I found that article on How-to Geek. Installing Hal solved the issue for me on Linux Lite, and I remembered this thread, came back and shared it just in case you were having the same issue.\

    Basically, I have no idea why nothing's working for you, but the good news is Hulu is aware that their site isn't working correctly for a lot of people on Linux and are working on correcting the issue.

    @Randall_Danger:

    As far as I know, Netflix has started moving to html5 […]

    If that's the case, then it's no surprise that Netflix isn't working in Vivaldi. Vivaldi doesn't support certain video codecs which are required for html5 video playback. It should be working fine in more recent versions of Firefox, though, as it has supported those codecs for a while now (not sure on the exact time frame).

    @TalGarik:

    The beautiful world of linux distros: I swapped distro (not that much of a swap, from Manjaro Gnome Community Edition to Manjaro Net-install) and now I am playing a TED video :)

    Glad to hear it's working for you now :D

    I tend to stay mostly in the Debian family, but I used to use Slax pretty frequently some years ago - and it's of the Slackware family. Still, Linux Mint is my favourite distro, and I don't know that I'll ever get used to others.

    Anyway, I hope this gets resolved soon. I'll continue posting any new information I find or come across as long as the last post in this thread isn't more than a week old - as I have a strict policy about not bumping dead threads on forums.



  • I've been doing some research and I wanted to report back what I found.

    First, after communicating with Adobe, I was directed to this site: https://helpx.adobe.com/x-productkb/multi/flash-player-11-problems-playing.html

    Thank you Tiamarth for the info that Adobe also shared,however, it appears that the How-to-Geek site left out an important step to clear out Adobe access directories in Linux. The above link shows you what to do.

    Secondly, HULU directed me to other Adobe sites [refer to screenshot] that clear our the Flash Player cache. After following the links and running the Adobe Utility via their site. I am able to play HULU.

    Lastly, I have been in communication with CRACKLE and they sent me an email stating they are aware of the Linux issue and they are working to resolve it (Windows is unaffected).

    My apologies to the Vivaldi team, it's not you it's me!

    My many thanks to the responders for their time and efforts. Hopefully this info will prove useful to others.

    I wish I knew how to mark this thread "resolved". ;-)
    Attachments:


  • Vivaldi Team

    Thanks a lot for your investigation!

    I can just close this thread. :-)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.