[SOLVED] My Tabs Are Invisible!



  • I am running Vivaldi 2.9.1705.38 (Stable channel) (64-bit) on Linux Mint 19.2. Within the last week or two (perhaps after a Vivaldi update), I began having a problem with my tabs sometimes becoming invisible. The tabs are apparently still there, I just can't see them. The whole tab area becomes a solid color. If I glide the cursor across the tab area and click, I will open whatever tab happens to be hidden there, but this is poking around in the dark. It makes Vivaldi almost unusable.

    This problem comes and goes, and I haven't noticed anything that seems to cause it to happen. It can commence right in the middle of a session.

    Am hoping to find a solution here on the forum, so I can resume using Vivaldi, which is my favorite browser. (Right now I am resorting to Firefox.)

    Many thanks, in advance!



  • Do you use any mods?



  • No. I have not made any code changes. I do run the uMatrix and HTTPSEverywhere extensions, but those have been running since Day 1, which was many months ago. This problem with the tabs just started very recently, and I have made no changes of any sort to Vivaldi during that time. However, there are frequent upgrades/updates to Vivaldi handed down by the Linux Mint update manager. I don't know if one of those caused this crazy problem with the tabs.

    Interestingly, I just opened Vivaldi again, and the tabs are visible again. So the problem continues to be on-and-off. The tabs are visible for awhile, then are invisible for awhile.

    I guess I should add that I am running in incognito mode, which I always do. I have that flag added to my launcher. However, this has been my practice from Day 1, and all was well until just very recently.



  • @Iggy64 Do the updates come more frequently than here?

    And what about the window panel, does it show all your tabs?



  • @Iggy64 Have you tried changing Vivaldi Theme (I'm suspecting something with Accent Colour)?



  • Regarding the updates:

    According to Synaptic Package Manager, the Vivaldi updates are coming from:
    Vivaldi Package Composer packager@vivaldi.com
    and the package name is "vivaldi-stable"

    The package repository is
    deb http://repo.vivaldi.com/stable/deb/ stable main

    I don't know how often the updates come.


    Regarding the Windows panel:

    I remember when the tabs first became invisible, I looked into the side panel to see if there was a "Tabs" section and didn't find one. I wasn't bright enough to try the "Windows" section.

    At the present moment, Vivaldi is once again showing me the tabs in the tabs bar; but when they become invisible again, I will check in the Windows panel!!!!!!! Presumably, they will be visible there, and I can keep working, although not as conveniently.

    Thanks for the tip!



  • Concerning the Vivaldi theme:

    No, I haven't tried changing the theme. I have always used the default. However, that's a good idea. I will try that right away.

    I also realize that there has been another change in tab behavior. At one point, each tab was a different color. Now they are all blue. And, when they become invisible, the entire tab bar is that same blue.

    Hmmmm!



  • @Iggy64 Then this could help (maybe, possibly…):

    • go to settings → themes
    • click the edit theme button
    • (a new theme will be created because you tried to edit a default theme)
    • untick accent color from active page


  • Thanks for the idea concerning the accent color.

    At present, my tabs are once again visible in Vivaldi, without my having made any changes. I'll have to wait until they become invisible again, in order to try changing the theme to see if that fixes the problem.

    This reminds me of taking my car to the shop because the radio isn't working. As soon as I hit the bump at the end of their driveway, the radio came back on. When I got home, it stopped working again.

    The tabs problem has been intermittent -- here one day, gone the next, then back again. When they become invisible again, I'll try the various suggestions and report back in.

    Thanks to all who have replied. Your kindness is much appreciated!



  • @Iggy64 Ah yes, that happens very often; more than any of us would wish.



  • Latest update:

    Vivaldi tabs appeared normally last evening, and again early this morning. Then, in the middle of a session, all 6 tabs became invisible.

    I immediately looked at the Windows panel, and could see all the tabs there. This allowed me to navigate among my tabs OK.

    I then followed the suggestion to "Edit Theme" and uncheck "Accent Color from Active Page." That did not render the tabs visible. Nor did choosing another theme.

    However, after about 10 minutes, the tabs magically became visible again, after I had opened a few new tabs.

    This is a real puzzler.

    I may go ahead and do a complete re-install.



  • @Iggy64 Before you reinstall, just try this (the chance the problem is in your ~/ is much greater than it would be in Vivaldi install dir):

    • close Vivaldi
    • rename ~/.config/vivaldi/Default/ to something different (e. g. Default_bak)
    • a new user will be created on next startup
    • browse some time with that profile; at least a day (24h) (of course you can change the settings)
    • if that doesn’t help, rename ~/.config/vivaldi and try again; this will reset also all your flags


  • Thanks for the continuing support!

    I tried running with a new profile, but that did not help. The Tab Bar continues to sporadically go blank, rendering my tabs invisible. Eventually, they magically re-appear, only to disappear sometime later, often when I close one of the tabs.

    I also went with all my flags reset, to no avail.

    Next, I forced an update of Vivaldi from 2.9.1705.38 to 2.9.1705.41. Again, this failed to solve the problem.

    My next experiment will probably to install chromium and see if the tab bar is stable there.


  • Moderator

    @Iggy64 I think it is i a graphiss driver issue if tabs are blank or black.

    What happens if you start Vivaldi in a shell with deactivated GPU features:
    vivaldi --disable-gpu
    All tabs visible now?
    If yes open Settings → Website and deactivate 'Use of Hardware Acceleration'

    Or you may try open internal page chrome://flags/#ignore-gpu-blacklist , set to Enabled and restart.
    On own risk: Settings such flags may cause other issues and is not officially supported by Vivaldi Team.



  • Wow. I hadn't thought of that one!

    I am now running

    vivaldi --disable-gpu

    and - at least for the first several minutes - the tabs are remaining visible.

    I'll give it some time and usage, then report back in.

    Thanks for the idea.



  • Ran for several hours using

    vivaldi --disable-gpu

    and tabs remained visible the whole time, regardless of how many I opened or closed.

    Then I closed Vivaldi and re-opened without the

    --disable-gpu

    flag. The tabs were immediately invisible, even though about six were open.

    So, as you suggested, I turned off hardware acceleration using

    Settings > Webpages

    and unchecking "Use Hardware Acceleration When Available"

    Upon closing and re-opening, the tabs are magically visible once again. I may wait a day or so before declaring total victory, but I believe you may have solved this issue for me.

    I'll try to remember to check back in, confirm, and mark this thread "Solved." Please accept my sincerest "Thank-You" for helping make Vivaldi usable for me once again. It is my favorite browser.


  • Moderator

    @Iggy64 Thanks for your feedback.
    Fine, disable of Hardware Acceleration worked for you. 🙂

    Seems your issue was caused by a graphics/GPU driver.

    Would be interesting which GPUs (graphics card hardware, chipset) are on your hardware.



  • Thanks, again, for helping me get Vivaldi running again! I will mark this thread solved.

    Any thoughts on what might have triggered this problem to start in recent weeks, when Vivaldi had been running just fine for many, many months?

    In answer to your interest in my gpu, etc., here are details:


    System:    Host: john-OptiPlex-360 Kernel: 4.15.0-70-generic x86_64 bits: 64 compiler: gcc 
               v: 7.4.0 Desktop: Xfce 4.12.3 tk: Gtk 2.24.31 wm: xfwm4 dm: LightDM 
               Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
    Machine:   Type: Desktop System: Dell product: OptiPlex 360 v: N/A serial: <filter> Chassis: 
               type: 3 serial: <filter> 
               Mobo: Dell model: 0T656F v: A02 serial: <filter> BIOS: Dell v: A02 date: 07/02/2009 
    CPU:       Topology: Dual Core model: Intel Core2 Duo E7400 bits: 64 type: MCP arch: Penryn rev: A 
               L2 cache: 3072 KiB 
               flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 bogomips: 11172 
               Speed: 1596 MHz min/max: N/A Core speeds (MHz): 1: 1596 2: 1596 
    Graphics:  Device-1: Intel 82G33/G31 Express Integrated Graphics vendor: Dell driver: i915 
               v: kernel bus ID: 00:02.0 chip ID: 8086:29c2 
               Display: x11 server: X.Org 1.19.6 driver: intel unloaded: fbdev,modesetting,vesa 
               resolution: 1024x768~60Hz 
               OpenGL: renderer: Mesa DRI Intel G33 v: 1.4 Mesa 19.0.8 direct render: Yes 
    



  • @Iggy64 said in My Tabs Are Invisible!:

    Any thoughts on what might have triggered this problem to start in recent weeks, when Vivaldi had been running just fine for many, many months?

    Anything could cause this, most probably a change in Chromium.

    Could you please edit the specs section like this (to make make it better readable)?

    ```
    (all the text)
    ```
    


  • I am sorry to say that I don't know how to edit my specs section into the black box you showed in your post.

    If you have time to school me on that, I will do my best to resubmit the specs.

    Thanks for your help!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.