Twitter videos not playing in 2.8.1664.35



  • Twitter shows "the media could not be played".
    I saw a post from 2016. Why is this still not fixed?



  • @SveBjorn Hello, do you have the problem with all videos on Twitter? Or just part of them? An example to share?
    Do you have extensions installed that could be the origin of the problem? (you can try with those disabled just to verify)
    Not related but you could update Vivaldi to the last version 2.8.1664.40



  • Maybe it's the usual Windows 10 N problem with no proper media codecs pack installed.
    I'm on Win7 32bit and I just played a couple of video clips posted on Twitter, no problems.

    Edit: found one channel posting "gifs" (actually mp4) that display only a circular animation as it's loading forever, but never plays
    https://twitter.com/gif_miku/status/1181457194409177088
    and others on https://twitter.com/gif_miku (some play, some don't)
    They all play on Kiwi browser on Android.
    VIDEO: [H264] 548x660 24bpp 16.667 fps 792.3 kbps (96.7 kbyte/s)
    I don't see any particular strange thing about it.


  • Moderator

    Sorry to hear about your issue and thanks for reaching out. In order to help you we need some more information 🙂

    1. What is your Mac/Linux/Windows version and build?
    2. What is your Vivaldi version? (via Vivaldi menu
      Help → About and first line)
    3. Which CPU and RAM do you have?
    4. Which GPU and graphics hardware do you have?
      Are the drivers from chipset/card manufacturer up-to-date?
    5. Which is the output of vivaldi://gpu – any red or orange warnings?
      Copy the red and orange and paste here.
    6. Which audio output devices or special audio hardware do you use (f.ex. 5.1 surround or others)?
    7. Which extensions do you have installed? (via page chrome://system, row extensions and button Show...)
    8. Which security software do you have running (Firewall, antivirus, malwarekiller, etc)
    9. Which URL causes this issue?


  • Ok something is really not correct in some of those mp4 "gif" in the twitter link I posted, even firefox 69.0.2 don't play them, on both my Win7 PCs. Kiwi on Android plays them all.



  • @Gwen-Dragon I dont like this passive aggressive behavior here. 😞
    I have a Windows Pro installation 32GB ram and a Nvidia quaddro card. Professional DELL CAD mobile workstation that should be capable to render some simple website video.
    I check the proposed solutions. Thanks!



  • @Gwen-Dragon said in Twitter videos not playing in 2.8.1664.35:

    vivaldi://gpu

    So here is the report. Does this make any sense for you?
    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Metal: Disabled
    Multiple Raster Threads: Enabled
    Out-of-process Rasterization: Disabled
    Hardware Protected Video Decode: Unavailable
    Rasterization: Hardware accelerated
    Skia Renderer: Disabled
    Surface Control: Disabled
    Surface Synchronization: Enabled
    Video Decode: Hardware accelerated
    Viz Service Display Compositor: Enabled
    Viz Hit-test Surface Layer: Disabled
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated
    Driver Bug Workarounds
    clear_uniforms_before_first_program_use
    decode_encode_srgb_for_generatemipmap
    disable_accelerated_vpx_decode
    disable_discard_framebuffer
    disable_nv12_dynamic_textures
    exit_on_context_lost
    force_cube_complete
    msaa_is_slow
    scalarize_vec_and_mat_constructor_args
    disabled_extension_GL_KHR_blend_equation_advanced
    disabled_extension_GL_KHR_blend_equation_advanced_coherent
    Problems Detected
    Older Intel GPUs cannot support protected video decoding in swap chains
    Disabled Features: protected_video_decode
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    ANGLE crash on glReadPixels from incomplete cube map texture: 518889
    Applied Workarounds: force_cube_complete
    On Intel GPUs MSAA performance is not acceptable for GPU rasterization: 527565
    Applied Workarounds: msaa_is_slow
    Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
    Applied Workarounds: disable(GL_KHR_blend_equation_advanced), disable(GL_KHR_blend_equation_advanced_coherent)
    Decode and Encode before generateMipmap for srgb format textures on Windows: 634519
    Applied Workarounds: decode_encode_srgb_for_generatemipmap
    VPx decoding is too slow on Intel Broadwell, Skylake, and CherryView: 616318
    Applied Workarounds: disable_accelerated_vpx_decode
    Dynamic texture map crashes on Intel drivers less than version 24: 890227
    Applied Workarounds: disable_nv12_dynamic_textures
    Metal is only available on macOS.
    Disabled Features: metal
    Viz hit-test surface layer version is not enabled by default.
    Disabled Features: viz_hit_test_surface_layer
    Skia renderer is not used by default.
    Disabled Features: skia_renderer


  • Moderator

    @SveBjorn Thanks for your reply, please try one step after another to see if it solves your issue:

    • Update your NVidia drivers from NVidia page.
    • Disable all Intel GPU in BIOS.
    • Check special Hardware acceleration in NVidia settings
    • Enable Use of Hardware acceleration in internal page chrome://settings/system and restart Vivaldi
    • Enable override of GPU black list with vivaldi://flags/#ignore-gpu-blacklist, set to Enable and restart Vivaldi


  • @Ornorm Hej. Yes, all videos are not playing. No gif or other format will load.
    I am on Windows 10 with a fairly fresh install - last time after a fresh install I had no issues with twitter. And if a codec is missing - how come Firefox, Edge and Chrome are showing all content? If this is a Vivaldi settings issue I have to find out which one it is.



  • @SveBjorn said in Twitter videos not playing in 2.8.1664.35:

    how come Firefox, Edge and Chrome are showing all content

    they have their own decoding libraries, Vivaldi don't.



  • @iAN-CooG 4b44c09d-b392-4a9e-94b4-9f8e27cc9310-image.png

    Ok. good to know.
    I tried : vivaldi://flags/#ignore-gpu-blacklist
    and tried Override software rendering list.

    Didnt help yet.

    Attached is a screen of a typical tweet.



  • On Windows 10 N You have to install the media codec pack for your Win10 version. I hope this is the correct link
    https://www.microsoft.com/en-us/software-download/mediafeaturepack



  • @iAN-CooG thanks!


  • Moderator

    @SveBjorn Did the installation of Media Feature Pack for Windows N helped you to solve the broken video display?


  • Community Manager

    Also, I also pinged one of our dev who's specialized with media issues and he's recommending to test out with disabled hardware acceleration.
    Does that do the trick?

    Lastly if you are using any extensions, please disable them and check if it works.

    Please let us know how it goes. 🙂


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.