Address field fixes – Vivaldi Browser snapshot 1566.6



  • @Gwen-Dragon e inglés



  • Since updating I frequently lose my custom tile thumbnails in start page (speed dial). Today I lost almost an hour re-assigning them and now they are gone again. Has someone else experienced the same thing?



  • @nutcracker it happens if you actually delete the files or the directory containing the files you are using when assigning the custom SD thumbnails.
    Make sure to have a permanent directory dedicated for them, I for example use %localappdata%\Vivaldi\thumbs\ so it doesn't get deleted/overwritten during updates.


  • Ambassador

    @nutcracker A number of images are stored in:

    \Vivaldi\Application\2.6.1566.6\resources\vivaldi\resources\

    where 2.6.1566.6 is the latest Snapshot version.

    I store my custom thumbnails in the \Vivaldi\ folder, which never changes after an update.



  • In the search field drop-down, with the last two (or more?) snapshots I can no longer delete an entry. The X still appears after a selected entry, but does nothing when clicked. Is there another method to delete entries until that gets fixed? I tried <shift+del> mentioned for the address field drop-down, but that's doesn't work either.



  • Posted last thread about the dev tools being non-interactable with cursor on breakpoint. Still same problem when docked, but I have now undocked the dev tools from the main window and it's working fine like this



  • The autocomplete seems faster but it's still too slow to be usable :C



  • Just reported VB-54220, maybe kind of related to VB-53983. In short, the "X" button appears on the right of bookmarks in the address field dropdown, acts as "Delete" for the bookmark.



  • The address bar seems to have gotten a little better since the last snapshot, but nowhere near as good as it was before.

    Completion now at least populates the dropdown with addresses that match what I typed, but the address bar itself only rarely gets populated (and then only with bookmarks from what I can tell, not typed history).



  • Auto update is not working for me (for several snapshots) but ... with this particular snapshot no crashes at all, not one!


  • Vivaldi Team

    @pezo: Yeah, we are in the process of re-writing most of the address bar, so it should get better as we continue to work on it. (This also breaks it a bit ofc 🙂



  • The tile thumbnails are gone again! I was absent for two hours but my PC was on, all the time - I returned and found everything blank! It's the second time that something like that happens and in this snapshot. It cannot be a coincidence.
    At least come up with a script to assign the thumbnails back - now I have to re-assign them all over again and I suspect it won't be the last time!
    PS 1 - I re-assigned the tile images and when re-starting the browser, some of them were missing. There is definitely a serious problem. I don't understand why nobody else has reported this. The problem started with this version!
    PS 2 - Important observation: I keep many nested tiles (3-level mostly). Every upper level goes blank like its image is blank, but does not show the nested tiles, i.e. it's not transparent by showing its context. When I choose "clear custom thumbnails" then the top-tile becomes "transparent" and the nested tiles are showing (as blanks of course). That happens to every "parent" tile. Bottom line: it seems that the start page tiles are searching for an image and, when not finding it, assign a blank one - they do not become "generic" (i.e. transparent showing contents)
    PS - 3 and final: I give up! Every-time I start Vivaldi speed-dial thumbs are blank. There is no way of keeping them.



  • @Aronand said in Address field fixes – Vivaldi Browser snapshot 1566.6:

    @pezo: Yeah, we are in the process of re-writing most of the address bar, so it should get better as we continue to work on it. (This also breaks it a bit ofc 🙂

    It's incredible the amount of work that goes into this. I'd assume that to most users the address bar was something that is largely 'done' because we can see it and it works. But then behind the scenes it's being completely re-written.



  • I've got a weird observation on address field auto-completion. Say I have "im" as a search keyword for IMDb and want to search for something, so I start typing "im interstellar". However, as I'm typing, something else from my history or bookmarks starting with "im" pops up and what ends up inserted in the address field is "iminterstellar" despite me having hit Space. This is not always reproducible. I think it started happening with this snapshot.



  • @nutcracker said in Address field fixes – Vivaldi Browser snapshot 1566.6:

    The tile thumbnails are gone again!

    Had similar problem today with this build: after the Vivaldi crashed because of flash player and i started it again, thumbnails was gone. My folder with images for them is ok.
    I re-assigned a couple of thumbnails and after a couple of Vivaldi restarts they are ok so far.



  • @d_a_y_x: I'm reluctant to shut down my PC! I have at least 48 tile folders & sub-folders with at least 300 bookmarks, not just a couple. Every-time I bookmark something, I assign a thumb to the tile. Every thumb image is in a separate folder inside Vivaldi's installation folder and they are all intact. But it takes at least 2 hours to re-assign them. Even the automatically loaded (by the browser itself) page images are blanking up. There must be a selection of "pinning" the tile images (either custom or automatically loaded) so that no change or update is permitted.


  • Moderator


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.