Adobe Flash Player out of date?



  • So i went on to twitch.tv and i received a grey screen saying my flash player was out of date. So i went to adobe's home page and updated it. I went to the plug-ins page for vivaldi and it said the most recent version was being used and was enabled. But when i go back to twitch i only see a white screen where the stream should be. I am not sure if its an issue with twitch or vivaldi as other video websites, like youtube, work very well. I have seen a few threads about issues similar to this but none of the fixes for them helped. If anyone has had the same problem or knows how to fix it any help would be appreciated!


  • Moderator

    Current flash player is insecure and lets hackers and other security services into you system!
    Deinstall it.
    See https://helpx.adobe.com/security/products/flash-player/apsa15-04.html
    No fix yet for Flash Player.



  • Atm and especially in the future we won't need it anymore.
    It causes many security issues, you'd better uninstall it =)

    Ohh it's your first post, welcome among us!


  • Moderator

    Now you can download a update from https://get.adobe.com/flashplayer/





  • @parson007:

    So i went on to twitch.tv and i received a grey screen saying my flash player was out of date. So i went to adobe's home page and updated it. I went to the plug-ins page for vivaldi and it said the most recent version was being used and was enabled. But when i go back to twitch i only see a white screen where the stream should be. I am not sure if its an issue with twitch or vivaldi as other video websites, like youtube, work very well. I have seen a few threads about issues similar to this but none of the fixes for them helped. If anyone has had the same problem or knows how to fix it any help would be appreciated!

    Be sure you have the PPAPI version installed.

    It works perfectly for me.



  • Updated Flash yesterday but taking a look at vivaldi://plugins today I noticed that the NPAPI had updated but the PPAPI version hadn't, attempted again, same thing. I opened Opera Dev. and same result. To update the PPAPI version I had to do it manually from here: PPAPI
    I don't know if it matters or not because both seem to work for me if the other is disabled.


  • Moderator

    In near future the support for NPAPI plugins is cut as they are less stable and secure.

    Chromium and other clones (like Vivladi) should alwys have PPAPI plugin installed.



  • Can someone explain me step by step how to fix this Flash problem. EVERY single browser on my PC (Opera Dev, Chrome,Slimjet, IE) working perfectly with YT and all video sites, Vivaldi not. Thx.



  • I don't know others, but I had the same problem as OP, and I couldn't find a way to fix it.
    Until I found this easy way to fix it.
    [ul]

    • Open the plugins page
    • Expand the details
    • Under flash, disable version 17 and leave version 18 enabled
      [/ul]
      That's it.
      It seems like I had both versions at the same time, and if both enabled Vivaldi tried to use 17 as default.

    For who prefers a graphic guide.



  • Thank you. It's working. Easy solution but never cross my mind :)



  • Just right click on the icon and run plugin.

    http://prntscr.com/7ugxpo



  • Another solution for avoiding the "adobe player out of date" message is adding this command-line switch to the Vivaldi's shortcut:

    –allow-outdated-plugins

    Please, Vivaldi Team, do not remove this switch as Opera did in their version 30. That was the main reason to me for downgrading to Opera 29, and then start looking for an alternative.

    While using old flash players is insecure, Adobe also still offers the "Extended Support Release": an older version of Flash player that includes all of the latest security updates:

    https://www.adobe.com/products/flashplayer/distribution3.html

    Extended Support Release - Flash Player 13.0.0.309

    What is the Extended Support Release?
    Adobe makes available a version of Flash Player called the "Extended Support Release" (ESR) to organizations that prefer Flash Player stability over new functionality. We have created a branch of the Flash Player code that we keep up to date with all of the latest security updates, but none of the new features or bug fixes available in our current release branch. This allows organizations to ceritify and stay secure on Flash Player with minimal effort.

    Actual Extended Support Release is Flash Player 13. Unfortunately, browsers think this is an outdated version and block it, despite it contains all the latest security updates. Adobe will be upgrading the ESR version to 18 next month, but eventually the problem will arise again as the main Flash Player version gets updated.

    My suggestion for Vivaldi team would be either keeping the command line switch alive, or properly detect the Flash Player ESR versions.

    Thanks for creating the Vivaldi browser!! :)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.