Turning off the red WASD selection box



  • Hello Vivaldi forums! I'm one of the many who are trying out Vivaldi for the first time and I've gotta say I'm pretty impressed so far. I'm really interested in seeing where the project's gonna be going and I've been using the browser as my secondary one for the last week or so. The only real problem I've had with it so far is that the WASD keys seem to control some sort of red selection box that moves from one interactive website element to the next (not sure if this is Linux-specific). It doesn't happen while writing in text fields, but it's very annoying when using flash-plugins that require you to use the WASD keys for navigation. I've looked in the options and on the forums already and haven't found a solution to this, so I'd like to know: [b]Is there any way you can turn this WASD navigation off?[/b] Thanks in advance for your answers :)



  • As a temporary workaround, at Vivaldi for Windows > Settings > Mouse and Keyboard > Keyboard shortcuts, you can disable Single Key shortcuts.
    It will help with WASD navigation, but you'll also loose the ability to use some other keys, i.e. 1, 2, 3, 4, Z, X (if it's important to you).



  • Is that supposed to be a singular checkbox? Because if so, nothing like that shows up for me under "Keyboard Shortcuts". It's only a long list of shortcut functions with the corresponding buttons, and even if I delete all of them, the WASD keys still bring up the red box.


  • Moderator

    @Aposke:

    Is that supposed to be a singular checkbox? Because if so, nothing like that shows up for me under "Keyboard Shortcuts". It's only a long list of shortcut functions with the corresponding buttons, and even if I delete all of them, the WASD keys still bring up the red box.

    Depends on the version you are using. We did not get that option until this most recent snapshot, ver. 1.0.178.2 and in this version, it's a litlle checkbox at the top of the "mouse and keyboard" category within Tools/Settings/Navigation.

    If you don't have this version yet, go to the Vivaldi Team Blog https://vivaldi.net/en-US/blogs/teamblog and snap it up.

    Before you turn off single-key shortcuts, however, check and make sure the behavior still exists in the new snapshot - because this is something they have been working the bugs out of.



  • @Aposke:

    Is that supposed to be a singular checkbox? Because if so, nothing like that shows up for me under "Keyboard Shortcuts". It's only a long list of shortcut functions with the corresponding buttons, and even if I delete all of them, the WASD keys still bring up the red box.

    It's right above the "long list of shortcut functions" and below words "Keyboard Shortcuts"


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.