Incorrect resolution in Responsive mode (dev tools)



  • Browser show incorrect resolution, especially width, when dev tools are open and Responsive mode is enabled.

    Screen:
    0_1539866475010_vivaldi-incorrect-page-width.PNG



  • Same. I have this too on macOS - Vivaldi 2.4.1488.35

    All set to migrate to Vivaldi as my new main browser, but being a web developer, this kills it for me.

    If anyone knows when this may be fixed, or whether there's a workaround, it'd be great to hear.

    [Sigh...] So close. Back to Chrome for now then.


  • Moderator

    I can use responsive mode and the width in the bar is the same as in inspect element tooltip.

    Happens that on all pages for you?


  • Moderator

    @happyhour said in Incorrect resolution in Responsive mode (dev tools):

    but being a web developer, this kills it for me.

    May be your issue is a bug.
    Please read how to Report a bug for Vivaldi carefully and then report the bug to Vivaldi bugtracker.



  • Thanks for the response @Gwen-Dragon. Apologies for the tardy reply; I completely forgot about this thread!

    Good news: I'm still using Vivaldi and loving it (as a developer too).

    I reckon the issue was that I was viewing the page at a slightly different zoom level. Bear in mind that both the dev tools frame and the page itself have separate zoom levels, meaning that if there's an accidental minimal zoom change in play, it may not be visually obvious, and only show as a discrepancy in the dev tools resolutions.

    Te resolve, click into each separately and select Page Zoom Reset from the View menu (or whatever key combo you have set up for it).

    So, I reckon it was a fairly naive user error at fault here, rather than a bug with the software, as originally suggested.

    Hopefully that sorts it for anyone else that stumbles upon the same - somewhat embarrassing - issue.



Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.