Jak uruchomić wtyczkę Flash (na stałe)


  • Moderator

    Firma Adobe zamierza wycofać wtyczkę Flash najpóźniej do roku 2020. W związku z tym, programiści projektu Chromium (na którego silniku oparta jest przeglądarka Vivaldi) zdecydowali się na stopniowe wycofywanie obsługi Flasha z przeglądarki Chrome, a co za tym idzie - także z innych przeglądarek opartych na jej silniku.

    Na chwilę obecną jednym z wprowadzonych przez nich utrudnień jest kasowanie ustawień dotyczących zezwolenia na uruchomienie wtyczki Flash po każdym ponownym uruchomieniu przeglądarki. Oznacza to konieczność ciągłego włączania wtyczki Flash dla każdej witryny gdzie jest ona potrzebna.

    Istnieją dwa sposoby obejście tych utrudnień. Jednym z nich (w systemie Windows) jest dodanie do rejestru listy stron na których Flash ma być włączony na stałe. Prostszą metodą jest natomiast wyłączenie tej funkcji we "flagach" (czyli zaawansowanych i eksperymentalnych ustawieniach przeglądarki).

    Sposób 1

    1. Przejdź do strony vivaldi://flags#enable-ephemeral-flash-permission;
    2. Ustaw flagę "Enable Ephemeral Flash Permissions" na "Disabled";
    3. Uruchom ponownie przeglądarkę.

    Teraz możesz włączyć dostęp do wtyczki Flash na każdej stronie, która tego wymaga, a przeglądarka zapamięta Twój wybór.

    Sposób 2 - Instrukcja krok po kroku:

    1. Tworzymy nowy dokument tekstowy, np. na Pulpicie;
    2. Otwieramy dokument i wklejamy w nim kod:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\Software\Policies\Vivaldi\PluginsAllowedForUrls]
    "1"="tutaj_adres_strony"
    
    1. Otwieramy w przeglądarce stronę na której chcemy zezwolić na obsługę wtyczki Flash;
    2. Klikamy ikonkę kłódki (lub globusa) w pasku adresu i przy opcji Flash wybieramy "Zezwalaj";
    3. Otwieramy stronę chrome://settings/content/flash (skopiuj i wklej w pasku adresu);
    4. Kopiujemy adres strony (URL) który pojawił się pod "Zezwalaj" (nie zawsze jest to ten sam, identyczny adres który wpisaliśmy w kroku 1);
    5. Wklejamy skopiowany adres w pliku tekstowym, w miejsce tutaj_adres_strony;
    6. Kroki 3-7 powtarzamy dla wszystkich stron, dla których chcemy zezwolić na działanie wtyczki Flash - każdy wpis musi mieć inny numer, wg. wzoru:
    "1"="tutaj_adres_strony1"
    "2"="tutaj_adres_strony2"
    "3"="tutaj_adres_strony3"
    ... itd.
    
    1. Zapisujemy i zamykamy plik.
    2. Zmieniamy rozszerzenie pliku z *.txt na *.reg, np. z Nowy dokument tekstowy.txt na Nowy dokument tekstowy.reg;
    3. Uruchamiamy nasz plik i potwierdzamy wprowadzenie nowych wartości do rejestru;
    4. Uruchamiamy ponownie przeglądarkę.

    Od teraz strony które wpisaliśmy w naszym pliku będą miały odgórnie przyznany dostęp do wtyczki Flash, we wszystkich instalacjach Vivaldi na danym komputerze.


  • Moderator

    Zła wiadomość. W wersji 71 z Chromium usunięto flagę #enable-ephemeral-flash-permission. To oznacza, że już wkrótce prawdopodobnie pozostanie nam tylko metoda druga na obejście problemu z wyłączoną domyślnie wtyczką Flash. To też nie wiadomo na jak długo...

    Dni Flasha są już policzone, szkoda tylko, że webmasterzy i wydawcy stron tak ociągają się z zastąpieniem go nowoczesnymi standardami webowymi... 😕



  • Jest jeszcze sposób trzeci.Pewny.Pozostać do końca flasha przy wersji 1.5.



  • @bogast ...z niezałatanymi dziurami dotyczącymi bezpieczeństwa.
    Prosty, aczkolwiek ryzykowny 😉



  • Zaryzykowałem i przeskoczyłem na najnowsza wersję i jest problem.Nie wiem czy tylko mój.Po uruchomieniu paru kart ze stronami gdzie jeszcze flash jest wymagany i po aktywacji wtyczki oraz np.kamery na każdej z nich, po każdorazowym przejściu z jednej strony na inną wywala mi na pasku adresu info ze wtyczka jest zablokowana oraz wyskakuje okienko z "prośbą" o odblokowanie a dodatkowo info ze strona używa mojej kamery lub ze czeka na zezwolenie na jej uruchomienie.Rzecz w tym ze strona działa bez zarzutu,kamera lub mikrofon również.Wnerwiające sa tylko te komunikaty
    Nie jest to wina chromium ponieważ mam eksperymentalnie zainstalowaną przeglądarkę Kinza na bazie tego samego chromium i tam problem nie występuje.
    Owszem,jak to w chrome trzeba każdorazowo po otwarciu strony aktywować wtyczkę i to co jeszcze się chce ale do wygaśnięcia sesji przeglądarka to pamięta natomiast vivaldi "głupieje".
    Nie jest to równiez problem rozszerzeń ponieważ i w viva i w kinzie mam te same.
    Nie jest to również związane z profilem ponieważ w nowej wersji mam go stworzony na nowo.Zakładki importowałem z htlm-u a hasła ze starego profilu.
    Nie potrafie znależć rozwiazania tego problemu.



  • Uwaga!Dotyczy Sposobu drugiego.
    Wypróbowałem ale po aktualizacji do wersji 2.5 wszystkie wpisy w tym kluczu zostały skasowane.
    [HKEY_LOCAL_MACHINE\Software\Policies\Vivaldi\PluginsAllowedForUrls]
    Na szczęście można to ponowić.Wystarczy mieć kopie pliku reg.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.