Cannot play Netflix or Amazon Prime Video with v1.15.1147.64

  • Tried everything listed at the help page, including "Playing a wider range of audio and video" and "Widevine and Flash" parts. I can play all type of video and sound files listed here and here, respectively (except for *.caf, which seems unrelated to my issue).

    However, I still can't play either Netflix or Amazon Prime Video on Vivaldi. Both Amazon and Netflix show a warning about my browsers WidevineCdm needs to be updated. However, Widevine addon is missing on the list when I visit vivaldi:components.

    Any ideas how to fix this?

    Missing Widevine in Vivaldi on Raspberry Pi

    uname -a
    Linux raspberrypi 4.14.59-v7+ #1131 SMP Thu Aug 2 15:57:42 BST 2018 armv7l GNU/Linux
    cat /etc/debian_version 
    Vivaldi	1.15.1147.64 (Stable channel) (32-bit)
    Revision	40a77e3ed05776b882a9944eb85f77c13ba3f3d9-
    OS	Linux
    JavaScript	V8
    Flash	(Disabled)
    User Agent	Mozilla/5.0 (X11; Linux armv7l) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.183 Safari/537.36 Vivaldi/1.96.1147.64
    Command Line	/usr/bin/vivaldi-stable --flag-switches-begin --flag-switches-end
    Executable Path	/opt/vivaldi/vivaldi
    Profile Path	/home/pi/.config/vivaldi/Default

  • Forgot to mention that my RPi is a 3B+ and my firmware version is as follows:

    Aug 16 2018 17:30:30 
    Copyright (c) 2012 Broadcom
    version 31e0613622dc2f2463bf3dd74e6c897d91201a4d (clean) (release)

  • Moderator

    Try this script to fetch the latest widevinecdm

    And i remember that a user-agent changer extension can help if the streaming server misdetects Vivaldi.

  • @gwen-dragon Thanks, saw this before but I'm afraid neither armhf nor armv7l are not supported with this script (See lines 23-30 below.)

    if [ "$ARCH" = "x86_64" ]; then
    elif [[ "$ARCH" = i?86 ]]; then
      echo "The architecture $ARCH is not supported." >&2
      exit 1

    It might not be scripts fault though; I've also tried manually downloading and from (where script looks for downloads), server returned 404s.

    That's why I have downloaded a Chrome OS image created for an ARM device and grabbed and pepper/ from it, as told on the help page here, which I believe authored by @ruario.

    So, as far as I can tell, libraries are exactly where they should be.

  • Vivaldi Team

    Upgrade to Vivaldi 2.0.

    Then, to make sure you have H264/AAC support, issue the following in a Terminal window on your RPi

    curl -Lr1078- | tar xJ -C ~ --wildcards \*libffmpeg\.so --xform 's,.*/,.local/lib/vivaldi/,'

    Next run this script. It does not have to be on the target machine. A x86/x86_64 PC is fine. It will create a file named something like widevine-flash-20181005_armhf.tgz (the date might be different, unless you happen to do this today).

    Copy it to your ARM device and install it as follows:

    sudo tar -C/ -xf widevine-flash-*_armhf.tgz

    You should now have proprietary media support, DRM support and Flash support.

    For Netflix you will also need to fake your user agent as per these instructions.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.