Unable to activate GPU acceleration on the browser



  • So, yeah, what it says in the title. I tried searching for it, but the other cases I saw aren't exactly the same as mine.

    No GPU acceleration at all is enabled in my browser. This is the vivaldi://gpu report:

    Graphics Feature Status
    Canvas: Software only, hardware acceleration unavailable
    CheckerImaging: Disabled
    Flash: Software only. Hardware acceleration disabled
    Flash Stage3D: Software only. Hardware acceleration disabled
    Flash Stage3D Baseline profile: Software only. Hardware acceleration disabled
    Compositing: Software only. Hardware acceleration disabled
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only. Hardware acceleration disabled
    Video Decode: Software only. Hardware acceleration disabled
    WebGL: Software only, hardware acceleration unavailable
    WebGL2: Software only, hardware acceleration unavailable

    To compare, this is my chrome;//gpu report on Chrome 65:

    Graphics Feature Status
    Canvas: Hardware accelerated
    CheckerImaging: Disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Hardware accelerated
    Video Decode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated

    I'm on 1.15, latest version. Already tried to go to vivaldi://flags and enable "Override software rendering list" and "GPU Rasterization", to no avail.

    The only extensions I'm using are nano adblocker, tampermonkey, stylish and lastpass (all of those are the same extensions I use on Chrome).

    My laptop is one of those that uses dual graphics (an onboard Intel and a GeForce 940MX 2GB VRAM. I already configured the system to open Vivaldi using the GeForce adapter. Also, I'm on Windows 10.

    Does anyone have any idea of what's happening, and what I can do to fix it?



  • OK, so I'll reply to my own thread saying that I found the answer.

    Fiddling around, I saw someone saying that you should go to vivaldi://settings/content and then fiddle with some options. My problem is that I wasn't seeing anything that the persona was saying I should see.

    So, it turns out that the real path is chrome://settings/content

    This will lead to a different screen. Pressing the arrow on top will lead to an "all setting" page, and then scrolling all the way down I found the option to enable hardware acceleration.


  • Moderator

    There are those ways. A brazilian user was having the same problem and I had found for him those two solutions:

    1- On the addressbar and pressing ENTER:
    chrome://settings/?search=hardware
    I dunno how is exactly in english but you will see some option written "Hardware Acceleration".

    2- On the addressbar and pressing ENTER:
    vivaldi://flags/#disable-accelerated-2d-canvas

    I used the both ways and improved a bit the browser fluidity


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.