Opening certain videos from thumbnails causes black screen, then all thumbnails on page become green



  • Hi,

    I have an issue that only happens with Vivaldi (1.14.1077.60), I'm on Windows but don't know if it's related to the OS at all.

    This is easy to reproduce on TweetDeck but happens on other sites too. When I click on a gif thumbnail (edit: turns out these are actually mp4s, but the issue doesn't happen with youtube thumbnails), I first briefly get the shadow overlay with the loading icon (as expected) then the whole window turns black for half a second, then back to the overlay but no gif/video to be seen. If I click anywhere to go back to the regular tweetdeck screen, all screen thumbnails on the page have turned green (but if I scroll up or down and a now one comes into view, it's fine).

    If I open the link to the tweet and see it on web twitter, it behaves normally.

    Before:
    1_1523544954257_before.png

    Black screen:
    2_1523544954258_black screen.png

    After (all gif thumbnails on the page appear like this)
    0_1523544954257_after.png

    Firefox, Chrome and Edge have no issue, as far as I can tell. It's quite recent in Vivaldi, maybe a couple weeks old, tops.
    Any idea how to fix this?

    Cheers :)



  • @acccent
    Hi, Twitter account is needed for TweetDeck, do you have another example?

    Gruß, mib



  • I believe it also happens on facebook.

    I'll post a gif here and see if it happens... huh – as I write this and go on TweetDeck to find one that triggers the bug, everything seems to be working fine. What.
    I'm guessing maybe it's because I have a game open and so it triggers my video card or something? Very weird. Anyway if I do find a gif that triggers the issue I'll post it here to see if it works.


  • Moderator

    Look like a GPU Hardware acceleration issue.



  • Alright so, it turns out this happens with videos not gifs – they're gifs initially but turned into videos by twitter.

    Here's an example of one: https://video.twimg.com/tweet_video/Dam9wBqUwAAlsJW.mp4

    Going to that link directly causes the same issue.


  • Moderator

    @acccent Plays normally here.



  • @ayespy well, I'm happy for you


  • Moderator

    @acccent The point being, your problem is likely local - and may be solved by disabling hardware acceleration.



  • @ayespy I understand that, but isn't it weird that I would have to disable hardware acceleration (which is something that I'd want to leave enabled) for Vivaldi, my main browser, when all other browsers (including the latest Chrome) just behave normally with the same video? I'm sure it is something specific to my configuration, but it also something specific to Vivaldi, and I don't claim that it's a universal issue but it also feels counter-productive to handwave it away.



  • @acccent If all programs were identical there would be no need for different ones. Vivaldi has some features chrome hasn't, on the other hand chrome devs (google inc) have billions of income so they can blindly pay for some patented codecs to support a wider range of video compressions (and some are even google patents) while vivaldi have to make do with whatever your OS supports.
    If in the chromium code your gfx card is blacklisted, it's better to switch off hw video decode for good.
    You can check with vivaldi://gpu



  • @ian-coog and if all programs were identical, I wouldn't use Vivaldi and I wouldn't be here trying to understand why a problem happens and help make it not happen :)

    How do I check if my GPU is blacklisted? the //gpu page has a ton of info.
    I'm pasting the "problems detected" section here, maybe it can help?

    • Some drivers are unable to reset the D3D device in the GPU process sandbox
      • Applied Workarounds: exit_on_context_lost
    • TexSubImage is faster for full uploads on ANGLE
      • Applied Workarounds: texsubimage_faster_than_teximage
    • Clear uniforms before first program use on all platforms: 124764, 349137
      • Applied Workarounds: clear_uniforms_before_first_program_use
    • Always rewrite vec/mat constructors to be consistent: 398694
      • Applied Workarounds: scalarize_vec_and_mat_constructor_args
    • ANGLE crash on glReadPixels from incomplete cube map texture: 518889
      • Applied Workarounds: force_cube_complete
    • On Intel GPUs MSAA performance is not acceptable for GPU rasterization: 527565
      • Applied Workarounds: msaa_is_slow
    • Framebuffer discarding can hurt performance on non-tilers: 570897
      • Applied Workarounds: disable_discard_framebuffer
    • Use GL_INTEL_framebuffer_CMAA on ChromeOS: 535198
      • Applied Workarounds: disable_framebuffer_cmaa
    • Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
      • Applied Workarounds: disable(GL_KHR_blend_equation_advanced), disable(GL_KHR_blend_equation_advanced_coherent)
    • Decode and Encode before generateMipmap for srgb format textures on Windows: 634519
      • Applied Workarounds: decode_encode_srgb_for_generatemipmap
    • Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
      • Disabled Features: native_gpu_memory_buffers
    • Checker-imaging has been disabled via finch trial or the command line.
      • Disabled Features: checker_imaging

    I have an Intel HD Graphics 620 and a GeForce GTX 950M.



  • @acccent All I know by reading this forum in these 2 years is that it's bad to have both intel chip active with a geforce (and I also don't see why keeping it active either, nvidia is better in any case) so it's better to disable it in the bios


  • Moderator

    @acccent If Chrome has blacklisted your GPU, it may be disabling it silently without input from you. Vivaldi may be trying to use it.



  • Hm, looking at https://chromium.googlesource.com/chromium/src/gpu/+/master/config/software_rendering_list.json, I can't find anything that would indicate my GPU is blacklisted. Besides, if it was, wouldn't the issue be consistent across websites and over time? It only happens some of the time and, even on a single website like TweetDeck, I think it's not constant. Plus it only started happening recently as I said and my laptop isn't that new.

    (These are genuine questions, not rhetorical at all!)

    I think having both the Intel and NVIDIA GPUs is to improve battery life. I don't know about disabling one...

    If the issue is indeed something like "Google just has specific fixes in Chrome to issues that exist in Chromium", are you saying there's just nothing that can be done about it and I should switch browsers? :(


  • Moderator

    @acccent Chromium/Chrome is blacklisting more and more GPUs all the time. When they do, Chrome disables the GPU without mentioning it to you, and renders video with software. If Vivaldi tries to use the GPU for rendering and it's not entirely compatible with the Chromium engine (due to successive changes in the engine, and changes in whichever codecs are chosen to render different content), it will render some kinds of video fine and others not, often. So "it used to work fine" is not really relevant to how Google is continually changing the internet and media landscape. You would find out if your GPU is blacklisted in Chrome by opening (in chrome) the address chrome://gpu . If Vivaldi is trying to use it, it's obviously not blacklisted in Vivaldi. Further, Chrome may ignore the GPU silently for certain content even when it's otherwise not disabled.

    If the issue is indeed something like "Google just has specific fixes in Chrome to issues that exist in Chromium", are you saying there's just nothing that can be done about it and I should switch browsers? :(

    Not at all. That just means that Vivaldi is going to have to derive solutions for things that they received no heads-up on, that the next intake of Chromium was going to break them.



  • Hm, so, I can't find in Chrome whether or not my GPU is blacklisted, however the gpu page for Vivaldi says:

    • Canvas: Software only, hardware acceleration unavailable
    • CheckerImaging: Disabled
    • Flash: Software only, hardware acceleration unavailable
    • Flash Stage3D: Software only, hardware acceleration unavailable
    • Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
    • Compositing: Software only, hardware acceleration unavailable
    • Multiple Raster Threads: Enabled
    • Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    • Rasterization: Software only, hardware acceleration unavailable
    • Video Decode: Software only, hardware acceleration unavailable
    • WebGL: Hardware accelerated but at reduced performance
    • WebGL2: Software only, hardware acceleration unavailable

    That is, everything has hardware acceleration disabled save for Multiple Rester Threads, and CheckerImaging that is just plain disabled.

    On Chrome, CheckerImaging is also disabled, and Native GpuMemoryBuffers is also software only, but everything else is hardware-accelerated...

    Also, "it used to work fine" is one thing, but the other thing is that it still does work from time to time. For instance right now if I open the link I pasted above, it shows up fine, no black screen. I thought this ruled out the GPU blacklist idea.


  • Moderator

    @acccent As i can see all hardware acceleration is off. That’s why you can’t see content. Perhaps the wrong video card is switched in.

    Please try to override the GPU blacklisting.
    Open vivaldi://flags/#ignore-gpu-blacklist in address field
    Select Enabled
    Restart Vivaldi



  • @gwen-dragon After enabling the ignore-gpu-blacklist flag, the issue still happens.


  • Moderator

    Oh. The you should report the issue to Vivaldi. Perhaps they know a solution.

    Please read How to Report a bug for Vivaldi carefully and then report the bug to Vivaldi bugtracker.



  • @gwen-dragon Done, cheers :)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.