ExpressVPN Plugin constantly reports needs update



  • Whenever I click on the eVPN icon, I get the same error message "Express VPN for Windows needs to be updated." I have the current version installed. I have even gone so far as to completely remove the plugin and eVPN installation then re-install everything. No change. The folks at Express VPN tell me as long as their product is working properly - and it appears to be - I can ignore the message and press on. I equate that with resolving a "Check Engine" light in your car by placing a piece of tape over the indicator.

    My question: Is Vivaldi misreading the status or shall I continue pressing eVPN for a fix?


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.