ALT+64 problem



  • I write @ in web forms by typing ALT+64 and I want to ask, why is ALT+64 only ASCII Code which jumps from form to address bar. How can I turn this feature off?



  • It's not just 64, it's the Alt+numpad 4 combination. I have no idea why though, it's not listed as a keyboard shortcut.
    On a separate note, why do you need Alt-codes to type @? That's a pretty common character, don't you have it under an AltGr combination?



  • ALT-codes are pretty fast for me and I use them for long time. I use Czech QWERTY keyboard and there Alt-Gr combination didn´t work. In "normal" Czech QWERTZ it works, but switching keyboards by ctrl+shift and then use Alt-Gr combination is not very useful, is same, like switch to English keyboard and use shift+2.



  • @Ondrej.Ulman:

    ALT-codes are pretty fast for me and I use them for long time. I use Czech QWERTY keyboard and there Alt-Gr combination didn´t work. In "normal" Czech QWERTZ it works, but switching keyboards by ctrl+shift and then use Alt-Gr combination is not very useful, is same, like switch to English keyboard and use shift+2.

    Just customize your keymap adding the simbols you miss to the keymap you use

    https://msdn.microsoft.com/en-us/goglobal/bb964665.aspx



  • This problem is already reported and known by Vivaldi developers.



  • Hello, it is good to know that problem is reported and known, but it will be 5 months since last post and this problem is not solved yet. Any solution how to use properly alt + numlock?


  • Vivaldi Translator

    @RRR13:

    Guys, seriously, wtf?! Alt codes?! What year is this?
    Just do what The_Solutor said!

    Well, ALT codes are universal method for typing special characters. They're working in all applications - except Vivaldi.
    This I can't tell about AltGr shortcuts. I know few applications, where AltGr doesn't work properly.

    Why I have to mess my PC with 8 years old unsupported app from Microsoft when there is cross-application working quick and functional ALT code method?
    I just want to sit to any computer and type easily. What if someone hasn't administrator privileges to the system?



  • ✓ They seem to be working for me :o

    I cheated. I posted this from my Linux machine. But I can confirm that I can reproduce the described behavior on my Windows machine.


  • Vivaldi Translator

    OK, I'll try it with another way. I thought, that Vivaldi was built with (power)users in mind. Why not let USER choose the way, how he can type characters? If he wants to be a masochist (because of ALT codes - press AltGR+V or ALT+64 is very huge difference…) - why not?

    @RRR13:

    Fifth, if you need to enter exotic characters regularly on a machine where you don't have sufficient rights to install a tool that helps you do your job, then there is a bigger issue in the organization that shoud be fixed and arguing against keyboard layout should be the secondary priority here.

    I don't have anything against keyboard layout changes. But with organizations are unfortunately problems. So please recommend me another "easy" way.
    Thank you.



  • Sorry, but customizing the keymap is really not the right solution. Yes, it can work but this is not the proper way. If I should customize anything always when I install some software to run it properly, I wouldn´t do anything else. You can seek any way how to bypass this temporarily but still it is Vivaldi´s bug and should be solved. It is quite a time it has been reported :dry:



  • @nfsmaniac:

    @RRR13:

    Why I have to mess my PC with 8 years old unsupported app from Microsoft when there is cross-application working quick and functional ALT code method?

    What you mean by "mess my PC" pretty please?
    Making a custom keyboard layout is a standard action, mo more "messy", than installing an updated driver for your gfx.
    The problem is that Microsoft itrself mess the layouts pretty badly, and that some programs "know better" what layout you "should" use.
    I had to edit NLS maps in registry and make OS believe that my custom layout is a standard Russian layout, but now I have about 15 characters more readily available without switching the layouts back and forth.



  • @tomas.lizner:

    Sorry, but customizing the keymap is really not the right solution. Yes, it can work but this is not the proper way. If I should customize anything always when I install some software to run it properly, I wouldn´t do anything else. You can seek any way how to bypass this temporarily but still it is Vivaldi´s bug and should be solved. It is quite a time it has been reported :dry:

    Nobody said that this is not a bug, but at the same time, if you find yourself constantly typing specific characters, making a custom layout IS THE right solution.
    When I've found myself repeatedly typing things like NBSP, §, °, as well as various brackets on RU layout, I went on and created a custom layout. Now, I have much more freedom in typing, and I don't have to waste my mind memorising all the alt codes.


  • Vivaldi Translator

    AnrDaemon: You're right. I was only disappointed that someone is arguing a bug.
    Custom layout really can be some usability improvement. But this I can do only on my home PC.
    So "destroying" ALT codes is still really bad idea even in year 2015. As soon as Microsoft allows to change layout also without extra permissions, we can discuss about "destroy" of ALT codes.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.