libffmpeg in latest builds

  • Starting with version 1.14 vivaldi no longer starts because of ffmpeg shared library. It shows error while loading shared libraries: cannot open shared object file: No such file or directory even though the file is there. The problem can be solved by copying the library from version 1.13.

    Interestingly enough is that ldd for so file from 1.14 shows not a dynamic executable, though it worked ok for 1.13 (see below).

    pi@raspberrypi:~ $ vivaldi-stable 
    No suitable library for HTML5 MP4 (H.264/AAC) video and MP3 audio was
    found, therefore only open codecs will play.
    For assistance on how to enable proprietary media, visit:
    /usr/bin/vivaldi-stable: error while loading shared libraries: cannot open shared object file: No such file or directory
    pi@raspberrypi:/opt $ ldd (0x7ebd3000)
    	/usr/lib/arm-linux-gnueabihf/ (0x76cbb000) => /lib/arm-linux-gnueabihf/ (0x76c79000) => /lib/arm-linux-gnueabihf/ (0x76c62000) => /lib/arm-linux-gnueabihf/ (0x76be3000) => /lib/arm-linux-gnueabihf/ (0x76bb6000) => /lib/arm-linux-gnueabihf/ (0x76a77000)
    	/lib/ (0x76ee9000)
    pi@raspberrypi:/opt/vivaldi/lib $ ldd
    	not a dynamic executable
    pi@raspberrypi:/opt/vivaldi/lib $ uname -a
    Linux raspberrypi 4.9.80-v7+ #1098 SMP Fri Mar 9 19:11:42 GMT 2018 armv7l GNU/Linux

    OS: Raspbian (Pixel), Debian stretch
    Hardware: RPi3

  • Forgot to say: nightly builds (1.15) have the same issue.

  • I posted a bug on the bug tracker, but I doubt they'll do anything about it since the ARM releases are unsupported.

    So I figured the workaround is to first download and install Vivaldi 1.13 stable
    Copy the from the installation at /opt/vivaldi/lib, install the latest and sudo cp the old library back to the lib folder.

  • Moderator

    I do not know if the armhf package chromium-codecs-ffmpeg-extra 65.0.3325.181 from may help.
    Copy to folder /opt/vivaldi/

  • Vivaldi Team

    Hmm… yeah, something is going wrong with the building/packaging of libffmpeg for armhf only. Need to find out why and fix it. I missed this for a lonmg time as I am not using the we bundled but rather one from Ubuntu that gives me h.264/aac support.

    Anyway, I have just repackaged the 1.15 stable (late yesterday) with a working This is not a proper fix as I would need to keep doing it for every release (the fix should be in the original build and packaging phase) but it will get stable users up and running for now. Check for updates and you should receive a working version 1.15.1147.36-2 (note: -2).

  • Vivaldi Team

    Ok, I have updated the latest snapshot as well


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.