WebRTC & sleeping: disable Vs broadcast



  • Hi everyone.

    My Windows 10 box very often can't sleep due to active WebRTC session in Vivaldi.

    Fresh install of Vivaldi 1.14.1077.50 (Stable channel) (32-bit).
    I've unchecked the "Broadcast IP for Best WebRTC performance" which this moderator post indicates is "disabling" WebRTC... Disable WebRTC.

    How can there be an active WebRTC session if it's "disabled" ?

    Thanks.



  • This is driving me a little mad...

    I can't figure out how to disable WebRTC in Vivaldi, and I can't figure out how to tell Windows sleep to ignore Vivaldi.

    Can anyone please help me ?

    C:\>powercfg -requestsoverride
    [SERVICE]
    
    [PROCESS]
    opera.exe DISPLAY SYSTEM AWAYMODE
    vivaldi.exe DISPLAY SYSTEM AWAYMODE EXECUTION
    \Device\HarddiskVolume2\Program Files (x86)\Vivaldi\Application\vivaldi.exe DISPLAY SYSTEM AWAYMODE EXECUTION
    
    [DRIVER]
    
    C:\>powercfg -requests
    DISPLAY:
    None.
    SYSTEM:
    None.
    AWAYMODE:
    None.
    EXECUTION:
    [PROCESS] \Device\HarddiskVolume2\Program Files (x86)\Vivaldi\Application\vivaldi.exe
    WebRTC has active PeerConnections
    PERFBOOST:
    None.
    ACTIVELOCKSCREEN:
    None.
    


  • If you take Vivaldi (with WebRTC switched "off") to a site like https://test.webrtc.org/, what does it show? (In the case of test.webrtc, you may have to tell it to "continue without audio/or video" and then hit "Start" to run the specific tests, which may take several moments to populate).



  • Thanks Blackbird.

    By "WebRTC switched off" you mean "Broadcast IP for Best WebRTC performance" un-checked?

    test.webrtc.org returned red X for all tests except for these green ticks:

    Tcp enabled
    [ OK ] Gathered candidate of Type: relay Protocol: udp Address: *xxxx*
    Relay connectivity
    [ INFO ] Gathered candidate of Type: relay Protocol: udp Address: *yyyy*
    [ INFO ] Gathered candidate of Type: relay Protocol: udp Address: *zzzz*
    [ OK ] Data successfully transmitted between peers.
    Data throughput
    [ OK ] Transmitting at 1146.88 kbps.
    [ OK ] Transmitting at 1486.485 kbps.
    [ OK ] Transmitting at 1490.944 kbps.
    [ OK ] Transmitting at 1490.195 kbps.
    [ OK ] Transmitting at 1503.492 kbps.
    [ OK ] Total transmitted: 7151.616 kilo-bits in 5.03 seconds.
    

    This page seems to consistently have WebRTC active for Vivaldi, but not FireFox:
    https://stackoverflow.com/questions/7719374/batch-uploading-huge-sets-of-images-to-azure-blob-storage?noredirect=1&lq=1



  • @igull Yes, turning off the "Broadcast IP for Best WebRTC" was what I meant earlier. Your website results are almost identical to mine, though I show only 1 relay connectivity "Gathered candidate of Type: relay Protocol..." entry. I surmise this all probably implies both our Vivaldi installs are working identically, at least nearly so. That said, my system enters hibernation intentionally several times in a typical 24-hour period, and I've yet to find it woken up unintentionally (that is, by other than me via a keyboard or mouse).

    There is a web page regarding a similar problem to yours involving a Chrome browser that may provide some insight into the sort of thing that might be occurring: https://techjourney.net/chrome-webrtc-has-active-peerconnections-prevent-computer-from-auto-sleep/ In their case, it's more a situation of the browser not allowing the system to enter hibernation because of a WebRTC involvement from a running tab; in your case, it appears a tab (or extension) in the browser may be periodically triggered by a WebRTC-related command from the website in an open/background tab or by an extension. Not being a WebRTC guru, I'm not sure beyond that what is occurring with regard to Vivaldi and its WebRTC functionality.

    There is another page at the Techjourney site that offers a possible work-around that might help at least stop the problem: https://techjourney.net/chrome-prevents-windows-from-going-into-sleep-standby-or-hibernation-mode/ About halfway down that page is a section entitled "Workaround 4: Override Chrome Power Requests" that provides an admin-level Command Prompt command that can likely be adapted to Vivaldi, along the lines of the following:
    powercfg /requestsoverride PROCESS vivaldi.exe AWAYMODE DISPLAY SYSTEM
    This would block Windows from accepting a power request from Vivaldi that might block or interrupt hibernation.



  • @blackbird

    Thanks for sharing... still no closer to enlightenment though 😞

    I've already added the requestsoverride for vivaldi (see post above), but it still prevents sleep.

    If you have time could you test the following please?

    Cheers.



  • I raised bug report for this.

    Summary: Can't disable WebRTC to allow Windows 10 to sleep
    Key: VB-38247
    Project: Vivaldi Browser
    


  • @igull said in WebRTC & sleeping: disable Vs broadcast:

    ...
    If you have time could you test the following please? ...

    I tested in that manner at the Stackoverflow site and the results showed 'clean' with no WebRTC activity at all here. So, apparently, whatever is going on with your installation is not occurring with mine. In reviewing this thread a little closer, I did notice that you're apparently using 32-bit Vivaldi, whereas I'm using the 64-bit version... though I'm not sure if that should matter.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.