Vivaldi keeps crashing on 9gag, even when idling



  • Greetings!

    A problem with the recent update (1.14.1077.50 / Stable channel / 32-bit): it keeps crashing on 9gag.com when typing, scrolling, and just idling. It hasn't happened in years, but now it happens every few minutes, and only on that site – on main page, on pages with "gifs" and with static pics.


  • Moderator

    No crash here, but no surprise that the site uses a lot of CPU and RAM.

    0_1519147596180_Task Manager.png

    What are your system specs?


    Specs: AMD A10-6800K, 8 Gb on Win 10 64-bit • Snapshot 1.15.1099.3 (64-bit)



  • @pesala said in Vivaldi keeps crashing on 9gag, even when idling:

    No crash here, but no surprise that the site uses a lot of CPU and RAM. What are your system specs?


    Specs: AMD A10-6800K, 8 Gb on Win 10 64-bit • Snapshot 1.15.1099.3 (64-bit)

    No crash Laptop ACER Aspire 6930 Win 7 32 4Gb nVidia 9600m GT 1Gb Vivaldi last stable
    It does not even say goodbye to pages like the ones that come in the FWA.
    It must be other problems than memory or CPU


  • Moderator

    • Try disabling extensions
    • Show the Task Manager (Shift Escape) to see how much RAM and CPU is being used


  • MB: ASUS M4A87TD EVO / Socket AM3 / SATA 3 / USB 3.0 / PCI-E 2.0
    CPU: AMD Phenom II X4 / 970 / 3.5 GHz
    RAM: Kingston DDR3 / 8 Gb / 1'333 MHz
    GPU: Gigabyte N75TOC-2GI / Nvidia GeForce GTX 750 Ti OC / DDR5 2 Gb
    HDD (main): Seagate Barracuda 7200.10 / 160 Gb / SATA x2
    PSU: Enhance ATX-0260GA / 600 W / Active PFC

    Just like everyone else with similar problems, I have to point out that random and frequent crashing only became a problem after the most recent update, and the browser wasn't crashing like this since, I dunno, v0.8 or so.
    I'm using the browser for YouTube, Twitch and one online text editor for hours, but on 9gag it's crashing every 2-3 minutes.



  • Active load while on the site: 2 Gb RAM, 20-30% CPU.



  • Don't seems to crash here.
    Usage is around 130mb/260mb, CPU around 3% max without scrolling the page and with (most) 3rd party scripts blocked.
    Most sites with infinite scroll, video autoplay and several scripts (js) are prone to have performance issues



  • Now it's even worse: dead bird icon after scrolling through every 3-5 posts. Again, no peaks in RAM/CPU usage. Maybe it has something to do with the switch to WEBP format that has happened a couple of days ago…


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.