User-Agentを変更する拡張機能が効かない



  • 質問・雑談カテゴリにて質問(User-Agentの変更について)したのですが、なかなかレスが付かず、考えたらこれまでもChromeの拡張機能が動作しないものを不具合として報告されていたので、改めてこちらで報告します。
    上記トピックがきっかけで @sasara さんに「User-Agentによって停止?する」という不具合を報告して貰いましたが、また別の現象と思います。

    内容は上のトピックと変わらないのですが、
    User-Agent Switcher for Chrome
    この拡張機能で例えばChromeとVivaldi両方で全く同じiPhoneのUAに設定すると、Chromeで安定してスマートフォン用のページが表示されるサイトで、VivaldiではPC用サイトが表示されることがあります。
    サイトによってUA変更の効きやすさが異なってくるのですが、例えばGoogleはほぼスマートフォン用サイトが、Yahoo! JAPANはほぼPCサイトが表示されます。サイトによってはもっとまばらに効いたり効かなかったり。

    1.13までこのようなことはありませんでした。

    同等の機能を持った拡張機能をいくつか入れてみましたが同様でした。

     不具合を確認したVer.
     Vivaldi 1.14.1077.41 (Stable channel) (32-bit)
           1.14.1077.39 (公式ビルド) (64-bit)
           1.15.1090.3 (公式ビルド) (64-bit)
     Windows 10 (64-bit)


  • https://chrome.google.com/webstore/detail/user-agent-switcher-for-g/ffhkkpnppgnfaobgihpdblnhmmbodake?utm_source=chrome-ntp-icon
    こちらのuser agent switcher for google chromeはどうですか?
    普通に使えてますが試してみませんか?
    文字は似てますが別物です。
    chrome使ってても反映されないのも以前ありましたよ。



  • 最新のスナップショットで試してみたのですが、私の環境では、同じ「User-Agent Switcher for Google Chrome」は機能しませんでした。しかしもう1つの方のUA偽装拡張(特定のサイトでのみ機能するようにできる拡張「Custom UserAgent String」)は、どうやら機能してるようで、私は「AbemaTV」で『Chrome』に偽装してるのですが、そちらでは『Chrome』と認識されてるようでした。Chrome以外だと表示されるアラートが表示されなかったので。
    (※ちなみにAbemaTVは、日本国内以外からのアクセスだと、たぶん動画は見られない…かと。)

    使用環境:
    macOS High SIerra 10.13.3
    Vivaldi Snapshot 1.15.1090.3



  • これ書き込んだ数時間後に出た1.15.1094.3でどうやら直ったようです😅
    これかしら。
    [Regression] Broken (webRequest and localStorage) extensions (VB-36965)



  • @shimagi そうみたいですねぇ〜。他にも「直った」と言ってる方いるので、たぶん間違いないかと。 😃

    当該ツイート↓
    https://twitter.com/AKAMAGE/status/961992097413804032


  • Moderator

    @shimagi
    こっちではないでしょうか。
    Vivaldi does not start the UI with some --user-agent command line switches (VB-29162)



  • @kyu3a さん
    本当だ,直った(*‘∀‘)
    0_1518249157479_Vivaldi_1.15_UA_01.PNG



  • @zyxwj そっちは上にも書いた「User-Agentによって停止?する」の方で、UA変更が動作しない不具合が出る前の1.13でも再現しましたし、UIが出ないのとは別だと思ったのですが。
    やっぱり関連していたのでしょうか。うーん。
    まぁ直ったのでなんでもいいですけど😙



  • Windows版はすでに先日のアップデート(1.15.1094.3)で解消されたようですが、Mac版も今日リリースされた最新のスナップショット(1.15.1099.3)にアップデートしたところ、この問題が解消されてるのを確認しました。(^^)

    使用環境:
    macOS High Sierra 10.13.3


  • Moderator

    @shimagi @kyu3a @Ivarn @zyxwj @iinews

    お待たせしました!
    本件に関しては、一つ前のSnapshotにmacを除き修正が既に盛り込まれておりましたが、
    昨日公開となったSnapshot Snapshot 1.15.1099.3 にて、
    mac を含む全てのプラットフォームで修正が公開済みとなっております。
    是非お試しいただき、お気付きの点があればいつでもお知らせください :)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.