1.14.1077.41 Clicks do not work in some forums



  • I cannot use a lot of forums anymore, mouse clicks do not work. Sometimes the mouse focus is wrong too. And on some website I cannot log in anymore.

    All this since I updated from 1.13xxx to 1.14.1077.41

    Probably something with JavaScript is broken.


  • Moderator

    Edited your title as severly bugged is not very declarative.


  • Moderator

    Please explain more how to check or what your issue with the mouse is.



  • I noticed a similar issue on some sites. E.g. on tweakers.net my mouse was highlighting links two entries higher than I was hovering on and clicking did not register. Related, I saw some sites not reading on the first load, but working fine on the second.

    After twiddling around a bit, I noticed that retyping the URL in the address bar manually (instead of following a speed dial) fixed the issue for me. I also had to recreate some of my speed dials (even though the addresses seemed to be fine).

    @thrust26, does this "workaround" work for you too?

    Have speed dials and/or bookmarks changed in any way that could have caused them to go corrupt?



  • Same problem on confluence based wiki sites. How do I revert back to 1.13 stable? This is critical for me - I use Vivaldi stable at work and this update causes several of the main sites I need to no longer be usable.

    @Caine no, manually typing the URL does not solve the problem for me.


  • Moderator

    You all can not click or is the real focus shifted upwards from the position the mouse cursor is seen?

    I pinged one dev for this.
    Can you please tell us more about your installed extensions?
    And how ca we test that? Give us some steps.



  • Focus of the mouse appears to be several lines above where it actually is but neither clicking directly on the link or below the link where it looks like the focus is correct works. Clicking and dragging does begin text selection but not of what is expected based on cursor placement.

    I already tried disabling all extensions - no effect.

    I also uninstalled Vivaldi leaving user data then re-installing it. Same problem.


  • Moderator

    @fiernaq Yes, i knwo what you mean.
    Please, we need a description in some steps, how to reproduce it on the site where it fails.



  • @gwen-dragon I think this is probably in the system already under, or at least related to, VB-36810

    The bug as described sounds quite familiar, and I believe is known to the devs.



  • I located a couple of random confluence based wiki sites using google and attempted to duplicate the problem but it's not happening on them. This may be tied somehow to bookmarked sites.

    I can't even logout of the site because the logout button is at the very top-right of the page and hovering over it give me a focus indicator on the minimize button (outside the render window). Bringing the mouse down a bit gives me a focus indicator of the address bar (again, outside the render window despite the cursor being inside the webpage).



  • I've uploaded a Gif of the issue to imgur.

    It should show the problem well enough.


  • Moderator

    @fiernaq Yes, you are right. We had this in older Snapshots.


  • Moderator

    @fiernaq said in 1.14.1077.41 Clicks do not work in some forums:

    I located a couple of random confluence based wiki sites using google and attempted to duplicate the problem but it's not happening on them. This may be tied somehow to bookmarked sites.

    Yes.
    Sorry, but how can we test it? We (testing team) need more precise steps to reproduce it.



  • I tried bookmarking one of those random confluence wiki pages and even adding it to speed dial but couldn't duplicate the problem on it. The only site I'm currently aware of this issue happening on is not a public site so I can run tests for you but can't provide a link for you to test with.


  • Moderator

    @fiernaq It would actually be very helpful if you could outline, step by step, what it takes to trigger the bug on your system.



  • @xyzzy

    • Open browser
    • Navigate to site
    • Issue exists

    There aren't any fancy steps involved to replicate the problem. It always exists no matter which part of the site I navigate to which is why I initially thought it could be replicated on any confluence wiki site but that is apparently not true. I had been on the latest stable version of 1.13 prior to the update to 1.14 and it was working fine. Like @Gwen-Dragon said, we did have this issue before and it was solved although I don't remember what the version number was. I'm pretty sure I posted in the forums that time as well so you may be able to browse my fairly limited number of posts to find it.


  • Moderator

    @fiernaq I've also run into this issue as well and have been able to trigger it by opening bookmarks from either the Bookmark section of the Start Page or from the Bookmarks Panel. It also only seems to trigger on some sites for me but reproduces reliably; others can't trigger the bug on their systems no matter what they try.



  • I opened a different speed dial bookmark to a specific page in our confluence wiki and that one works fine right now. If I then manually type in the URL of the page I was originally attempting to use it works fine. Browsing through the wiki from this tab now seems to work.

    If I go back to the original site I opened the link to our wiki from and click that link the problem returns. If I then manually type the URL into this particular tab the same problem exists.

    The problem appears to get stuck to the tab. If you can open a new tab not affected by the problem then it doesn't occur. Not sure if that's very helpful but it's all the info I have.

    edit
    If I duplicate the original problem by clicking the link to open the wiki page in a new tab the problem exists on that tab. If I manually enter a new URL for the same wiki site but different pages in that wiki into the address bar the problem follows. If I manually enter a URL for a different site the problem goes away. If I then hit the back button the problem returns. If I create a new tab and manually put in the URL of the specific wiki page that had the problem the problem does not exist. I can navigate around without issue from that tab.


  • Moderator

    @fiernaq Thanks very much. Any details (or step-by-step) instructions that anyone can provide to trigger this would be very helpful.

    For me it occurs when opening a bookmark in a new tab. However, the bug doesn't trigger if I open a new tab, then open a bookmark via the Bookmark Bar; only from the Start Page or from the Panel.



  • I already reverted back to the last 1.13 version because I couldn't continue this way. But my problem was exactly as described here.

    E.g. one forum where the mouse focus issues happened was:
    https://www.heise.de/forum/heise-online/News-Kommentare/Wegen-Cheatings-Gamer-verliert-aeltesten-bestehenden-Videospiel-Rekord/forum-396316/page-4/
    Click on '+' to open the thread. Then hover over the answers and to click one. The hovering is focusing the wrong lines and the click doesn't work (or is unreliable).


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.