[Snapshot 1.14.1077.3] Specific YouTube videos don't play, others play fine



  • These videos:

    https://www.youtube.com/watch?v=-hgIYrCwTdo
    https://www.youtube.com/watch?v=jM2wzd1A0Jk

    don't play for me with the message:

    Your browser does not currently recognise any of the video formats available.

    ALL other videos I've encountered today worked just fine. (I've installed libffmpeg.so as per this blog entry.)

    Here are the YouTube problem details:

    {
      "ns": "yt",
      "el": "detailpage",
      "cpn": "V5lbIsLht7qWB-5x",
      "docid": "-hgIYrCwTdo",
      "ver": 2,
      "cmt": "0",
      "plid": "AAVjeBNjOOhID97v",
      "ei": "b6ZnWsnEL4fY1gKhr7HICw",
      "fs": "0",
      "rt": "7.183",
      "of": "th9IsO8dcL-r1mBVmNYQ4g",
      "euri": "",
      "lact": 2,
      "cl": "182751999",
      "mos": 0,
      "state": "80",
      "vm": "CAEQARgE",
      "volume": 100,
      "subscribed": "1",
      "c": "WEB",
      "cver": "2.20180122",
      "cplayer": "UNIPLAYER",
      "cbr": "Chrome",
      "cbrver": "64.0.3282.97",
      "cos": "X11",
      "hl": "en_GB",
      "cr": "DE",
      "len": "1159",
      "fexp": "23704842,23708158,23708904,23708906,23708910,23710476,23710861,23711274,23712392,23713238,23713321,23713711,23714105,23715611,23716971,23718466,23718793,23719066,23719519,23719526,23720102,23721898,23722568,9422596,9431754,9449243,9471235,9480775,9485000",
      "vct": "0.000",
      "vd": "NaN",
      "vpl": "",
      "vbu": "",
      "vpa": "true",
      "vsk": "false",
      "ven": "false",
      "vpr": "1",
      "vrs": "0",
      "vns": "0",
      "vec": "null",
      "vvol": "0.5022847616121362",
      "debug_error": {
        "errorCode": "fmt.noneavailable",
        "errorDetail": "nosupported.1;a.1;d.0;f18.1;c18.0;f43.0;c43.1;f133.1;f140.1",
        "message": "This video format is not supported.",
        "messageKey": "YTP_HTML5_NO_AVAILABLE_FORMATS_FALLBACK"
      },
      "prerolls": "ad",
      "ismb": 4860000,
      "relative_loudness": "5.981",
      "user_qual": "auto",
      "debug_videoId": "-hgIYrCwTdo",
      "0sz": false,
      "op": "",
      "yof": true,
      "dis": "",
      "gpu": "AMD_RV730_(DRM_2.50.0_/_4.13.0-31-generic,_LLVM_5.0.0)",
      "cgr": true,
      "debug_playbackQuality": "unknown",
      "debug_date": "Tue Jan 23 2018 22:17:43 GMT+0100 (CET)"
    }
    

    I'm not sure if this is related, but I've also noticed that this gifv doesn't play:

    https://i.imgur.com/IVEl1WI.gifv

    Whereas e.g. this one plays fine:

    http://i.imgur.com/mwf28dW.gifv

    This is on Ubuntu 17.10 with today's updates.



  • I'm seeing the same bug on Ubuntu 17.10 too.
    Vivaldi 1.13.1008.44
    The links you posted work for me but others don't.
    The do work on Firefox.



  • FYI, they both play fine for me, but i updated my V to 1.15.1089.3 prior to seeing your post, ie, i have not tested them with your V-SS version. Can you update then retest?



  • I can see the first here (not tested the second) though I do have problems with some videos (not on youtube)

    Vivaldi 1.13.1008.30 (Official Build) snapshot (64-bit)
    OS Linux
    JavaScript V8 6.2.414.43
    Flash 999.999.999.999 /usr/lib64/chromium/PepperFlash/libpepflashplayer.so


  • Moderator

    Snapshot 1.14 uses a older codec package.

    You should update Vivaldi to 1.15 Snapshot and chromium-codecs-ffmpeg-extra package to 64.0.3282.119



  • @gwen-dragon said:

    You should update Vivaldi to 1.15 Snapshot and chromium-codecs-ffmpeg-extra package to 64.0.3282.119

    Were you talking to me? (not you fault, but communication on these foruns are quite bad, most people talk "to the air" and hope readers guess about what and to who... maybe I am too much "last millennia"? :-) Surely that is why I stopped coming here often - OK, rant done, sorry, again, it is not you, thanks for helping)

    I already had updated to 1.15.1089.3 (Official Build) snapshot (64-bit), then upon reading this I installed (not upgraded) chromium-ffmpeg-extra (not chromium-codecs-ffmpeg-extra) version 61(not 64, because that is what some of the repositories I use has available). And restarted Vivaldi.

    I know, that is a lot of things not exactly what you advised, still close enough to try, so I did. To no visible effect. The about Vivaldi page still says Flash 999.999.999.999 /usr/lib64/chromium/PepperFlash/libpepflashplayer.so and some videos - e.g. IMdB's trailers - still do not play, but they do if I use Firefox.


  • Moderator

    @rkzn My hint was for all users of older Snapshots.

    The older snapshots 1.14 use other libffmpeg version as the newer 1.15 ones.


  • Moderator

    Closed.
    Please open a new thread for Snapshot 1.15 on Linux with video issue.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.