Dies ist keine sichere Verbindung bei web.de, gmx.de, dwd.de



  • Bei Aufruf von z.B. https://web.de bekomme ich folgende Mitteilung zu lesen:

    Dies ist keine sichere Verbindung

    Hacker könnten versuchen, Ihre Daten von web.de zu stehen, zum Beispiel Passwörter, Nachrichten oder Kreditkartendaten. Weitere Informationen
    NET::ERR_CERT_AUTHORITY_INVALID

    ERWEITERT ... NEU LADEN

    Analog bei den anderen genannten Seiten.

    Was läuft da falsch?

    Eine gleichlautende Meldung gab es anfangs auch bei google.de. Dies konnte ich durch leeren des DNS-Caches mit dem Befehl "ipconfig /flushdns" lösen.

    Selbst vivaldi.com lieferte zunächst eine ähnliche Fehlermeldung. Dort konnte ich aber mit einer Schaltfläche die Seite trotzdem aufrufen.

    System:
    Windows 7 Pro inkl. Updates bis November 2017
    Vivaldi 1.13.1008.32 32-bit
    Uhrzeit und Datum korrekt



  • Ich sehe keinerlei von diesen Warnungen, ebenfalls Win 7 32 und Vivaldi gestern actualisiert 1.13.100834 32.
    Versuchs mal mit der Quad9 DNS



  • Ein Wechsel des DNS-Servers löst keine Probleme mit den Zertifikaten.



  • Ok, war nur eine Idee. Ich kann das Problem nur nicht nachvollziehen, da ich ohne jegliche Warnhinweise die Seiten benutzen kann. Es muss also an irendeiner Erweiterung, Einstellung oder ähnlichem liegen.



  • Virenscanner/Desktopfirewall/Hardware-Firewall verfälscht die Zertifikate beim Scan über SSL.

    Drück mal in Vivaldi F12 und schau mal was bei dem Tab Security kommt.

    The connection to this site is using a valid, trusted server certificate issued by TeleSec ServerPass DE-2.
    Secure connection
    The connection to this site is encrypted and authenticated using TLS 1.2 (a strong protocol), ECDHE_RSA with P-256 (a strong key exchange), and AES_256_GCM (a strong cipher).
    Secure resources
    All resources on this page are served securely.

    Du kannst auch in der Adresszeile vivaldi://flags/#show-cert-linköffnen, da auf Aktivieren stellen, Vivaldi neu starten. Danach kannst du beim Klick auf das grüne Schloss bei Zertifikat sehen ob das Zertifiakt passt.



  • @gwen-dragon said in Dies ist keine sichere Verbindung bei web.de, gmx.de, dwd.de:

    Du kannst auch in der Adresszeile vivaldi://flags/#show-cert-linköffnen, da auf Aktivieren stellen, Vivaldi neu starten. Danach kannst du beim Klick auf das grüne Schloss bei Zertifikat sehen ob das Zertifiakt passt.

    Mit Aktivierung von "Show certificate link" sehe ich bei web.de ein offenes rotes Schloss rechts in der Adressleiste. In den Informationen dazu finde ich: "Zertifikat ungültig".

    F12 auf web.de fördert im Bereich "Security" folgenden Fehler zutage:

    Certificate error
    There are issues with the site's certificate chain (net::ERR_CERT_AUTHORITY_INVALID).

    Übrigens funktionieren die Seiten in Firefox 57.01 und Opera 12.18 aber nicht im IE 11.0.38.

    Es liegt wohl an einer Windows-Einstellung. Firewall ist deaktiviert, ebenso die Erweiterungen von Vivaldi.



  • Deine Zertifikate im Windows sind nicht aktuell.
    Vivaldi wie auch Chromium oder neuere Operas nutzen die von Windows.



  • Ursache gefunden, Problem gelöst

    Ich hatte zunächst gedacht, dass die Zertifikate immer von den Websites an die Browser übermittelt werden und somit auch die Lösung des Problems bei den Browsereinstellungen zu suchen ist.

    Ich habe dann in Windows Foren gesucht und mit dem Befehl "certmgr.msc" den Zertifikatsmanager aufgerufen. Unter den "Vertrauenswürdigen Stammzertifizierungsstellen" wurden nur 29 Zertifikate angezeigt. Mit der im Netz gefundenen Datei "rootupd.exe" und dem Parameter /Q wurde dann die Liste auf 361 Zertifikate aktualisiert.

    Mein Fehler war eine übereifrige Einstellung im Programm XPAntispy nach der Installation von Windows 7. Dort hatte ich das automatische Update von Stammzertifikaten deaktiviert. Aufgefallen ist das erst jetzt, da ich zuvor noch mit Opera 12 und Firefox gearbeitet habe und dort keine Probleme auftraten.

    Danke für Hinweise, die mich auf den richtigen Weg gebracht haben.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.