ウィンドウを閉じて再度起動したとき、タブが復元されません。



  • ver.1.13.1008.32

    タイトルの通り、ウィンドウを閉じて再度起動したとき、タブが復元されません。
    設定はもちろん、「起動時に開くページ」を、最後のセクションにしています。
    まだ、この状態であれば、shift+ctrl+tで復元出来ますが、
    PCの電源を落とすと、完全にタブ情報が失われます。


  • Moderator

    @krntkmn
    vivaldi 及びOSのbit数含む環境を明記ください。



  • Windows7 Professional 64bit
    です。


  • Moderator

    @krntkmn vivaldiも64bit版でしょうか?



  • vivaldiは32bit版でした。



  • いろいろ試行錯誤した結果、
    バックグラウンドで動作しないように設定を変更したら
    この現象が起きなくなりました。


  • Moderator

    @krntkmn
    windows7が無いので手元の64bit版のWindows10で32bitのvivaldiインストールして検証しました、ブラウザ終了させてPC再起動、ブラウザ開いたまま再起動、電源終了しても再現できませんでした。

    バックグラウンドで動作しないように設定を変更したら
    この現象が起きなくなりました。

    バックグラウンドの動作しない設定とは、vivaldiの設定画面で見つけられなかったのですが、こちらの設定の事でしょうか?

    0_1511599433737_43afaa4f-d5f7-4269-b4e8-bc0b39e294b1.png



  • 多分その設定だと思います。
    自分は、通知領域アイコンから設定をOFFにしました。


  • Vivaldi Translator

    1台のPCにWindows7と10をデュアルブートにしています。
    BIOSでブートドライブを変更してWin7を起動し、Vivaldi 1.13.1008.32(32bit)を新規でクリーンインストール。
    新規インストールですが一応確認してみたところ、

    • Vivaldiを閉じた際にバックグラウンドアプリの処理を続行する>ON
    • ハードウェアアクセラレーションが使用可能な場合は使用する。>ON

    であることをを確認。

    • 環境
      Win7 Pro 64bit Service Pack 1
      C:の空き容量 226GB/システム73GB (総容量:約299.7GB)
      メモリー32GB
      仮想メモリー設定 最大2048MB-最小2048MB(C: 直下に作成)
      グラフィック:Intel HDGraphics 4000 (オンボード)
      Vivaldiのインストール先:C:\Users\ユーザー名\AppData\Local\Vivaldi
      ※拡張機能は入れていませんが、Flash Playerはインストール済みです。

    検証条件

    1. 4つほどタブを開いて実行してみて終了させる。
    2. install Per User とスタンドアロンインストールの2つで検証(All Userは未検証)
    • PCを再起動してみましたが再現できませんでした。
    • PCをシャットダウンしてみましたが再現できませんでした。
    • PCをシャットダウン後に、電源ユニット自体をOFFにする。その後にPCの電源をON/OFFさせて完全放電させた後で電源ユニットをON PCに電源をONにして通常起動してみましたが再現できませんでした。

    以上、簡単な報告まで。

    • Win7 システム情報
      0_1511735654982_Win7 Pro 64Bit SP1.jpg

    • Vivaldi 初期状態のまま(設定は何も触らず。)
      0_1511735618117_vivaldi設定1.jpg


  • Vivaldi Team

    @krntkmn

    ご報告ありがとうございます。
    Windows7にて確認を試みましたが、再現はできませんでした。
    引き続きモニタリングを行ってみます。
    通知領域より上記設定をオフにしたとのことですが、
    常にオンオフの切り替えがそこからできますか?



  • @ahojo
    私はWindow8.1ですがこの現象は起きますよ。



  • This post is deleted!


  • Windows10bit使用しています。
    私の環境でも再現します。
    Windowの右上のバツ印、もしくはAlt+F4の「閉じる」操作で終了すると、次の起動時にはセッションが再現されずに、Start Pageのみが表示されます。
    しかしながら、Vマークからメニューの中の「ファイル」-「終了(X)」から終了させると、次の起動時にはちゃんと最後のセッションが保持されて起動しました。

    使用バージョンは以下の通りです。

    Vivaldi 1.13.1008.34 (Stable channel) (32-bit)
    変更履歴 b6fccac0c52b4c99d9e782ecd46c3537fbea1b28-
    OS Windows
    JavaScript V8 6.2.414.43
    Flash 27.0.0.187 C:\WINDOWS\SysWOW64\Macromed\Flash\pepflashplayer32_27_0_0_187.dll
    ユーザーエージェント Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.97 Safari/537.36 Vivaldi/1.94.1008.34
    コマンドライン "C:\Users*7*\AppData\Local\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --enable-blink-features=ResizeObserver --ppapi-flash-path="C:\WINDOWS\SysWOW64\Macromed\Flash\pepflashplayer32_27_0_0_187.dll" --flag-switches-begin --flag-switches-end
    実行ファイルのパス C:\Users*7*\AppData\Local\Vivaldi\Application\vivaldi.exe
    プロファイルのパス C:\Users*7*\AppData\Local\Vivaldi\User Data\Default
    Compiler MSVC 2015


  • Moderator

    @ddd_vivaldi
    詳細情報の提示ありがとうございます。
    windows10のところがbitだけになっていますがsyswow64のフォルダーがあるので64bitですね。

    スレッドを立てた方も64bitOSで32bitを使ってらっしゃる点が共通点で少し気になりました。

    64bit版vivaldiにアップデートしても改善しませんでしょうか?
    https://downloads.vivaldi.com/stable/Vivaldi.1.13.1008.34.x64.exe

    セッション不良のユーザーさんは昔から一定数いらっしゃって出出ない人と出る人がいて原因がわかりにくい不具合なので、ハードウェアの相性が無いとも言えません、お手数ですがPCのスペックをわかる範囲で結構ですので教えていただけますでしょうか。

    【PC環境】
    PC型番メーカー及び製品名:(自作の場合は自作)
    プロセッサー(CPU)名:
    実装RAM(メモリサイズ):
    グラフィックボード型番:
    vivaldiをインストールしているドライブの容量:HDDまたはSSD



  • Windows10 64bit環境ですが発生します。
    Ver 1.13.1008.34 64bitで事象が発生したため、1.11.917.43に戻したところ事象は発生しません。

    具体的な再現方法は不明ですが、ゲームなどをプレイしながら動画やwikiなどを閲覧して、
    ゲーム終了後、Vivaldiを終了してすぐに再起動させるとスタートページのみで起動してきます。

    OS:Windows10 Pro 64bit
    Vivaldi:1.13.1008.34 64bit
    PC:自作
    CPU:Intel Core i7 Extreme 980X
    メモリ:24GB
    GPU:ASUS GeForce GTX 980x2(SLI)
    Vivaldiインストールドライブ:SSD(C:)空き容量は約56GB


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.