[Solved] - Screenshot not working (Debian Stretch fvwm)



  • If I click on the camera icon in the status line and then
    Full Page -> Save as PNG -> Capture Page
    an error window pops up: 0_1511047429937_pic_04.png
    On linux mint the screenshot tool works fine, so I think something is missing in my environment. I am using the fvwm window manager (no GNOME, no KDE).
    Any ideas what is missing?



  • Please tell me, which Linux distribution and fwm version do you have?
    I like to check it on my Linux.

    Works on my Ubuntu 16 LTS | XFCE 4.12 | xfwm 4.12.3 with latest Vivaldi 1.12 and 1.13 Snapshot.
    Saves the screenshot on my Linux to ~/Pictures/Vivaldi Snapshots

    What happens if you start in a terminal/shell?
    vivaldi



  • @gwen-dragon I'm using
    Debian GNU/Linux 9 (stretch) and fvwm 1:2.6.7-3.
    When I start vivaldi from a terminal, I see the following error message:

    ERROR dbus-server.cc:865 [dbus_server_init]: D-Bus error: Unknown or unsupported transport 'disabled' for address 'disabled:'
    ERROR util.cc:295 [audgui_simple_message]: No files found.

    The screenshot will be saved in ~/Pictures/Vivaldi Captures/ but at the same time the error popup appears my standard audio player (audacious) is opened! So if I take 10 screenshots, audacious was opened 10 times too! So I think it's a dbus problem with vivaldi, but I don't know how to fix it.



  • @afrie Tested now with Debian 9 KDE 5 Plasma and/or XFCE. and Audacious installed. Can not reproduce your issue. :(

    Did it work before for your with older Vivaldi 1.13 versions?

    @afrie said in Screenshot not working on debian stretch with fvwm:

    The screenshot will be saved in ~/Pictures/Vivaldi Captures/ but at the same time the error popup appears my standard audio player (audacious) is opened! So if I take 10 screenshots, audacious was opened 10 times too!

    Really strange.
    Audacious looks in the background for changed files to play? Or is it registered to PNG or JPEG files?

    when this happens any errors in log of:

    • syslog
    • audacious

  • Moderator

    The capture page is working fine.

    @afrie said in Screenshot not working (Debian Stretch fvwm):

    ... but at the same time the error popup appears my standard audio player (audacious) is opened!

    Really strange. It seems Twilight Zone.
    Try starting Vivaldi from shell:

    vivaldi-snapshot --user-data-dir="/tmp/TEST-VIV" &
    or
    vivaldi-stable --user-data-dir="/tmp/TEST-VIV" &



  • @lamarca I've tried both - same dbus error.


  • Moderator

    @afrie dbus has some nasty issues.



  • @lamarca I've tried it again on another linux mint system with Xfce running and find out that after storing the screenshots a file manager (thunar) is openend.

    I think that's the problem, because on my system I have no file manager installed and therefore the default audio player is opened.

    Is there a way to disable the call of the file manager in vivaldi? If not, a configuration option would be nice.



  • @afrie ... or a better solution: Maybe vivaldi can check if a file manager is available before calling it.


  • Moderator

    @afrie For me the Capture Page opens my image viewer (Mirage). It could be relate to MIME types.



  • @lamarca Yes you are right.
    After the screenshot was stored, vivaldi calls an application which was defined for the mime type inode/directory. The default application for this type is the music player audacious on my system (which is wrong - don't know why):

    xdg-mime query default inode/directory
    audacious.desktop

    Workaround:
    Because I have no file manager installed (and don't want to have one), there is no application which could handle inode/directory. So I created a "null" application which does nothing:

    vi ~/.local/share/applications/null_application.desktop
    [Desktop Entry]
    Version=1.0
    Type=Application
    Exec=true
    TryExec=true
    StartupNotify=true
    Terminal=false
    MimeType=inode/directory;

    Then override the default for "inode/directory":

    vi ~/.local/share/applications/mimeapps.list
    [Default Applications]
    inode/directory=null_application.desktop

    Now, nothing happens after the screenshot was stored. Maybe this helps someone.


  • Moderator

    Glad to know. In this case, dbus is not guilty:)

    @afrie said in Screenshot not working (Debian Stretch fvwm):

    ....... Maybe this helps someone.

    I will tag your post as Resolved.



  • @afrie said in Screenshot not working (Debian Stretch fvwm):

    Maybe vivaldi can check if a file manager is available before calling it

    It is a broken Linux Desktop installation. I cant remember at all over the years where a Linux Desktop has no file manager.


    If you think a feature is useful and missing in Vivaldi, please make a request.

    How to make a feature request for Vivaldi
    If you think your problem can be solved by a missing feature, please add each request at https://forum.vivaldi.net/category/48/features-requests in the corresponding thread for your browser version.
    Add one line in bold as a short title for the feature and 2-3 lines to describe the wanted feature.




  • @gwen-dragon Oh no no no, there is nothing broken.

    Debian allows you to set up a small system which can be configured at your needs. I know many people like me, which are working on command line and don't want a full featured desktop environment!

    In my opinion it is not the task of a browser to call a file manager GUI automatically after a screenshot was saved. I know no other browser which does something like that. Why is no file manager called after a download was finished? It's a similar situation.

    Thank you for the feature hint but I don't think a feature is missing in Vivaldi, I think this feature should be removed.



  • @afrie said in [Solved] - Screenshot not working (Debian Stretch fvwm):

    I think this feature should be removed

    It's better if it's customizable, what if one wants to see the snapshots directory?



  • @afrie said in [Solved] - Screenshot not working (Debian Stretch fvwm):

    I think this feature should be removed.

    Then you think it is a bug? Please report.


    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug separate at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    If you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bug tracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!



Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.