How to open Slack site correctly from Vivaldi browser?



  • Hello,
    I'm trying to open Slack group chat in Vivaldi browser on Windows 7 SP1.
    When opening it loads the group chat but refuses to open sidebar with list of channels. After a minute Slack tells me it couldn't load all necessary resources. Text of the error:

    Connection trouble
    Apologies, we’re having some trouble with your WebSocket connection.

    We’ve seen this problem clear up with a restart of your browser, a solution which we suggest to you now only with great regret and self-loathing.

    When I open Developer Tools > Security I see that it tells "The page is insecure (Broken HTTPS)", and it lists several resources starting from wss protocol:

    https://imgur.com/a/TD0tC

    The error there is
    WebSocket connection to 'wss://resource name' failed: WebSocket opening handshake was canceled.
    [SOCKET-MANAGER] Closing socket due to unknown error

    I went through all the other links it blocked from downloading and enabled them to be downloaded by opening menu More and letting browser to open the link (btw it lists slack.com in the canceled sites but it can be opened just fine). However due to wss protocol the rest of the links can't be opened like usual links and I don't know where are they stored.

    How can I enable this browser to download resources for the site which I do know for sure is secure?



  • Slack and Websockets works with Vivaldi.

    Your problem is a bad server certificate for the connection.



  • @gwen-dragon if I open Slack certificate in the Security tab it tells me that certificate is valid.
    What else can I do to tell Vivaldi this certifacte is ok? It isn't my certificate after all.

    I'm pretty sure Vivaldi works with Slack, however afaik Chromium rejects http sites from loading resources as insecure. The only way I'm aware is to load those sites manually to make Vivaldi skip secure check.

    I didn't do anything other than installing Vivaldi and loading Slack.



  • No, the problem is the certificate transparancy policy of a domain is not available and that's why Chromium blocks the websocket over SSL.
    Looks like certifcate authority (signer of cert) is known as insecure.


    !!! On own risk !!!
    as it ignores problems with all certificates
    Try to start Vivaldi only for the chat with vivaldi.exe --ignore-certificate-errors



  • @gwen-dragon yes, in Vivaldi executed with that command Slack opens up just fine.

    Certificate is told to be given to Slack by GeoTrust SSL CA - G3, valid until 02.02.2019. Certificate to GeoTrust SSL CA - G3 is given by GeoTrust Global CA, valid until May 2022. I can provide screenshot but the interface is in Russian, I'm afraid it won't be convenient.



  • @zanxer The distrust of some certificates of Symantec and its subsidaries, GeoTrust, RapidSSL and Thawte CA was announced more than 9 months long ago.
    That was done by Chromium devs and Google because theses certificat signers did not show transparency on their certificate creation processes and they did create fraudulent certificates in the past.
    And the certificate authorities Symantec, GeoTrust, RapidSSL and Thawte should have contacted their customers for a change/renewal.

    The fault ist at the server admins and webmasters which provide your chat, the did not renew their certificates. Bad Admins and Webmasters from hell!



  • @gwen-dragon so as I understand no way to workaround or solve the problem other than waiting if GeoTrust admins do something with their certificates and give Slack renewed one? (or running Vivaldi from command line with parameters you gave to enter SLack chat)
    Btw thank you for your support, didn't tell that earlier.



  • @zanxer You can run only the Slack chat with a desktop shortcut having this
    vivaldi.exe --vivaldi.exe --ignore-certificate-errors https://yourchatadress…slack.com/ as target in its property.

    As is said: it is a risk to lower the trust to all certificates with errors by such commandline.
    Do not use the browser for logins, mail reading, money transfer etc.



  • Really strange, but with 1.13 and Windows 10 on internal Vivaldi Slack chat is all ok, i do not get Websocket problem with certificates wss://mpmulti-zjec.lb.slack-msgs.com/?flannel=2&token=xoxs-2318987732-……-d4… .

    So it must be your very old Windows 7 having problems with outdated Root CA Certificates.

    Vivaldi browser uses the ones from Windows to establish a secure connection.

    You could download newer CA certificates from Symantec, GeoTrust, RapidSSL, Thawte CA and add them to Windows 7 Root CA certificates Store.





  • @gwen-dragon ok thanks for the information, good to know.
    One more reason to hate new technology which doesn't accept backwards compatibility (I know why it is like it is). I can't update OS now, I will see what could be done.





  • This indeed worked.
    Although not like I expected, e.g. I thought importing them into Certifcates Snap-In however they didn't want to renew (and their expiration date hasn't come yet surprisingly).
    It worked via direct importing in the Vivaldi settings.
    I pressed Lock button to the left from the address bar with the issued site opened already (Slack), found Site Settings link and in the opened window opened Privacy And Security rollout > Manage Certificates.
    Great thanks for the help.



  • @zanxer Thanks for your positive feedback that importing the CA certificates mentioned by me resolved your problem.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.