Crashing/Problem with Twitch.tv?



  • I watch twitch regularly. This has been happening recently, and I don't know what it means:

    https://i.imgur.com/5Odx2mJ.png

    Using HTML5 player.





  • Appreciated. thank you



  • @Gwen-Dragon Looking at the other threads related to this problem, I have HTML5 player enabled. I've tried both and enabling disable-accelerated-video-decode vivaldi://flags/#ignore-gpu-blacklist

    this is my content of vivaldi://gpu

    https://pastebin.com/JippW0uC


  • Moderator

    svanhildr, please tell us:

    • which Vivaldi version
    • which CPU/Chipset/graphics hardware


  • Vivaldi 1.12.955.48 (Stable channel) (64-bit)
    Revision d008b6490dacb4042ddcb6b145f9d223032d4697-
    JavaScript V8 6.1.534.41
    Flash 27.0.0.183 C:\Windows\system32\Macromed\Flash\pepflashplayer64_27_0_0_183.dll
    User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.102 Safari/537.36 Vivaldi/1.93.955.48
    Command Line "C:\Users\Rob\AppData\Local\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --enable-blink-features=ResizeObserver --ppapi-flash-path="C:\Windows\system32\Macromed\Flash\pepflashplayer64_27_0_0_183.dll" --flag-switches-begin --disable-accelerated-video-decode --ignore-gpu-blacklist --flag-switches-end

    I have a Intel i7-5820K running at default clock of 3.3GHz - X99 Chipset - and my gpu is an MSI GeForce GTX 980ti Gaming 6G - current drivers 388.15, however its happened on previous driver versions

    If you want more system information I can take an msinfo and dxdiag and upload



  • @svanhildr Just tried Twitch.Tv on my Vivaldi (Win 10)

    Vivaldi 1.12.955.48 (Stable channel) (32-bit)
    Revision d008b6490dacb4042ddcb6b145f9d223032d4697-
    JavaScript V8 6.1.534.41
    Flash 27.0.0.183

    No crashes for me (tried 4 different streams) - but I'm not logged in there.

    My command line options are

    --flag-switches-begin --disable-accelerated-2d-canvas --enable-cloud-print-xps --enable-gpu-rasterization --enable-print-preview-register-promos --wallet-service-use-sandbox=0 --flag-switches-end

    And my gpu output is

    Canvas: Software only. Hardware acceleration disabled
    CheckerImaging: Disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Hardware accelerated
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated

    My system has Nvidia GTX 640 - not as powerful as yours; but not disabled, wonder why yours is??


  • Moderator

    @svanhildr Please try disable internal Intel GPU in BIOS and only use external GeForce.



  • @gwen-dragon 5820k has no builtin graphics and uefi shows no option for that.


  • Moderator

    @svanhildr said in Not sure what this means - Crashing/Problem with Twitch.tv?:

    has no builtin graphics

    Oh yes, my fault. I see now in specs for chipset that it has no internal GPU.


  • Moderator

    in bugtracker i saw some crashing of tabs after a while.



  • Sort of Grave-Digging, but same problem surfaced again. This problem stopped for quite a while, completely forget it existed.

    I am trying to see go through these threads again to see if I can come back to the fix if there is a specific thing that does fix it.

    Current Info: (For Refence if I find a solution)

    Vivaldi 1.13.1008.34 (Stable channel) (64-bit)
    Revision b6fccac0c52b4c99d9e782ecd46c3537fbea1b28-
    OS Windows
    JavaScript V8 6.2.414.43
    Flash (Disabled)
    User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.97 Safari/537.36 Vivaldi/1.94.1008.34
    Command Line "C:\Users\Rob\AppData\Local\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --enable-blink-features=ResizeObserver --flag-switches-begin --ignore-gpu-blacklist --flag-switches-end
    Executable Path C:\Users\Rob\AppData\Local\Vivaldi\Application\vivaldi.exe
    Profile Path C:\Users\Rob\AppData\Local\Vivaldi\User Data\Default
    Compiler MSVC 2015

    And Vivaldi://gpu:
    Graphics Feature Status
    Canvas: Software only, hardware acceleration unavailable
    CheckerImaging: Disabled
    Flash: Software only, hardware acceleration unavailable
    Flash Stage3D: Software only, hardware acceleration unavailable
    Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
    Compositing: Software only, hardware acceleration unavailable
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only, hardware acceleration unavailable
    Video Decode: Software only, hardware acceleration unavailable
    Video Encode: Software only, hardware acceleration unavailable
    WebGL: Hardware accelerated but at reduced performance
    WebGL2: Unavailable
    Problems Detected
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers
    Checker-imaging has been disabled via finch trial or the command line.
    Disabled Features: checker_imaging
    Version Information
    Data exported 12/9/2017, 11:13:41 PM
    Chrome version Chrome/62.0.3202.97
    Operating system Windows NT 10.0.16299
    Software rendering list version 0
    Driver bug list version 10.30
    ANGLE commit id unknown hash
    2D graphics backend Skia/62 e74b41c6c84638d5a9ee6d254a715bcd9e17c603-
    Command Line "C:\Users\Rob\AppData\Local\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --enable-blink-features=ResizeObserver --flag-switches-begin --ignore-gpu-blacklist --flag-switches-end
    Driver Information
    Initialization time 0
    In-process GPU true
    Passthrough Command Decoder false
    Supports overlays false
    Sandboxed false
    GPU0 VENDOR = 0x10de, DEVICE= 0x17c8
    Optimus false
    Optimus false
    AMD switchable false
    Desktop compositing Aero Glass
    Diagonal Monitor Size of \.\DISPLAY1 23.9"
    Driver vendor Google Inc.
    Driver version 3.3.0.2
    Driver date 2017/04/07
    Pixel shader version 3.0
    Vertex shader version 3.0
    Max. MSAA samples 4
    Machine model name
    Machine model version
    GL_VENDOR Google Inc.
    GL_RENDERER Google SwiftShader
    GL_VERSION OpenGL ES 2.0 SwiftShader
    GL_EXTENSIONS
    Disabled Extensions
    Window system binding vendor
    Window system binding version
    Window system binding extensions
    Direct rendering Yes
    Reset notification strategy 0x0000
    GPU process crash count 0
    Compositor Information
    Tile Update Mode One-copy
    Partial Raster Enabled
    GpuMemoryBuffers Status
    ATC Software only
    ATCIA Software only
    DXT1 Software only
    DXT5 Software only
    ETC1 Software only
    R_8 Software only
    R_16 Software only
    RG_88 Software only
    BGR_565 Software only
    RGBA_4444 Software only
    RGBX_8888 Software only
    RGBA_8888 Software only
    BGRX_8888 Software only
    BGRA_8888 Software only
    RGBA_F16 Software only
    YVU_420 Software only
    YUV_420_BIPLANAR Software only
    UYVY_422 Software only

    I just flipped "vivaldi://flags/#ignore-gpu-blacklist" - see how that goes.



  • Same issue here. Only happens after a while and not in the first ~30 mins of watching.
    Using HTML5 player and Vivaldi snapshost 1.14.1036.3 (Official Build) (64-bit)



  • @svanhildr said in Crashing/Problem with Twitch.tv?:

    Vivaldi 1.13.1008.34 (Stable channel) (64-bit)
    Command Line "C:\Users\Rob\AppData\Local\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --enable-blink-features=ResizeObserver --flag-switches-begin --ignore-gpu-blacklist --flag-switches-end

    I just flipped "vivaldi://flags/#ignore-gpu-blacklist" - see how that goes.

    I don't know where the problem is, however you had already activated the flag, but this had no effect as under vivaldi://gpu everything shows

    Software only, hardware acceleration unavailable

    Which GPU are you using?

    GPU0 VENDOR = 0x10de, DEVICE= 0x17c8
    GL_VENDOR Google Inc.

    0x10de is same as mine, so NVIDIA but not sure which device and the browser is not using it and using the software Google driver.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.