British English language option



  • I have just crossed over to Vivaldi and am enjoying using it, with one glaring exception. The language option is English-English. What this actually means is American English. Most people probably aren't bothered but, as someone who is concerned about the use and abuse of grammar in the internet age, having the UK spellings highlighted as an error, when I know they are not, is extremely irritating. As I've previously indicated, I'm new to Vivaldi, though I'm no computer newbie as I've been using computers since Windows 3. If other programmes and apps can apply language options, of which I consider British English to be quite important, is Vivaldi going to offer this any time soon? Do these messages get viewed by Vivaldi's programming team for potential inclusion?



  • @altissimma That's odd as my installation, although it has American English installed, is set to use British English by default. What happens if you type in the address bar the URL chrome://settings/languages and try changing those settings?



  • open chrome://settings/languages
    add English UK as language
    remove English US
    in 3-dot-menu set to show UI in English UK.



  • @gwen-dragon said in British English language option:

    chrome://settings/languages

    Some issues here...

    I abhor US "English" -- Z's where there's supposed to be S's, an almost manic prohibition on U's where they're supposed to coexist with O's -- & in all my browsers one of the first adjustments i make is to select a proper English.

    Despite your advice here, it's tragically not possible to actually remove US "English" [the option is not offered].
    0_1508197606568_20171017_001.png

    Furthermore, the selection of plain "English" [what is this?] does offer the removal, but ignores it.
    0_1508197631033_20171017_002.png

    BTW, re:

    in 3-dot-menu set to show UI in English UK.
    

    where is this pls?



  • You can get to that from the context menu of a text field also.. Click on Spellcheck > Language settings, In my case it doesn't list Australian English at all, not sure why. Under Settings there is a setting for UI language, but it only lists English (United States) ... I suppose they don't have anyone translating it into British English. Care to volunteer?

    (Having lived in Canada I'm familiar with the differences between their English and ours here - they seem to be all of the variety listed in the first post: color/colour, defense/defence, center/centre, etc. I've seen British refer to an elevator as a lift, but I don't suppose that would come up when dealing with the UI translation.)



  • The 3-dot-menu is the vertical dots at the right in Other Languages.

    Yes, a little bit confusing in Chromium settings.
    "English" is the main language setting for the UI. The other countries are, i would call it in my bad en knwoledge: a "dialect" of English.
    You have to add such local language for UI and select the one it you like to have.



  • @lonm said in British English language option:

    chrome://settings/languages

    I only get to edit Search Engines. There is no three button, but there is a settings menu with three lines (i guess that is what you mean) where I am offered the above Search Engines and "About". That's it.
    At least I can delete Yahoo.



  • @greybeard Copy the chrome-URL into address field and hit Enter.



  • @gwen-dragon

    Did that (it's a habit, no typos from my Phat Phingers).
    see attached result0_1508258823440_Vivaldi-Chrome-Settings-options.jpg

    The only options I have are what you see in the image.



  • @gwen-dragon

    That's what I did. Result in capture.0_1508260396621_Capture2.JPG



  • @greybeard No, you should type this in regular address bar after opening a tab:
    chrome://settings/languages/
    If you do not want to have any url completion type space bar at end of typing and the enter.
    That works in Vivaldi 1.12 Stable and 1.13 Snapshot.



  • @gwen-dragon said in British English language option:

    chrome://settings/language/

    That is exactly what I did. Result only gives me a settings page to edit search engines. There are no other options except to go to the About page.



  • @greybeard Really? Can not imagine. I tested it on 4 Vivaldis.

    Which Vivaldi is this for you, which OS?



  • @greybeard said in British English language option:

    chrome://settings/language/

    OMG! My fault! :older_woman: :eyeglasses:
    chrome://settings/languages/



  • @gwen-dragon

    Sorry to say I get the same results.
    I get directed to: vivaldi://settings
    Only thing I can edit are search engines.

    In a New Window I get the full page version of Alt+p but there is only "English" which is US.



    1. Make sure that the address you type ends with "languages" (note the 's' at the end): chrome://settings/languages
      If that doesn't work, you can try to right-click in a text input field (like the search box on Google) and click "Spellcheck -> Language Settings".

    2. Click on "Language" on the page that is opened.

    3. Click "Add language" and choose your preferred language.

    4. Click on the icon that looks like a vertical line of 3 dots, to the right of the language you just added.

    5. Select "Display Vivaldi in this language".
      The same menu (the 3-dot icon) can be used to remove other languages.

    6. Click on "Spellcheck" and select what languages you want to have spellcheck for.

    0_1508272132887_b95b693b-56f9-4b87-b19c-ff2553abd455-image.png



  • @komposten

    As I said, I did that. Copied and Pasted the url, with the "s" at the end.
    Only thing I get is a page to change my search engines.
    There are no other options except the "About" page.



  • @komposten "Select "Display Vivaldi in this language"."

    As my earlier pics showed, my SS [current version] in Linux does NOT offer any such choice. Clearly there are conflicting user-experiences happening here...

    Edit: My earlier pic actually was not definitive, so i just did another test now... added German, then used its 3-dot menu... & once more, as i already said, that option is not present.

    0_1508285960722_20171018_001.png



  • @steffie "Display Vivaldi in that language" seems to be a Windows only setting, I don't have it on MacOS. I've noticed some other minor differences in Chrome settings as per OSes, e.g. the "Spell check" item is not available either on MacOS (or, maybe, I'm blind).



  • @hlehyaric Aaaaaaaaaaaaaah, that would explain it then - ta.

    Your good feedback simply reinforces the importance of something i've banged on about here for a while but which many people seem uninterested in, or even resentful of... when posting, include what your OS & V-type is.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.