User Agent Switch Preventing Amazon Log In



  • Hello again! As mentioned in my previous topic, my online banking site was giving me trouble not recognizing my browser, so I added the following parameter to my Vivaldi shortcut: --user-agent="Chrome/61"

    That fixed the problem with that site, but now, Amazon won't let me log in. I get the following message, even though cookies are enabled.

    0_1506310768339_4c57e281-28c3-4009-aa62-254738d38433-image.png

    When I start Vivaldi without the User Agent switch, I can browse to Amazon and it recognizes my cookies and I am logged in.

    Any reason why the User Agent Switch might cause that behavior?

    I'm using Windows 10 and the following Vivaldi Version: 1.12.955.36 (Stable channel) (32-bit)

    Thanks for any ideas.

    Christine :)



  • apart that user agent is too short to be really identified correctly as chrome, use an user agent switcher extension, they are better at this work and they can be also customized with newer user agent strings. The UA in Vivaldi is exactly the same as Chrome but with appended "Vivaldi/1.94.966.3
    "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.91 Safari/537.36"
    Also, never fake your UA unless you're really in need to.



  • @ian-coog

    Thanks for the help. I removed the User Agent parameter I was using and my User Agent is now:
    Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.91 Safari/537.36 Vivaldi/1.93.955.36

    I checked it on this site: http://www.whoishostingthis.com/tools/user-agent/

    No more problems with Amazon, but my online banking site continues to tell me that my browser is outdated.

    When I use Chrome, my user agent is:
    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36

    I don't understand why my online banking is having a problem with the first user agent, but not the second. I tried using a switcher extension, but that didn't help.

    I've decided to use the simplest solution. Use Chrome when I want to access my online banking. :)



  • Hi, is it only for log in or whole bank page?
    Which bank is it? I have no problems with my banking at Norisbank, Germany and Amazon.
    I use "User Agent Switcher for Chrome" with own setup:
    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.104 Safari/537.36

    Cheers, mib



  • @mib2berlin Thanks so much for your help! I got it to work with your setup.

    It's Bank of America and I could log in and use the site. The message appeared when I tried to use the Bill Payment feature. I tried User Agent Switcher for Chrome using "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.91 Safari/537.36" and that didn't help.

    Just now, I tried it with your setup, "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.104 Safari/537.36" and it let me into the Bill Payment.

    So it seems, rather than my browser being too old, it's the bank who needs to get up to date with the latest version of Chrome! :)



  • Haha, good to know.
    Though I should update times.

    Cheers, mib


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.