I will have to stop using Vivaldi... (flicker while scrolling)



  • For now, I switched to Edge. I'm not sure when this started, but now it's so annoying that my head hurts after a few hours of browsing.

    Vivaldi always had some random white flickering on some heavy pages, but it was strange. Now on long articles pages, like for example arstechnica.com, it is completely not usable. Every time you scroll down white flickering, almost on all pages. I'm using the latest stable release, and I'm sure this was not so bad in previous versions. I will wait for some update as browsing like is unbearable.



  • Try disabling hardware acceleration.

    vivaldi://flags/#disable-accelerated-video-decode



  • I actually knew that solution as I searched Vivaldi Flickering and it seems that is the suggest option except that is not a real solution in 2017 for any browser.

    I don't have the problem with Chrome which has hardware enabled, and so do other browsers. So the solution is to use Vivaldi in an inferior software rendering mode only?

    Sorry but that means Vivaldi has a problem with rendering. I should not be disabling something that important in a browser to avoid flickering. Since Vivaldi is using Chromium it makes me wonder why Chrome can get it right but the version Vivaldi uses has problems. It must be something in Vivaldi that is causing this or the latest Chromium version in Vivaldi since the problem was not here before.



  • @terere Try this: Settings > Appearance > check "Use Native Window" and see if it works. I've had the same problem under Linux, not Windows, and it worked. See if it works for you under Windows.


  • Moderator

    @terere Chrome has proprietary media patches which a) are not included in Chromium and b) are not available to anyone else. And even with hardware acceleration "turned on" in Chrome, there's no way for you to know whether your graphics card is blacklisted by them meaning that on your system, Chrome is not using it. You make assumptions which are presumptively derogatory of Vivaldi, but which have no basis in fact.

    I don't know why your system has this unique flickering scroll problem. I know that mine doesn't. Hence, per your own style of logic, there is something wrong with your system - because mine can use both Chrome and Vivaldi without problems. And since my system is good, yours is, perforce, bad.


  • Moderator

    @terere All that said, we have a developer working full time on every last little bug concerning media and graphics reproduction that anyone can find and report. She has already slain some bugs the size of grey wolves.


  • Moderator

    Did you try to disable smooth scrolling?
    vivaldi://flags/#smooth-scrolling

    Did you try to disable gpu vsync?
    Start from commandline or desktop shortcut as vivaldi --disable-gpu-vsync



  • @ayespy

    That is a very bold statement when I work with IT and all drivers, patches, etc. are up to date. It's also a bit arrogant when you apparently can google that others had the problems in the past and your approach and logic here are entirely wrong. Do you think that a mom and dad cares about the technical things you posted? No, they don't. They install a software and it works, or it does not. I don't care how or why Chrome does it. My statement is that other browsers don't have the problem and Vivaldi does. The end users minds about something working or not and if Chrome can get it right, what ever approach they managed, then they are doing a better job. I don't care what trick or hack they did, it works. Also, other Chromium based browsers like Brave or Opera don't have the problem either, but you say this is a unique problem to my system only?

    Maybe, but then it's a unique problem with my system plus Vivaldi, and since I'm not going to change expensive computer setup to keep using Vivaldi, I just switch browsers until it's fixed. Unless you propose telling someone to buy a new computer if Vivaldi has a bug or problem.

    My comment was not derogatory to Vivaldi in any way. I'm not even sure why you read it as some personal attack to the browser or took it so personally. I'm using Vivaldi from the first day they released it, version 0 and all my comments and feedbacks are to improve the browser. I posted this because the issue with flickering was not there before (at least for me), and it was introduced in the last Chromium update. I'm having this even while typing this post now.

    Here let me help you out since you think this is unique to my computer hardware&software only:

    http://lmgtfy.com/?q=vivaldi+flickering

    By the way, my system has two video cards, so your argument makes even less sense...


  • Moderator

    @terere said in I will have to stop using Vivaldi... (flicker while scrolling):

    By the way, my system has two video cards (…)

    Yeah, 2 GPUs? That causes the problem.

    But wait… Never tell us which one you have. We love hunting informations. :spider_web:



  • @terere said in I will have to stop using Vivaldi... (flicker while scrolling):

    Here let me help you out since you think this is unique to my computer hardware&software only:
    http://lmgtfy.com/?q=vivaldi+flickering

    You forgot to put the search in quotes - no point in searching ALL mention of Vivaldi as well as ALL mention of flickering (whether Vivaldi or not).

    Not trying to criticise you, though.
    That search lead me to this post which may be of some use to you (I hope)
    https://forum.vivaldi.net/topic/8116/screen-flickers

    Unfortunately the other such problems appear to be related to video playing (Youtube etc).


  • Moderator

    The most problems are combos of internal Intel and external second GPU (AMD, NVidia) where the OS driver does not work correct or Vivaldi can not distinguish which hardware has to be used.
    I always disable the Intel GPU on Linux and Windows.



  • @terere A lot of great suggestions have been offered so far. However, my advice, before trying anything, would be to first get some key Vivaldi settings back to their defaults:

    • Disable any extensions that you may have installed
    • Disable "Smooth Scrolling" in the Vivaldi settings
    • In the Advanced chrome://settings ensure that the "Use hardware acceleration when available" option is checked/enabled
    • Go to vivaldi://flags and click the button to reset all flags back to their defaults, then Restart Vivaldi.

    If this gets Vivaldi working again for you, great.

    If not, go to vivaldi://gpu and either a) copy/paste/save the entire contents as a text file or b) use Vivaldi's "Capture" feature and save the "Page to File"; it's important to do this while the Vivaldi settings that you reset are still in their default state.

    Try the suggestions that the others have made, one by one.

    If you're still experiencing problems with flickering or jittery scrolling, please file a bug report at https://vivaldi.com/bugreport/ to report your issues to the developers. When you get the confirmation e-mail from the bug tracker, reply to it and attach the vivaldi://gpu capture that you saved earlier.

    I hope this helps and best of luck with your troubleshooting!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.