Downloaded files always have .bin extension



  • Hi all, does anybody have this problem that every downloaded file have (by default) .bin extension?

    E.g. I just downloaded an rpm file, the download confirmation dialog shows it correctly as an rpm:

    0_1504596483317_Screenshot_20170905_091453.png

    However, when I invoke the "Save As..." dialog it suddenly becomes a .bin file:

    0_1504596540748_Screenshot_20170905_091525.png

    I have to explicitly open the "Filter" drop-down and change to rpm (which is correctly offered but is not the default).

    Anybody else?

    T.I.A.
    Cris


  • Moderator

    On Debian 8 KDE and Mint 18.2 (GNOME) i use Save link as… and get for a rpm file the .rpm dropdown.

    Do you have a URL where i can test such download?
    Which Linux and Desktop do you use?



  • Hey,

    I do have the same problem and was about to start a topic. Has been happenin for a while now. The files download correctly, as renaming them after the download makes them perfectly usable.

    For me it has been happening for the last couple of Snapshots, a few months at least, now. Linux Distro is OpenSuse Tumbleweed.



  • @gwen-dragon I'm on openSUSE Tumbleweed, KDE plasma 5.

    Happens everywhere, no need to have a specific URL... btw if you want to test the same file as the one shown in my screenshots, here is the URL:
    http://download.opensuse.org/repositories/home:/hlavki/openSUSE_Tumbleweed/x86_64/latte-dock-0.7.1-1.1.x86_64.rpm

    Cris



  • @topha thank you for your confirmation. It seems an interaction between Vivaldi and some kind of configuration peculiar to openSUSE Tumbleweed.
    UPDATE: Chromium has the same problem. Firefox behaves correctly.

    Cris


  • Moderator

    On my Debian 9 KDE Plasma 5 with Vivaldi 1.11 Stable and 1.12 Snapshot i get in Save dialog "Filter unknown, rpm" and can save as rpm.

    Looks like SUSE save dialog acts strange with Vivaldi.


    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    If you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • @gwen-dragon said in Downloaded files always have .bin extension:

    On my Debian 9 KDE Plasma 5 with Vivaldi 1.11 Stable and 1.12 Snapshot i get in Save dialog "Filter unknown, rpm" and can save as rpm.


    @Gwen-Dragon I can save as rpm too, but the default is "unknown" and the file get saved as .bin (if I don't explicitly chose rpm).

    Are you getting this too? Or you have rpm as default?

    Cris



  • Hi, I am on Opensuse Leap 42.3 and I don´t have even the file dialog.
    If I hit save it download and store in "Download" directory.
    Save as open dialog and show file as .rpm.

    Opensuse Leap 42.3 x86_64
    KDE plasma 5
    CPU Intel T4200 4 GB
    GPU Intel GN 965
    xf86-video-intel 2.99.917-6.1
    Vivaldi latest snapshot


  • Moderator

    @cris70 said in Downloaded files always have .bin extension:

    @Gwen-Dragon I can save as rpm too, but the default is "unknown" and the file get saved as .bin (if I don't explicitly chose rpm).

    For me it shows in KDE "Save as dialog" window at Filter "unknown, RPM package" and in filename field latte-dock-0.7.1-1.1.x86_64.rpm

    0_1504609253254_save-as-rpm-kde-plasma5.png



  • @cris70 Doesn't happen to me either (Linux Mint 18.2 KDE).
    I noticed on your screenshot that the flag (below the filter) "Automatically select filename extension (.bin)" is ACTIVE. Why is this?

    I have the same as @Gwen-Dragon - the flag is titled "Automatically select filename extension" AND is INACTIVE (greyed out).

    Have you tried to deselect that flag (make it INACTIVE) ?



  • Well, I just reported is as a bug now. Have been negligent concerning bug reports over the past weeks anyhow 🙂


  • Moderator

    Why did you select the Filter Unknown (Sconosciuto) to save?
    Change the filter to Sconosciuto, Pacchetto RPM and all will be good.

    Perhaps OpenSuse has a bug if it shows Sconosciuto always.



  • @gwen-dragon said in Downloaded files always have .bin extension:

    Why did you select the Filter Unknown (Sconosciuto) to save?
    Change the filter to Sconosciuto, Pacchetto RPM and all will be good.

    Perhaps OpenSuse has a bug if it shows Sconosciuto always.

    At least for me the Filter unknown is set by default, never selected that.

    Issue occured on two different machines, both with Tumbleweed however.


  • Moderator

    @topha said in Downloaded files always have .bin extension:

    At least for me the Filter unknown is set by default, never selected that.

    Issue occured on two different machines, both with Tumbleweed however.

    Can confirm only on OpenSuse.
    This looks like a Tumbleweed bug to show the bin first..


  • Moderator

    Bug VB-32412 "[Linux] All downloads are saved as *.bin files by default (OpenSuse Tumbleweed)"
    is confirmed internally only for OpenSuse Tumbleweed.



  • @topha said in Downloaded files always have .bin extension:

    @gwen-dragon said in Downloaded files always have .bin extension:

    Why did you select the Filter Unknown (Sconosciuto) to save?
    Change the filter to Sconosciuto, Pacchetto RPM and all will be good.

    Perhaps OpenSuse has a bug if it shows Sconosciuto always.

    At least for me the Filter unknown is set by default, never selected that.

    Issue occured on two different machines, both with Tumbleweed however.

    Yes, same for me. Happy to know a bug has been opened and accepted.
    Thank you.

    Cris



  • BTW I can confirm that deselecting the "Automatically select filename extension" option solves the problem. But the bug remains because, as you can see from the screenshot, V would want to assign the .bin extension to the file.

    0_1504681172153_Screenshot_20170906_085738.png

    Cris


  • Moderator

    @cris70 Yes @Cris70, but the problem with the wrong filter Order happens only on Suse Tumbleweed KDE Plasma 5.
    Just yurious: which is GTK and KDE version do you have?



  • @gwen-dragon Plasma v5.10.5 - KDE Framework v5.37.0
    GTK... how do I check it out?


  • Moderator

    @cris70 Sorry, GTK not needed. My fault. I meant QT.

    My OS tests:

    • Suse - detection of Filter is wrong.
      KDE 5.37.0 | QT 5.9.1
    • Debian 9 - Filter is ok.
      KDE 5.28.0 | QT 5.7.1

    I guess the fault is on newer KDE and QT on Suse.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.