Cant play streams on twitch.tv - Media resource not supported



  • Hey guys,

    Just encountered this Issue, whenever I try to play any stream on twitch it just cycles through stream quality then displays message "Media resource not supported"

    I've googled this issue and there haven't been a solution for me, I tried clearing cache, cookies, enabling override software rendering, enabling GPU accel and so on. Problem persists in Incognito aswell.

    Needless to say that Chrome and Safari don't have this problem

    Thanks!



  • We have some MacOS versions and hardware failing with Vivaldi on video streams. :(


    Please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    If you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a exact link to the page where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!



  • Moderator

    @enzou Vivaldi decodes certain types of video using the native macOS system libraries and typically uses the GPU hardware to do the actual decoding. For most users, when media playback fails but only for some videos, it's usually because GPU hardware acceleration got disabled, either because:

    a) The GPU got blacklisted by the Chromium developers, and you can temporarily work around this (usually without major side effects) by overriding the blacklist in vivaldi://flags

    or

    b) End users (usually MacBook users) intentionally disabled GPU hardware acceleration by unchecking "Use hardware acceleration when available" in the Advanced chrome://settings -- Please ensure that "Use hardware acceleration when available" IS enabled.

    However, if neither of the above caused media playback to break for you, the problem is most likely due to an issue that's specific to your hardware. If this is the case, PLEASE file a bug report at https://vivaldi.com/bugreport/ -- be sure to include the URL of the video that won't play and also the specific model of Mac and graphics hardware that you are using. (To find information about your Mac hardware, click on the Apple icon in the macOS Menu Bar and select "About This Mac"; you can copy and paste the parts of the text that you need.) It would be tremendously helpful to the Vivaldi developers as well if you could also save a capture of the vivaldi://gpu status page to a file (using "Tools / Capture / Page to File"), reply to the confirmation email from the bug tracker, and send them that file as an attachment.

    Users running the pre-release macOS High Sierra Beta releases have also reported media playback issues.

    FYI, work is currently underway to (hopefully!) resolve all of the above issues.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.