Vivaldi and the Yahoo mail



  • This is what I get if I try to login to my Yahoo mail:
    alt text

    and if I proceed I can only use the basic/classic mail...

    Any ideas how to fix it?
    Thanks..



  • @Regnas
    The problem is that yahoo does it'S browser sniffing not good enough and so it doesn't detect that you use vivaldi correctly.
    An easy way to bypass this is by using an user agent switcher - you can get them as extensions in the chrome web store:
    https://chrome.google.com/webstore/search/user agent switcher?hl=en-US
    Just install one of them --> go to the yahoo site --> click on the extension icon and select that vivaldi should cloak as chrome/windows or firefox/windows --> reload the website --> should work now.

    In addition the vivaldi team is working on the issue that some websites doesn't recognise vivaldi correctly.



  • @zaibon
    Thanks for the suggestion.... I hope the vivaldi team can solve this issues soon..



  • May be it is bug VB-29805 "Yahoo Mail stopped working in the normal format"



  • So it's still not fixed? I'm using the latest snapshot btw...



  • @Regnas I do not know as i haven't any Yahoo mail account.

    Did you made a bugreport to Vivaldi bugtracker?



  • Didn't report anything yet...
    The vivaldi team don't check things on this forum?
    By the way, those are my first days with vivaldi, don't know how things work on this side..



  • @Regnas said in Vivaldi and the Yahoo mail:

    The vivaldi team don't check things on this forum?

    The forum is to ask for help and to check if others and internal Vivaldi testers have the same problem. The developers rarely visit the forum, not enough spare time. Sometimes you can post in blog https://vivaldi.com/blog/ when Stables and Snapshots are released and sometimes the developer may see it.

    By the way, those are my first days with vivaldi, don't know how things work on this side..

    No aplologize, please, it is no problem. Please feel free to ask.

    Didn't report anything yet...

    Please do so.
    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    if you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a link to a testpage where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • Thanks...



  • @zaibon said in Vivaldi and the Yahoo mail:

    In addition the vivaldi team is working on the issue that some websites doesn't recognise vivaldi correctly.

    Oops sorry, my bad - seems like maybe I gave you some wrong info -->

    @Gwen-Dragon said in Vivaldi and the Yahoo mail:

    May be it is bug VB-29805 "Yahoo Mail stopped working in the normal format"

    Thought this bug is the same as the one you're experiencing

    Does the user agent switcher solve your problem anyway or do you still have problems with yahoo?



  • @zaibon

    I have the User Agent Switcher installed but setting my user agent to Firefox or Chrome for Windows still loads the browser upgrade popup. What's worse is I can no longer access Classic Mail either, as of a couple of days ago when I click the Try it Later button the page just reloads and gives me the popup over again. Clearing cookies and cache has no effect.


  • Moderator

    @mcgr You have to reload after setting user agent.



  • @Ayespy ,

    Appreciate the response but I have tried completely quitting the browser, deleting all cookies related to Yahoo, setting the User Agent String, and then trying to load Yahoo Mail. Many times the page will not load at all and I get a page not found error with links to other Yahoo pages that also will not load. The only way I can even get to the popup displayed in the first post is to manually type in yahoo.com in the address bar, wait for the page to load, and then click on the mail button in the upper right. But that just takes me back to the popup. About every 10 times I do this it will get me to the actual Yahoo Mail page, sometimes the classic page and sometimes the more modern one...and once I'm there it works fine. But it is not at all consistent when starting up.


  • Moderator

    @mcgr Odd. All I had to do was spoof user agent and reload. Not sure I can reproduce your problem.



  • Hi, I use agent switcher and add a new agent string:

    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.104 Safari/537.36

    I have a Yahoo.com mail account and can use classic and advanced mail client.

    Cheers, mib



  • I was having problems signing into Yahoo Mail from Vivaldi. I run Ubuntu-Gnome 17.04. I followed Ayespy's advise,but I used the spoof for Thunderbird mail: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.2.0 Lightning/4.0.2.
    This gave me access to my Yahoo Mail account just like I was using Fifrefox.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.