[1.10.867.38] WebGL AND/OR Tinkercad.com Slow



  • I updated to 1.10.867.38 and have noticed that webgl content is quite slow(low FPS), for example Tinkercad.com. I actually reinstalled the browser twice and noticed the problem doesn't exist for 1.9x

    I'm using Maui OS with AMGPU and a FuryX with latest Mesa from Oibaf.

    EDIT: In fact it does appear the browser seems slow overall as I notice pages don't scroll quite as smooth anymore so I think this is a broader issue and possible related to WebGL content in general which allot of sites use (pretty sure Tinkercad users webGL for its model building system).


  • Moderator

    Perhaps disabled/incorrect OpenGL driver in Linux?

    Please open vivaldi://gpu , have a look if in first section something is red or orange and post it here.


  • Vivaldi Translator

    @theriddick
    I test;

    • The Gallery "3D"
    • Play a bit in "Learn"

    I met no problems so far. Everything smooth. Only loading everything is slow (downloading contents?).
    Mine is an old nVidia 8600 GT card with proprietary driver. nVidia vdpau. Mesa from Debian official repo.

    Did you test with Chromium or Google Chrome Stable/Beta? Could you test with latest version.Or better with same/close version with Vivaldi.

    I see problems with AMD & Intel or AMD+Intel vs newer Chromium. Usually, here, we usually advice to start with disabling hardware accell. But, that won't solve WebGL issue here, as that option turn off WebGL.



  • @Gwen-Dragon said in [1.10.867.38] WebGL AND/OR Tinkercad.com Slow:

    vivaldi://gpu

    Not sure what you mean by disabling incorrect driver in Linux, AMDGPU open source works fine for most things.

    Here is the output for from that GPU info:

    Graphics Feature Status
    Canvas: Software only, hardware acceleration unavailable
    Flash: Software only, hardware acceleration unavailable
    Flash Stage3D: Software only, hardware acceleration unavailable
    Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
    Compositing: Software only, hardware acceleration unavailable
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only, hardware acceleration unavailable
    Video Decode: Software only, hardware acceleration unavailable
    Video Encode: Software only, hardware acceleration unavailable
    WebGL: Hardware accelerated but at reduced performance
    WebGL2: Unavailable
    Driver Bug Workarounds
    adjust_src_dst_region_for_blitframebuffer
    clear_uniforms_before_first_program_use
    decode_encode_srgb_for_generatemipmap
    disable_framebuffer_cmaa
    dont_remove_invariant_for_fragment_input
    force_cube_map_positive_x_allocation
    init_texture_max_anisotropy
    regenerate_struct_names
    remove_invariant_and_centroid_for_essl3
    scalarize_vec_and_mat_constructor_args
    disable_software_to_accelerated_canvas_upgrade
    Problems Detected
    ATI/AMD cards with older drivers in Linux are crash-prone: 71381, 76428, 73910, 101225, 136240, 357314
    Disabled Features: flash_stage3d, gpu_compositing, panel_fitting, flash3d, gpu_rasterization, accelerated_2d_canvas, accelerated_video_decode, webgl2, accelerated_webgl, flash_stage3d_baseline, accelerated_video_encode
    Accelerated video decode is unavailable on Linux: 137247
    Disabled Features: accelerated_video_decode
    Accelerated video encode is unavailable on Linux
    Disabled Features: accelerated_video_encode
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Linux AMD drivers incorrectly return initial value of 1 for TEXTURE_MAX_ANISOTROPY: 348237
    Applied Workarounds: init_texture_max_anisotropy
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    Linux AMD drivers handle struct scopes incorrectly: 403957
    Applied Workarounds: regenerate_struct_names
    Linux ATI drivers crash on binding incomplete cube map texture to FBO: 518889
    Applied Workarounds: force_cube_map_positive_x_allocation
    Limited enabling of Chromium GL_INTEL_framebuffer_CMAA: 535198
    Applied Workarounds: disable_framebuffer_cmaa
    adjust src/dst region if blitting pixels outside read framebuffer on Linux AMD: 664740
    Applied Workarounds: adjust_src_dst_region_for_blitframebuffer
    AMD drivers in Linux require invariant qualifier to match between vertex and fragment shaders: 659326, 639760
    Applied Workarounds: remove_invariant_and_centroid_for_essl3, dont_remove_invariant_for_fragment_input
    Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
    Decode and Encode before generateMipmap for srgb format textures on Linux AMD: 634519
    Applied Workarounds: decode_encode_srgb_for_generatemipmap
    Software to Accelerated canvas update breaks Linux AMD: 710029
    Applied Workarounds: disable_software_to_accelerated_canvas_upgrade
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers
    Version Information
    Data exported 24/06/2017, 11:55:47
    Chrome version Chrome/59.0.3071.90
    Operating system Linux 4.11.3+
    Software rendering list version 13.8
    Driver bug list version 10.101
    ANGLE commit id unknown hash
    2D graphics backend Skia/59 ef6f9c65527412ec4057ea0551f2e051beb94d32
    Command Line Args --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --flag-switches-begin --flag-switches-end
    Driver Information
    Initialization time 0
    In-process GPU true
    Passthrough Command Decoder false
    Supports overlays false
    Sandboxed false
    GPU0 VENDOR = 0x1002, DEVICE= 0x7300
    Optimus false
    Optimus false
    AMD switchable false
    Driver vendor Google Inc.
    Driver version 3.3.0.2
    Driver date 2017/04/07
    Pixel shader version 3.0
    Vertex shader version 3.0
    Max. MSAA samples 4
    Machine model name
    Machine model version
    GL_VENDOR Google Inc.
    GL_RENDERER Google SwiftShader
    GL_VERSION OpenGL ES 2.0 SwiftShader
    GL_EXTENSIONS
    Disabled Extensions GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent
    Window system binding vendor
    Window system binding version
    Window system binding extensions
    Window manager KWin
    XDG_CURRENT_DESKTOP KDE
    Compositing manager Yes
    Direct rendering Yes
    Reset notification strategy 0x0000
    GPU process crash count 0
    System visual ID 0
    RGBA visual ID 0
    Compositor Information
    Tile Update Mode One-copy
    Partial Raster Enabled
    GpuMemoryBuffers Status
    ATC Software only
    ATCIA Software only
    DXT1 Software only
    DXT5 Software only
    ETC1 Software only
    R_8 Software only
    RG_88 Software only
    BGR_565 Software only
    RGBA_4444 Software only
    RGBX_8888 Software only
    RGBA_8888 Software only
    BGRX_8888 Software only
    BGRA_8888 Software only
    RGBA_F16 Software only
    YVU_420 Software only
    YUV_420_BIPLANAR Software only
    UYVY_422 Software only



  • ok fixed the issue by doing vivaldi://flags/#ignore-gpu-blacklist and enabling that, as suggested in
    https://forum.vivaldi.net/topic/17261/solved-performances-and-screen-tearing-issues/11

    TinkerCad now works good. Odd issue but at least its solved now.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.