Magnet Link default program

  • Not sure if this is a Linux question or a browser question, but...

    Up until this morning, when I clicked on a magnet link, it opened qbittorent, suddenly it is opening Transmission?!?!

    I have not made any changes that I'm aware of. If this is a browser settings issue, could someone tell me what to do. If this is a Linux question, I'll post on the Mint forum.

  • @Felemur
    Did you already check default MIME handler for magnet link?
    Most DE has their own tool for it.

  • OK, thanks, so that means it is something I will have to set in Cinnamon.

  • Not sure what to do now. I posted the question on the Linux Mint forum and the only answer I got was this:

    It depend on which browser you are using. In Firefox, just assign them to qbittorrent in the preferences/applications. In Chrome and Chromium they open with what ever is associated by the system. I don't know if there is an easy way to do that for magnet (it is not a file) but if you uninstall transmission (cinnamon default), it will revert back to qbittorrent or you will be ask for it.

    To dLeon: I cannot find any setting for a MIME handler, so I'm not sure how to check it. Any help would be appreciated.

  • @Felemur
    I forgot to tell you to also check "Handler" in Vivaldi "Site Settings". It's unlikely something will be there but just checking.

    GUI Settings for MIME;
    I don't know every single one of them. I mostly remember KDE/Plasma or XFCE MIME settings GUI. But mostly, I edit the file directly or use command line.

    Seem we need more harder direct approach;
    First I must explain, my attempt to explain obviously a disaster, I hope you could follow it. Using GUI MIME editor will change these files anyway. Sorry before hand.

    All of these to answer;

    Chrome and Chromium they open with what ever is associated by the system.

    Check/search/backup then edit these files;

    • $HOME/.config/mimeapplist (new XDG place 2016>)
    • $HOME/.local/share/applications/mimeapplist (old XDG place)
    • $HOME/.local/share/applications/mimeinfo.cache (old file manager or DE/WM sometime use this)
    • $HOME/.local/share/applications/default (even older but sometimes its there)

    for magnet & torrent MIME handler.

    • x-scheme-handler/magnet (for magnet link)
    • application/x-bittorrent (for *.torrent file)

    Because you expect magnet link to open in Qbittorent but open in Transmission instead, there's possibility that magnet handler already there. If there is, just change it to qBittorent.desktop.
    Note: I don't know what qbittorent desktop file named on your system, double check it in /usr/share/applications. The name I gave above is what I get in Debian.

    For example magnet & torrent open in qbittorent;

    [Default Applications]

    If you need to change them, it will look like above.
    If you don't find any, just put those two line in all those file above.
    I think Vivaldi need to be restart after we change or add those lines.

    Sample from my mimeapplist


    a bit of reference:

    In those references there's a mention about using command line xdg-mime. Better not use it. It still only register to old XDG file (point 2) above.

  • dLeon:

    Thank you for such an effort to help me. Right now things have become so busy I don't have time to do this. I'm going to go through your suggestions this weekend. I will post the results.

  • @Felemur
    Take your time. 😄


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.