Backspace on Google Docs file makes the page go back even while filling in text field



  • Hi there guys,
    good morning to everyone from India. First off, I would like to say that Vivaldi is possibly the most stable browser I have ever used in my life. Thank you for that to the Vivaldi team and some of my queries were cleared up thanks to the threads on the Vivaldi Community so thanks for that as well.

    Now getting right into it, I use Google Docs for a lot of my work as a primary word processor. However, while typing on it when I use the backspace key on my keyboard a lot of the times the page just goes back to the previous one. This is what backspace is supposed to do normally but NOT when some field is being filled in. It does not do that when I am filling in passwords or emails on login pages anywhere, or at least not any place I have encountered yet. However the problem on Google Docs is almost eternal, with me having to be very careful with the back space. I have to use it with shift on and I have tried to do various things but nothing has worked as of now. If anybody else is facing the same issues please let me know how you fixed it or whether there is some setting to help with this.

    I have isolated the issue to Vivaldi because neither Firefox nor Chrome do this and I have tested both extensively. When the text field is not being filled in, all of them go to the previous page.

    Thankfully Vivaldi did not go back to the previous page while I was typing this out!

    Thanks in advance if somebody solves this for me. Much appreciated.


  • Moderator

    @Arsensei: Known bug. For now, you can simply go into extensions and delete the "backspace" shortcut unless it's something you use a lot.



  • @Arsensei
    Or you can use - on those sites that are affected by this - the shortcut to disable shortcuts.
    This one is unassigned by default but you can enable it in
    Settings --> Keyboard --> open "Page" --> scroll down until you find "Disable Keyboard Shortcuts" --> assign a shortcut

    EDIT: and of course you can also assign a mouse gesture to this action



  • @Ayespy Or you could disable the "Single key shortcuts" by un-ticking the box. That might work.
    Also note that backspace shouldn't activate going back if you are in a form field (textarea, input field etc), and it may be that the form field you were in was actually a normal html element with the attribute contenteditable set to "true".
    I have this issue sometimes in Opera12.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.