KDE Activities and Vivaldi



  • I'm using Fedora 25 and the newest release of KDE on my brand new Dell Latitude laptop. About a year ago I installed Vivaldi on my old desktop (last years releases of the above OS and Vivaldi) and decided to play with KDE's "Activities" function. For the un-initiated, it's like a parallel set of virtual desktops. I think the idea was to have one convenient set for work, one for home and one for whatever, each with it's own independently taylorable set of shortcuts, widgets and wallpapers.

    Today was the first time in a while I tried using the facility. Everything seems okay, except, unlike other apps, Vivaldi appears in each activity. The others appear only in the activity (and virtual desktop) in which they were started.

    I don't think that's new - I have a vague memory of the same thing happening a year ago. However, I'm pretty sure a found a control that kept Vivaldi from appearing in any activity except the one in which it was started. Now I can't find that control.

    I'm not sure that the control was in the Vivaldi settings, so I'm asking if any KDE user is familiar with it, or how to update this particular setting.

    Thanks in advance.



  • @jbuckley2004 It's the V Native Window setting. When i first installed V in early 2015 [Mint 17.3 KDE4, back then], i had the same puzzle as you. I discovered that by ticking this setting & restarting V, it then respects the Activities [that is, until the inevitable next Plasma hiccup, after which annoyingly all pgm windows now appear in all Activities, thus [technical term] buggering my carefully organised layout] :-)

    0_1493175056389_upload-bc1e9c1e-a8eb-4a83-a678-e7ad123dbac1

    ..............................................................................................
    Tower & Lappy = Maui Linux 17.03 x64 Plasma 5.9.3.
    ..............................................................................................



  • @Steffie thanks so much. That worked.
    And sorry I took so long to get back to you!



  • @jbuckley2004 Cool, i am really pleased it worked for you. I still recall my own puzzlement at the initially perverse behaviour of V re Activities, & the pleasure [yes, really - i don't get out much!] i felt when i sussed it out... so i'm happy to share.
    ..............................................................................................
    Tower & Lappy = Maui Linux 17.03 x64 Plasma 5.9.3.
    Vivaldi 1.10.845.3 (Official Build) dev (64-bit)

    ..............................................................................................



  • @jbuckley2004 BTW, one of your songs came on my radio a little while ago... always a joy to hear ;-)



  • I think the fact it's need to be in "Native Window" mode is a bug.
    Vivaldi need also to work in its default look.
    Maybe bugreport it?



  • It's not a Vivaldi problem but a KDE problem. All applications that don't use the window manager to draw their decorations behave the same way. Steam is the most well-known example I can think of.

    The standard workaround is to open system settings and navigate to Window Behaviour/Window Rules, then to set a rule for the offending application. (But this isn't necessary for Vivaldi because it allows the user to use the window manager if they prefer.)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.