Google Drive - nie działa "Otwórz w..."



  • Problem jak w tytule, podczas próby otwarcia pliku zapisanego na gdrive za pomocą funkcji "otwórz w..." otwiera się pusta karta.
    Czy u Was również występuje takowy problem? U mnie na Operze działa ok



  • Hmm, nie używam Google Drive, nie jestem pewien czy wiem o co chodzi... Masz może możliwość podesłać linka do jakiegoś publicznego katalogu w Google Drive, żeby to przetestować?



  • dzięki za zainteresowanie, niestety dopóki się nie zalogujesz do konta google nie masz możliwości wyboru funkcji z Otwórz z... dostępnej z menu prawego klawisza myszy.



  • Jestem zalogowany, tylko nie widzę nigdzie opcji "Otwórz w..." w menu kontekstowym, dlatego pytałem. Generalnie nie używam dysku Google, więc mogę się nie znać, ale jak mi wskażesz gdzie to jest, to może uda mi się dojść do przyczyny problemu...





  • Widzisz, znalazłem u siebie wcześniej jakieś fotki, ale nie miałem w ogóle opcji "Otwórz w". W tym linku który podałeś też nie mam tych wszystkich opcji które Ty masz, ale te które są faktycznie nie działają. Dziwne jest to, że po przekopiowaniu jednego zdjęcia do siebie, nagle funkcja "Otwórz w > Dokumenty Google" zaczęła działać. Pozostałe jednak tworzą tylko puste karty.

    Problemem jest chyba to w jaki sposób Vivaldi tworzy nowe karty. Google używa skryptu, który podaje jakieś argumenty przy tworzeniu nowego okienka, ale te gdzieś po drodze się gubią i powstaje tylko pusta karta. Zastanawia mnie w jaki sposób działa to w przypadku Dokumentów Google, które jakimś cudem się jednak otwierają - widocznie dla zewnętrznych aplikacji używane są inne parametry i stąd problem.

    Niestety, jakbym nie kombinował, nie idzie tego obejść. Pozostaje chyba jedynie skorzystanie z innej przeglądarki, aż to naprawią...



  • właśnie sprawdziłem, działa w IE 11 :thinking: . Wygląda że to zdecydowanie problem Vivaldiego. Skoro działa w IE11 to znaczy że nie mamy do czynienia z usługą która działa nijako na "wyłączność" w Chrome.


  • Moderator

    @pwlsrs Sprawdzałem na Snapshocie 1.8 --> Rzeczywiście. Otwiera się w tle pusta strona (biała). Możesz zgłosić to w formularzu (w języku ang) na https://vivaldi.com/bugreport/

    W steps opisując w krokach że wchodzisz na dysk, klikasz PPM na dokument, klikasz otwórz

    W rezultacie pojawi się pusta strona.


  • Moderator

    @pwlsrs Sprawdziłem jeszcze raz - Problem jest -- ale tylko kiedy otwiera się nieprzekonwerterowane na googlowski typ pliki. Po takiej "nieudanej" próbie otwarcia - na dysku pojawia się duplikat (zero bajtów) z inną ikonką. To otwiera się w tle normalnie. Musisz sprawdzić czy tak też jest np. w Operze, FF. 0_1489164133944_b3cf1be1-b9b0-4f4b-86a7-dca29a073358.png


  • Moderator

    @pwlsrs

    W wersji stabilnej 1.11 otwiera się już prawidłowo. Potwierdzasz?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.