Address bar always prefers bookmarks even with the option off



  • Windows 10 Pro 1607 & Vivaldi 1.8.755.3 (Official Build) (32-bit)

    Ever since this new snapshot, my address bar has been prioritizing my bookmarks over top-level domains. For example, typing "re" makes the autocomplete highlight "reddit.com/r/subreddit/bookmarkedpage" instead of "reddit.com" which I have visited before. The option "Always prefer bookmarks" is unchecked. This happens with multiple of my domains I have bookmarked and only started happening with this new snapshot. I have tried disabling my extensions.

    I would appreciate any help.



  • Refreshing Vivaldi and importing just my bookmarks did not fix the issue.

    Image of issue



  • Couldn't find a solution so I've reverted to 1.7 stable until it's fixed in the snapshots.


  • Moderator

    @moonfirespam: And yet my snapshot is not broken. It operates the same as the Stable, as far as autocomplete suggestions in the URL bar.



  • @Ayespy Thanks for the reply.

    I just tried again on a fresh install of the newest snapshot and the bug still persists for me. Here are the steps I took to reproduce it.

    1. Delete the Default folder in Vivaldi's User Data

    2. Open Vivaldi and delete the default bookmarks (because reddit.com is bookmarked)

    3. Uncheck "Always prefer bookmarks" in settings

    4. Bookmark this page (https://www.reddit.com/r/pics/comments/5v693t/panhandler_in_omaha/) or any reddit page that isn't the base domain

    5. Visit the "reddit.com" domain at least once so the browser should auto-complete it

    6. Type "re" in the address bar.

    This is what I get.


  • Moderator

    @moonfirespam: What happens if you enable "Show full address?"



  • @Ayespy No change in behavior.


  • Moderator

    @moonfirespam: I get:
    0_1487639818691_reddit.PNG



  • @Ayespy Did you bookmark the Reddit page? Could you try it with a refreshed Vivaldi profile?


  • Moderator

    @moonfirespam: I never go to reddit. I never have gone to reddit until I typed it in. There's no Reddit bookmark on my system. I can't mess with a clean profile at the moment, as I'm working. Perhaps later.



  • @Ayespy Thanks for taking the time to reply while you are working.

    I don't have a problem with Vivaldi auto-completing to domains when I don't have a bookmark for a subpage under that domain. It only starts auto-completing to the subpage when I have a subpage bookmarked and only in the latest snapshot. It doesn't happen to me only on Reddit but it was a convenient example.



  • Same here, I just allowed it to update so it was in a recent version.



  • Is this going to be fixed? I hoped it would be a reversion in the latest update but it's still broken.



  • @dib_ Issue still persists for me as well.

    I filed a bug report.



  • @moonfirespam Thanks!



  • Are they ever going to fix this? I just had yet another update and it still is broken! This is becoming the biggest thing I hate about this damn browser.


  • Moderator



  • @Ayespy He said he already did. Hopefully the devs get on it soon, it's a daily nuisance.



  • I've had a quick look and I think your problem might be the way it orders suggestions from bookmarks...

    I typed "bbc.co" and I got www.bbc.co.uk/iplayer in the suggestion instead of www.bbc.co.uk. I noticed that in the bookmarks listed, it shows all the subpages (iplayer, news, weather...) before showing my bookmark for just the domain www.bbc.co.uk! The suggestion is the top one from the list. This is a case of their alphabetical ordering being wrong, in my opinion.

    So I'm guessing you also have reddit.com as a bookmark, and ironically that means it shows up lower in your search suggestions than the subpages you bookmarked...

    When I tried with another search for something where I have only a subpage bookmarked but I've previously visited the top-level domain manually, it suggests the typed (without "www"), then visited (with "www") TLDs instead of the bookmark when I type the website name.


  • Vivaldi Translator

    My problem is, what ever options I choose. The sorting always like that.

    1. Search
    2. Typed
    3. Bookmarks
    4. History

    Even if "Typed" didn't exist, "Bookmark" will show before "History".

    From my logic the sorting suppose to be;

    1. Search
    2. Typed
    3. History
    4. Bookmarks

    If about "Word" based searching, isn't Vivaldi already do that?
    I search for "vivaldi", the drop down just list it. Unfortunately with problematic sorting list I mentioned above.

    Plus, it seem visit count didn't work?
    I regularly visit Google Translate. It was bookmarked of course.
    When I search for word "translate", that site always on bottom/middle list in "History" & "Bookmarks" drop down sorting because there was a bunch URLs contain "translate" in alphabetic order before it.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.