Thumbnails and HiDPI improvements - Vivaldi Browser snapshot 1.6.689.13


  • Vivaldi Team

    In today's snapshot we finally resolved a long-standing issue with thumbnails for tabs opened in the background, have a couple of improvements to HiPDI for our Windows fans and fixed several important regressions.

    See the full blog post here



  • First !
    It's my first first, I'm so happy :'-)



  • cheers, VB-23733 fix confirmed when in another window, but still happens if another tab on the same window is choosen.



  • In today's snapshot we finally resolved a long-standing issue with thumbnails for tabs opened in the background

    Still some bugs here. Works sometimes, but most of the times I get a white thumb.
    Easy to test:
    Just google something, and do Ctrl+Left-Mouse-Button on some links ….
    Then you can go to the white thumbs and do a reload to see if Vivaldi is able to create a thumb for that page.

    Keep up the good work.

    Win7x64 Vx32

    EDIT:
    Tabs on the left, "Show Tab Thumbnails" enabled



  • I can confirm this. I think it has somethine to do with the fact that on my computer, when I open or reload a new tab, Vivaldi first shows it blank, and then loads data.
    I suppose the new algorith cashes the very first image after reload (i.e. blank/white/grey), which causes this problem for us.



  • • Group tab stack related context menu items

    Close Tab Stack is not grouped with the other items, and Tile Tab Stack is in a group of its own.



  • Many thanks for solving the "Links unreachable in warning page about invalid certificate" issue! Now I'm up to date again,,, ;-)

    mf


  • Vivaldi Translator

    A question for both of you : when you tested, did you have a low available RAM ?
    Is lazy loading activated ?



  • Yes, a new snapshot!
    And finally the fix for the Speed Dial! Now I can use all the space I have available (which is not much, considering I'm using a CRT monitor)! I had only three columns on the last build, now I can have 5! Thanks for that!



  • @Cqoicebordel:

    Is lazy loading activated ?

    How can this be DEactivated? I never ever want anything to lazy load, and certainly not my browser!
    EDIT: was meant as a reply, but 'quote' obviously doesn't include 'reply', and now there's no way to delete my comment either…



  • Win 7 64 Bit, Viv 32

    Possible, as you call it regression or behavior?

    As in previous SS but not others this one and previous one when you dowloaded a file with the same name and directory ( folder) it gives a filename (1) INSTEAD of asking if you want to overwrite current file. I prefer the choice instead of making another.



  • Hm, what do you mean..? How at the same time you can be within one window in fullscreen mode on one tab and not fullscreen mode on another tab? ._.



  • Lazy Loading is disabled.
    I am running on a machine with 64GB RAM (available RAM was approx 45GB when I tested).
    Is it enough? :wink:

    EDIT:
    Screenshot: http://imgur.com/a/DIVIh



  • Win 7 64 Bit, Viv 32, 8 Gig no problems
    FYI:
    Using process Explorer previous SS used 47% TOTAL "current limit" and this one is using "35%" same pages open. Nothing else changed so my guess it's improved. Sorry didn't use your tools. No other programs active at both times.



  • AFAIR it has always been like that so not a regression. But you can file a bug for it.



  • Open Settings and you immediately see this option in front of you. :D



  • I was running it at work when I wrote the above and yes - that computer is rather slow, but still has about 4 gigs of RAM.

    I've been trying to do it at home, on a much better computer, and I am not able to reproduce it exactly that way - except in one case, where the website has a "loading logo" at the beginning, it remembers the logo and not the page that comes after.

    Here, try it yourself in this example: https://walls.io/bbd16



  • Hmm, I've been testing drag&drop of tabs to a new window (and back). Vivaldi crashes 2 out of 3 times (window disappears in the blink of an eye …)

    Win7x64 Vx32



  • Nothing yet about tab stack renaming working in my Viv x64 in Win10 x64…


  • Moderator

    I found a regression with Tab Stacks on OS X.

    I start my test as follows:

    1. Launch Vivaldi (I have one window with a Start Page tab)
    2. Open vivaldi.net in a new tab
    3. Open a blog post (e.g. this page) in a new page
    4. Select the tabs from steps 2) and 3) then "right_click,Create New Tab Stack with Selection"

    If I "right-click,Move Tab Stack to New Window", sometimes it results in the tab stack getting broken in the new window. (It's seems to reproduce more easily if I reload one of the tabs first, then move the stack while the reload is still in progress.) I can't reproduce the problem via tab dragging.

    If the tab stack is intact in the new window after the move and I then "right_click,Move Tab Stack to Window with 1 Active Tab (Start Page)", the tab stack moves back intact but one of the tabs in the stack is a frozen blank page that will not render. This reproduces very consistently. I don't get a crash. I also can't reproduce this problem via tab dragging either.

    Needless to say, clean install, fresh profile, no extensions.

    I'm still testing but this v1.6 snapshot otherwise seems to be pretty solid so far.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.