Increase width of panel anchor



  • As I use the autohiding panel, I find sometime it fails (the hovering isn't triggered) because the border control is small.
    It's possible to increase its width? :)



  • Ok, found it.
    Simply add this in a new .css (for vivaldi hooks) or in the custom.css.
    I use combined with the great panel autohide .css =)
    Default value is 1px.

    #panel_switch  {
        padding: 5px; 
    }


  • @Hadden89 said in Increase width of panel anchor:

    panel autohide .css

    Can you show/link the panel autohide .css. Thanks



  • I don't use the autohide panel mod, and it was probably posted in the thread about customizations (mind that most of the formatting of the code posted is lost when forum was changed)
    https://forum.vivaldi.net/topic/10629/vivaldi-ui-customisations
    but I found this one very useful for me (posted by @sdfg), copied as _overlay-panels.css and put in the hooks dir of Vivaldihooks, lets the panels appear/hide very smoothly without the jerky page redesign Vivaldi has by default.
    https://forum.vivaldi.net/topic/10590/overlay-panels/13



  • I'll try also the version linked, however I still use the code taken by the old customization thread.
    This will only autohide panel (need panel switch on) and with code above is easier to trigger the hovering.

    #panels-container {
    	position: fixed;
    	height: 100%;
    	max-width: 0vw;
    	opacity: 0;
    	z-index: 1;
    	transition: max-width .5s cubic-bezier(0.18, 0.89, 0.32, 1.28), opacity .2s linear .2s;
    }
    #panels-container:hover {
    	max-width: 99vw;
    	opacity: 1;
    	transition-delay: 0s;
    }
    

    For the overlay follow the link said by iAN and add the relative portion of code ;)



  • @Hadden89 said in Increase width of panel anchor:

    Ok, found it.
    Simply add this in a new .css (for vivaldi hooks) or in the custom.css.
    I use combined with the great panel autohide .css =)
    Default value is 1px.

    #panel_switch  {
        padding: 5px; 
    }
    

    This won't work since 1.8 stable. Maybe the resource for it is slightly changed.
    If anyone know how to correct it, let me know ;)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.