Cannot Drag and Drop Anything!



  • Hopefully we can resurrect this one because this still impacts the user experience now moving into the 2017 new year and while it wasn't really a big deal for the OP it's a deal breaker for me. I absolutely LOVE everything about this browser but I simply can't use it as my daily driver for anything I manage administratively on the web that requires dragging.

    It appears to be, most if not all implementations of drag-able items in the viewport do not work in Vivaldi. In fact, I haven't found any that do. With the growing number of web admin UI dialogs, this becomes a bigger issue because it renders all of them useless (unless those developers had the foresight to provide an alternative method, see last example below), thus rendering this browser useless, in that regards.

    For example, I can't use any page builders that use drag and drop. I can't use commonplace web services that require anything to be dragged into place, facebook, gmail, hotmail, pinterest...JQuery draggable - nope, nadda, zilch. Even simple and standardized html5 examples like these don't work:

    http://www.w3schools.com/HTML/html5_draganddrop.asp
    http://html5demos.com/drag
    http://coursesweb.net/javascript/drag-drop-html5-attributes_t

    And here is an example where dragging is broken but at least they provide a fallback method to browse for the file using a click event. http://filedropjs.org/demo/

    Cheers!


    Vivaldi 1.6.689.46 (Stable channel) (64-bit)
    Revision fce2113643dbabe51ad6825c974c40dbfbaed139
    OS Linux
    JavaScript V8 5.5.372.33
    Flash 24.0.0.194
    User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.98 Safari/537.36 Vivaldi/1.6.689.46
    Command Line /usr/bin/vivaldi-stable --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --flag-switches-begin --flag-switches-end
    Executable Path /opt/vivaldi/vivaldi
    Profile Path /home/bitchpleaze/config/vivaldi/Default



  • @pingram3541
    Drag and Drop on all your example pages works for me. What's your OS?


    Vivaldi 1.6.689.46 64bit
    Vivaldi 1.7.721.3 64bit
    Debian sid amd64



  • Ubuntu 16.04 x64 specifically. Looks like you are same version as me, maybe a missing dependency? Already ran apt-get update...



  • Ditto -- all worked for me too.

    Vivaldi - Linux x64 Deb SS 1.7.721.3
    ..............................................................................................................................................
    Tower's SSD = Linux Maui 2.1 "Blue Tang" x64 Plasma 5.8.4.



  • Well, dependency is one. First check the compositor if you use it. Then there's WM/DE problem. Xorg video and input go next. Libraries and Kernel go last.

    Not much we can track here if we lack information about your system specs.



  • hello pingram3541
    That was fun ... this debian machine passed the three drag example tests using V. 1.7.721.3 today.
    can you review the extensions in your vivaldi for html5blocking? or forcing? or others interfere? is bitchpleaze a good mix with administrative?



  • Ok I really appreciate everybody letting me know this issue is more or less isolated to me. I only discovered this problem after another had mentioned it on a support forum for one of the web dev products I use where drag and drop works in other browsers but not in Vivaldi.

    I set out to investigate and after a few hours I realized I couldn't complete drag and drop operations either...but even worse, I couldn't do it with any type of implementation as per my provided examples, i.e different js libraries, iframe w/ and w/out, etc. Additionally, it only happens in Vivaldi on my system, other browsers are fine.

    I have nothing plugged into this browser that doesn't happen during install. I have no extensions and have only customized the general look/feel and some feature creature stuff like enabling quick access to things. If there is something I can provide the community to help debug I'm glad to help flush this out as it surely could resurface with someone else.

    I created my temp user to start with a new fresh profile just to try that...while I was a little peeved okayhmmmm. Peace!



  • Update: Installed and tried snapshot 1.7.721.3 but same result.

    I'm not using a compositor and my WM/DE is still default Unity w/ Ubuntu 16.04. I'm running on an XPS 15 i7/GTX960 Laptop in which this distro seemed to have the most support for the hardware. Again, I don't have any of these drag problems with other chromium browsers on this same machine so it led me to believe this issue is specific to this browser or an independent support library not shared by the other browsers.

    Another test making me further crazy: http://mdn.github.io/drag-and-drop/copy-move-DataTransfer.html I can see the events in the console, dragStart and dragEnd.



  • @pingram3541 -- i fully recognise the outrageousness of this question, but shall ask it anyway... how wedded are you to having to / wanting to use Ubuntu 16.04 as your OS?



  • @pingram3541 All work for me too.
    On Linux Mint 18 (KDE) with Vivaldi 1.7.721.3 (64 bit)

    • just to add a Ubuntu type OS :grin:


  • @TbGbe -- yes, & my Maui has a Ubuntu 16.04 LTS base, with Neon on top. Some of the distros i least like, are Kubuntu [unstable] & straight Ubuntu.





  • @Steffie Yes, I know (I'm following your OS progression stories).

    But your post said you'd tested in Debian, not Maui. So i just "stuck my 2 pennyworth in".

    @Gwen-Dragon So you were able to reproduce the problem in 1.6 Stable (or current SS)?



  • thanks Gwen-Dragon for attention with encouraging response.
    hello pingram3541. Yes it is time to update, upgrade and trial Again; just that quickly there is today new snapshot for You to try Drag and Drop.



  • @TbGbe said in Cannot Drag and Drop Anything!:

    @Gwen-Dragon So you were able to reproduce the problem in 1.6 Stable (or current SS)?

    I can confirm all 3 example links working with 1.6.689.40 Stable and 1.7.721.3 Snapshot.

    And: https://www.html5rocks.com/en/tutorials/dnd/basics/#toc-examples works with 1.7.725.3 !!!



  • @pingram3541 said in Cannot Drag and Drop Anything!:

    ...
    I'm not using a compositor and my WM/DE is still default Unity w/ Ubuntu 16.04. ...

    Isn't Compiz the built-in compositor-cum-WM?



  • @Steffie The only "real" reason I am running Ubuntu 16.04 is because of my hardware and obviously a fairly large support community. I open to pretty much any distro that is nice on the eyes without a whole lot of tweaking to get there. I am a graphic/web designer/developer so I write a lot of code too and run multiple web tools.

    If I can find a thread confirming "full" hardware support (bluetooth and 4k GTX were the buggers at the time) for my XPS15 9550, I'm not opposed to Mint, Arch, Manjaro or even Elementary.

    @Gwen-Dragon Awesome news, so maybe I'm not crazy with a broken distro after all. Glad someone was able to reproduce the problem I am experiencing. I feel less like a nut =)

    @i_ri Great news I'll test it out asap and report back!

    @aesouza Yes Compiz, I really meant and should have clarified that I didn't install anything on top of or in place of the default core Ubuntu 16.04 environment.



  • I've confirmed the latest snapshot does indeed appear to fix the problem. I've tested about a half dozen sites using different methods and they all work. woohoo fireworks!



  • Nice to hear, @pingram3541 :dancers: :dancers: :dancers: :dancers: :v:



  • @TbGbe said in Cannot Drag and Drop Anything!:

    @Steffie Yes, I know (I'm following your OS progression stories).

    But your post said you'd tested in Debian, not Maui. So i just "stuck my 2 pennyworth in".

    Teehee, OMZ, you're shadowing me; i'd better be on my best behaviour!! To your comment ... but but but... my post gave my V SS version above the line, & my OS below the line. The Deb reference there was to the V file downloaded & used. Are we at cross-porpoises here? [yes, angry aquatic mammal bad pun was deliberate].


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.