1.7.715.3 64-bit: h5ai web server folder listing isn't rendered

  • Found another problem:

    https://nightly.mpc-hc.org/ is showing a blank page. This is how it looks:


    And this is how the good old Opera renders it:


  • works for me, try disabling all your extensions.

  • Tried that, disabled them all, restarted even. No listing. ☹

    When I comment this line

    <script data-module="index" src="https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js">

    the page loads.

    @iAN-CooG Is it possible you have javascript disabled? Because when I disabled JavaScript for that domain, the directory listing does show. So it must be a JavaScript bug in Vivaldi.

    Here's the error log from the developer tools:

    scripts.js:2 Uncaught (in promise) DOMException: Failed to read the 'localStorage' property from 'Window': Access is denied for this document.
        at Object.<anonymous> (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:13894)
        at Object.<anonymous> (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:14111)
        at e (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:488)
        at Object.<anonymous> (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:13278)
        at e (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:488)
        at Object.<anonymous> (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:10890)
        at e (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:488)
        at Object.<anonymous> (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:10600)
        at Object.<anonymous> (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:10772)
        at e (https://nightly.mpc-hc.org/_h5ai/public/js/scripts.js:2:488)
    (anonymous) @ scripts.js:2
    (anonymous) @ scripts.js:2
    e @ scripts.js:2
    (anonymous) @ scripts.js:2
    e @ scripts.js:2
    (anonymous) @ scripts.js:2
    e @ scripts.js:2
    (anonymous) @ scripts.js:2
    (anonymous) @ scripts.js:2
    e @ scripts.js:2
    r @ scripts.js:2
    (anonymous) @ scripts.js:2

    Why does a simple directory listing need such a humungous piece of JS code anyway? Well, the webserver is lying:

    Works best with JavaScript enabled!

  • Moderator

    I can see the listing with 1.7.715.3 32bit and 64bit on Win 10x64.
    And i tested it with 1.6 Stable and internal 1.7.x versions.

    That is not a bug as it works on our OS.

    Please check:

  • @Gwen-Dragon That's because you allow websites to store local data. As is clear from the error log, the site wants to store data, but Vivaldi refuses. With Opera 12 denying cookies and local storage does not break the site, but I guess that's because the web server (or rather that big chunk of JS code) identifies Opera 12 as an outdated browser and refrains from storing data by using fallback JS code. It says “Works best in modern browsers!”.

    When I disable cookies in Firefox the site doesn't render at all just like in Vivaldi. Either I have to disable JavaScript or enable Cookies. I didn't notice the sidebar with the directory folder until I looked at it with Firefox – where I happen to have cookies enabled by default – just now. (Opera 12 was my main browser and kind of still is until I find a satisfying RSS reader. So I never knew all these months there was a folder listing to the left.)

    So basically it's a poorly designed web server, and not Chromium's/Vivaldi's fault.

    Of course my workaround is to disable JavaScript and not to enable local storage for that site. 😉

  • Moderator

    @grogge You did not mentioned that you block this or that...

    As is clear from the error log, the site wants to store data, but Vivaldi refuses.

    It is not clear for us that you have special settings. Block of localstorage may come from extensions, too. 😞

    Well, as you investigated: The visited webserver config is a crappy interface and Vivaldi has no bug.
    Thats why i removed the BUG from thread title and post.

    if you want to do something, please inform the webmaster of nightly.mpc-hc.org about their broken UI.

  • @Gwen-Dragon Well, I've mentioned that I had all extensions disabled yet the site bug prevailed. To be fair I should have thought about cookies right away, because disabling cookies breaks a lot of sites nowadays. Or looked at the developer tools log.

    I've notified the webmaster of the site to fix their setup, btw.

  • Moderator

    @grogge Thanks for your feedback and report to the webmasters of MPC.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.