Vivaldi starts delayed



  • Hi there, I am using Vivaldi since Open Beta but since maybe 2 weeks Vivaldi does not start instant when i press the button of my quickstart bar. What i recognized was, that when the last opend tab was a youtube video, he begins to play the video almost instant but there is no vivaldi window, so you can only hear the sound of the video. After a minute vivaldi starts and you can use it like ever.
    Any ideas how to fix the start delay?

    Greetings
    Munreal



  • @Munreal I don't notice any significant delay. If the youtube video is in the background it won't play on startup until the tab is focused, but if it's the active tab (Startup with last session) then it plays at once and is visible.

    Try diabling extensions.



  • when Vivaldi start-up wast some time to the cofee machin.. the best way is to call the "task_manager" by a clic-right on the task bar...

    seem to work at home... vivaldi appears on the desk quite immediatly...



  • @Pesala Thats what i meant, i am no native speaker. But when my last active tab was a youtube video and i start vivaldi after an reboot, i can hear the sound of the video almost instant without delay, but the browser doesnt show up. I dont have any extension, i also tried the 64-bit client, but same problem.
    When Vivaldi is open and usable and i close it, i can reopen it without any delay, but after rebooting maybe a minute delay.



  • I'm new to Vivaldi. Very nice browser but I noted the same thing as people in this thread. Startup time is 4 / 5 seconds. (win 10 pro, vivaldi 32 bits, last release)



  • I had delays of 4-8 seconds when starting Vivalidi.exe (from SSD !), wether extensions are active or not. :confused:
    Delaytime seems to increase while using vivaldi more intensive.
    Lurking with Mark Russinovichs great procmon-tool, i watched vivaldi during startup spending "a lot of time" when it sniffs around in the files of my download-folders. It tries to query some basic information for each file, then close them again and looking for the next one...
    To check this out, i temporary renamed my default download-folder (which lies on a NAS).
    So, not able to access the downloaded files anymore, my vivaldi comes up within a second! (Skylake i7 / SSD )
    Similar effect, when i cleared the list of previous downloaded files (use the brush-icon in the download-sidebar) - doing no more download-checks results in a quick start on my system.
    Could anyone with annoying delays check this out and report?



  • @RRR13

    60 seconds is far beyond acceptable! :rage:

    "...I think the last test we do should be to clear all the downloads in the downloads panel and see if it changes anything."

    This is exactly, what i would ask other users to try!
    I have tested this with four different vivaldi-installations so far and the effects on my systems are always the same: After clearing the download-list, vivaldi comes up much more faster. This works well for me for the time being, but there may be additional problems out there, which throttle vivaldi during startup. We'll see...
    I wonder, what vivaldi is doing with these file-checks ... Is this just to ensure, that the dl-list is still correlating with the download-folder? :confused:

    "..Can you please test the restart after update as well?"

    I will! But they send 1.5.658.42 to me, just before I read your post :-) So I have to wait for next update.



  • @fay01 you have to manually download the stable 1.5 release if you have the dev snapshot build installed. Snapshots don't see stable releases updates and vice-versa.



  • @iAN-CooG

    Right, let's see, what the stable version will do.
    (But they send these dev snapshots out to be proved by us, didn't they? )

    Need to gather some downloads then... :-)



  • @fay01 said in Vivaldi starts delayed:

    @iAN-CooG

    Right, let's see, what the stable version will do.
    (But they send these dev snapshots out to be proved by us, didn't they? )

    Need to gather some downloads then... :-)

    just install Stable as Standalone for you testing, no need to "lose" Snapshot.
    (Not sure there is any difference between 1.5 RC 4 and 1.5 Stable, just rebuild for Stable branch).



  • @TbGbe the HUE support was not in .42, appeared only in .44, probably even something else.



  • @RRR13 yes



  • @fay01 said in Vivaldi starts delayed:

    But they send 1.5.658.42 to me, just before I read your post So I have to wait for next update.

    There is a new snapshot today - with "improvements" to start up.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.