Speak It Fails But Works Under Chrome :(



  • Hello Community,

    I have been using the SpeakIt extension with Vivaldi on Windows however on Linux (Ubuntu based specifically) it fails. There is NO error provided as it just doesn't work.

    However Chrome on Linux (same Ubuntu machines) works great with SpeakIt. So same extension and Vivaldi (based one Chrome) fails. That means Vivaldi is doing something or not doing something that Chrome is and also the OS has the necessary software or Chrome would fail too.

    I wanted to report this to the community and to the Vivaldi team. I do not want to use Chrome proper. I want my Vivaldi and am puzzled as to why this isn't working.

    https://chrome.google.com/webstore/detail/speakit/pgeolalilifpodheeocdmbhehgnkkbak?utm_source=chrome-ntp-icon

    Thanks!

    Jeremy O



  • I should add I honestly don't care about SpeakIt persay. I just want text to speech. If Vivaldi had this built in that would be fine with me. I just want to highlight text, right click, and select something like Speak It or Read. Then I hear the text read through my speakers.

    Thanks.

    Jeremy O



  • Hi, I was interesting in such an extension and first I check is working.

    Select and Speak - Text to Speech

    Cheers, mib



  • Thanks for the suggestion. That doesn't work either unfortunately.

    I guess there is something with the way Vivaldi is working on my system. However as stated Chrome works fine with SpeakIT on this system. So I am not sure what Vivaldi is doing or not doing that works for Chrome.



  • i have seen other command line tricks to make tts work as well. this just looks like the main thread for the ubuntu forum. i remember seeing a cli program to do this in any distro.
    https://help.ubuntu.com/community/TextToSpeech
    one way or another you should be able to bypass this through accessability settings.

    mint 18 kde: system-settings>desktop behavior>accessability>screen reader.


  • Moderator

    SpeakIt only works with Vivaldi Snapshot on Debian 8.6 KDE 4.14 ALSA + Pulseaudio.
    I tested it minutes ago with Vivaldi 1.5.658.3 Snapshot.

    You need to install package chromium-codecs-ffmpeg-extra or fetch a libffmpeg. https://labs.gwendragon.de/blog/Web/Browser/Vivaldi/vivaldi-debian-install-libffmpeg-en



  • @Gwen-Dragon Is there any information when will this feature become available in stable Vivaldi version?

    Seriously, I use TTS all the time, and missing this on Vivaldi is causing great pain :)



  • I wanted to report that after upgrading to 1.5.658.44, a few days ago, this feature started working. I am currently using Ubuntu MATE 16.04.1 with current updates.

    I am very glad this feature is now correctly functioning. I am not sure what edits were performed however a big thank you to the team!

    I do want to test this on other distros too.

    Good luck to others.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.