Scroll Wheel of my mouse now only ZOOMS a page – can't do regular scrolling



  • I used a Logitech mouse, Anywhere MX, and a corded version, too...I've had no problems with the mouse until the latest very upgrade. Now, when I am on a web page, say, Google News, instead of scrolling up or down with my scroll wheel, page ZOOMS size, up and down. I can't get it to scroll regularly. I DO NOT want my scroll wheel to control zooming, or if I do, I want to control that. I have the same problem with a Microsoft mouse I tried. Anyone else having this problem? This bug (if it is one) has made Vivaldi unusable for me...I have to be able to scroll in web pages...the weird thing is, (if this is a Logitech mouse/software problem)I don't have this issue with any of the other browsers: not Firefox, Chrome, Chrome Beta, Safari, or Tech Safari..... Steve



  • Hmmm, maybe this is related problem with scrolling in Vivaldi has to do with this, which I just found:

    USERS REPORTING 'WRECKED SCROLLING' ON LOGITECH MICE AFTER MACOS SIERRA UPDATE

    http://www.macrumors.com/2016/09/22/wrecked-scrolling-logitech-mice/

    But, I'm not having mouse problems anywhere else but Vivaldi…works fine with Firefox, Firefox Beta, Chrome, Chrome Beta, Safari and Safari Tech review....and in all my other programs, works fine...



  • I'm having the exact same problem. The scroll wheel now zooms in and out rather than scrolling up and down. I have a Logitech M310 mouse and I'm using the Logitech Control Center software.



  • I face the same problem. Right after updating to macos sierra and latest vivaldi. It seems to only affect vivaldi even after disabling all the mouse gesture function. I hope this can be fixed soon because I do not want to use other browser.



  • Same here! Updated to Sierra, but no scrolling/zooming issues anywhere but in Vivaldi. Really makes it difficult to even use Vivaldi.



  • Well, I justed updated the Logitech Control to the new 3.9.5 version for MacOS Sierra via MacUpdate

    https://www.macupdate.com/app/mac/8154/logitech-control-center

    And that didn't fix the problem with ZOOM/scrolling with Vivaldi that I reported, which I hoped it might. (Though glad Logitech was quick to give a Sierra fix, given problems others had reported.)

    My question to others having this problem is whether these reports here are seen by the developers? Should I be reporting the bug in some other way? I hope there's an update soon to fix this, since I don't seem to be the only one with this problem, proving it's not just my machine – Retina 5K 27-inch iMac.

    Steve


  • Moderator

    The developers read here, plus the bug has been reported at the page where you or anyone can file a bug report or request a feature. It is receiving attention from developers, but it's not fully understood why it happens, so there's no eta on a fix.



  • Ah, thanks SO much! Good to hear the bug is know…..I know these things can be hard to track down, and thanks for the link to posting bug reports...

    Hope this can be fixed soon!

    Best wishes,
    Steve



  • I am also having this issue (macos Sierra), but I can scroll the page and when it hits the top/bottom and if I continue to force the scrolling the page zoom in/out. I have a Razor mouse with default mac os x driver. No problem with the trackpad, only with an external mouse with scrollwheel.



  • Same issue here. I made a thread about this a few weeks ago when the GM candidate for macOS Sierra released. Been having problems ever since.

    I ended up giving up and switched back to Safari. Vivaldi has been rendered useless for me on macOS Sierra.



  • Same here. I switched back to Chrome…I can't live without OneTab and FVD Speed Dial (yes, available for Firefox and Opera, too, but I've got so much ram and speed to burn, I use Chrome.)

    I do hope the software ninjas can figure this out soon. I really love Vivaldi, esp. the Panels...it's great putting Pocke there..

    Best wishes,
    Steve



  • Same here. OSX Sierra, Logitech Performance MX. I like Vivaldi, but I cannot use it with Logitech mouse, so, I switch back to Safari :-(



  • Installing "Logitech Options" fixed the problem for me. (MBP Mid 2014, macOS Sierra 10.12.1, MX Anywhere 2)



  • WooHoo!! The latest OSX Sierra update has fixed this issue! It has for me at least, hopefully everyone else too. I just tested it and no zoom anymore. Gotta love it! ;)



  • Same here, but wasn't sure what fixed it since I installed the OS Sierra update and tried a few suggestions here, as well. But you post makes me think it was something that changed in Sierra. As you say, WooHoo!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.