Cannot open URLs from Outlook



  • When I click on an URL in an Outlook email, I get an error message, "Something unexpected went wrong with this URL: <url>. Access is denied." If I change Windows default browser to, e.g., Chrome, everything works as expected. I am using Windows 8.1, most recent version of Vivaldi. The problem may have been introduced with the latest Vivaldi update, which I made recently; in any case opening URLs used to work for me with Vivaldi previously. Anybody else experiencing this? Is it possible to download prior Vivaldi versions? Then I could check.</url>



  • bump



  • For me it works fine with Vivaldi 1.3.551.38 (Stable channel) (32-bit) in Windows 8.1 and Outlook 2013

    Older versions you may find here:
    https://vivaldi.net/en-US/content/vivaldi-updates



  • Thank you, your help is appreciated!
    I am using Office 2016, and upgraded recently. Perhaps only this exposes the issue….


  • Moderator

    The "issue" is Windows refusing to acknowledge the default browser. Have you gone to the control panel in Windows, default programs section, and checked to ensure that Vivaldi has all defaults? You may have to check one protocol at a time.



  • Yes, I have already checked that. I found 2 protocols associated with browsers, and set both to Vivaldi, to no avail.



  • Ayespy we agree that default programs is where this got fixed when it happened to us. ..turned away from mentioning prior because we didn't have a microsoft system running to look at to get the exact names of the defaults that needed to be selected. Sure seems like there is more than two. it was two of the many choices. where do you suppose Metaspace is going wrong with finding default program settings? default programs, by application(helpers), vivaldi, select defaults. is there really count of two?
    Lucius What defaults does your machine have set Lucius?
    edit add: initiated a pc vivaldi on microsoftWindows. has thirteen protocols and six extensions. That is whyAyespy suggested one at a time to locate the fix. then set, save. good luck Metaspace. opposite/: or set all defaults to vivaldi.. see if outlook hyperlink open function, then untick the boxes [reassign defaults] to find what turn it off to not working for outlook.


  • Moderator

    The setting you need to look at under Default Programs is not "Set your Default Program" but rather "Associate a File Type."

    You can click the headings at the top of that window to sort by "Current Default" and then scroll down to "Microsoft Edge" (or whatever browser is opening instead of Vivaldi) . There are two frames, one above the other, to scroll through. The first is file types, and the second is protocols. You will find Edge or IE or Chrome or Firefox or whatever in both of them probably. For ANY file type that says Microsoft Edge, change it to Vivaldi. Under protocols, there are only two that should be set to a Microsoft browser. The one that contains the name of the browser, and one called "Read." If there is a Microsoft browser or Chrome or firefox or any other browser) assigned to any protocol, that assignment should be changed to Vivaldi.



  • Hi again, finally was able to come back to this.
    First of all, thank you for your help.

    I checked my file types, protocols; for the former, Opera is the only other browser listed for .xhtml files.
    For protocols, IE is the only other one listed for URL:MK and URL:RES protocols.

    So it does not look like I can do anything here. BTW, I use Microsoft Office 2016 - I upgrade recently, before I had 2013 and no issues, so the combination of '16 with Vivaldi may well be the problem.
    Please note, when clicking URLs e.g. from Cisco Jabber (or other programs), everything works.

    Something new I noted yesterday, at home I use a very old mail client, Eudora for Windows, when I click a link from there, Vivaldi is not started properly (the process is spawned, but nothing happens); if Vivaldi is already open, the URL is displayed.
    At home I use Windows 7 64bit. Just mentionning this as the problems might be interconnected.



  • Hi,

    just for explanation:
    I did not change any associations manually.
    All I did was checking the check box "Make Vivaldi default Browser" during installation.

    It suffices that Vivaldi is connected to the URL:HTTP and the URL:HTTPS protocols.
    And these are the only associoations to Vivaldi in my protocol-list.
    However, I am running Win 8.1 here…



  • Whenever I use Outlook it makes me wish Vivaldi's mail client was already here.

    What version of Windows are you running?



  • hello Metaspace
    Don't confuse this thread Outlook with a Eudora example. Eudora grants permissions through the address contacts list. Please stick to the Outlook solutions. ((plus if you have used Eudora why did you ever go to outlook; that would be another thread for you.))



  • I use Outlook at work, Eudora on my private PCs at home. I just mentioned it because both problems observed have to to with notifying the OS that a browser should be launched/an URL displayed. So the problems are likely to be related.

    For the Windows version I use, please see above.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.