Window stuck on "invisible" second screen



  • I have a main monitor, which is in front of me and secondary - on the right. I work on 2 windows of Vivaldi, one on the main, second - on the second one, of course. The problem is, after I close Vivaldi, turning off my PC and then turn it on, so the Vivaldi - my saved session automatically opens. My second window from the saved session, which was on the right screen, opens on the main one. But my first window, which was on the main screen, opens on a left screen, which doesn't exist! (I have my secondary monitor on the right). I can't access to my first window, I'm clicking it, to maximalize and/or minimalize and I see the window is moving from the left to the down. So the only one way to recovery this window is to change my secondary screen in Nvidia drivers to the left and the stuck window is back, then change back to the right. Strange, because in older versions everything was ok. If I want to open new window, it normally opens on the right screen, but saved session after I turn on my PC - doesn't :(



  • I'm having this same issue, but with a single window. It starts up off screen and I cannot reposition it. New windows open on the screen as normal.

    Has anyone found a solution to this?

    Thanks


  • Moderator

    The only thing I could recommend is to refresh your profile.

    This is a very rare and puzzling problem, and the developers and testers have not been able to replicate it yet.



  • Hi
    I do have the same issue even after a brand new Linux setup
    When i ask a new window it's opening on the right screen.
    This is only concerning Vivaldi: neither Chrome neither Firefox are doing that.


    Linux version 4.4.0-21-generic (buildd@lgw01-06) (gcc version 5.3.1 20160413 (Ubuntu 5.3.1-14ubuntu2) ) #37-Ubuntu SMP Mon Apr 18 18:34:49 UTC 2016
    Vivaldi 1.3.551.38 (Stable channel) (32 bits)
    Révision ec1fa47e9941592fc4783e7c53ea5291c667df58
    Blink 537.36 (@ec1fa47e9941592fc4783e7c53ea5291c667df58)
    JavaScript V8 5.2.361.49
    Agent utilisateur Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.117 Safari/537.36 Vivaldi/1.3.551.38
    Ligne de commande /usr/bin/vivaldi-stable –ppapi-flash-path --ppapi-flash-version --always-authorize-plugins --disable-translate --window-depth=24 --x11-visual-id=33 --wm-user-time-ms=1650477 --flag-switches-begin --flag-switches-end
    Variantes 9f0416c1-ec60c096



  • I do have same issue, but in my case, chrome and chromiun have a similar behaving, I'm using nvidia propietrary driver on lubuntu with xinerama enabled.
    4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
    vivaldi-stable 1.4.589.38-1
    0f:00.0 VGA compatible controller: NVIDIA Corporation GF116 [GeForce GTS 450 Rev. 2] (rev a1)
    0f:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)
    28:00.0 VGA compatible controller: NVIDIA Corporation G86 [Quadro NVS 290] (rev a1)

    Cheers,



  • Actually, Going here vivaldi://settings/search#hardware and disabling the hardware acceleration solved my issue.

    Cheers


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.