Vivaldi Proxy Settings



  • Proxy Settings - is there a way to uncouple those setting tied to Windows Network Settings in Vivaldi? I like the Proxy Settings like FireFox & SeaMonkey has - Not coupled to Windows Settings. What I like doing is blocking proxies trying to hack my blog. The software I prefer is paid, open source, freeware & not taking a chance with embedded nasties from hack wares.



  • I use the VPN.S HTTP Proxy extension, which offers pretty much the same setup options as the FF > Settings > Avanced > Network options do.

    So, i point my vivaldi to 127.0.0.1:8118 (privoxy which forwards to tor). The best thing is, this proxy extensions offers also (like FF) the option to define exceptions for those sites which are not tor friendly (for some reason), but you need to use nevertheless; without the hassle to configure a pac file.

    [EDIT]Obviously, you can do the forwarding also in privoxy[/EDIT]



  • Where do you get said extension for vivaldi ?



  • There is no need for an extension. Simply start vivaldi with the Chrome-Option –proxy-server="127.0.0.1:8118" (example for privoxy). http://www.chromium.org/developers/design-documents/network-settings

    Well, you can do a lot of things in privoxy, but i confess: I still prefer doing them in Opera 12. I wish they worked the same way here.



  • So Linux version has no way to change the proxy settings? I am hoping to find a way to change them to link to my VPN as google is blocked in China?



  • Extra info:
    It seems that there is a workaround based on existing access to an unrestricted internet:

    @gwen-dragon said in Proxy settings:

    There is no extra setting, you must use the system proxy.

    Try to workaround with this extension: https://chrome.google.com/webstore/detail/proxy-switcher-manager/onnfghpihccifgojkpnnncpagjcdbjod

    Seems like a bit of a catch 22

    Does anyone know how I can do this, or should I resign myself to not using Vivaldi in China when behind a proxy?

    Maybe there is a proxy extension somewhere?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.