Webの日本語表示のうち旧字体がある漢字が新字体でなく旧字体になる



  • 質問か不具合報告かで迷ったのですが、不具合である確信が持てなかったので、
    一旦こちらで質問させてください。
    皆様のところではこのような問題は起こっていないでしょうか?
    また解決方法などご提案があればよろしくおねがいします。

    環境
    Vivaldi 2.3.1440.41 (Stable channel) (64-bit)
    OS Windows10 Pro 64bit Ver.1809 Build.17763.253
    再現手順
    Web上の日本語サイトの日本語表示すべてで発生するので下記は一例です。
    1.検索欄に「台湾」と入力して検索結果を表示させる
    2.検索結果の入力欄は「臺灣」に切り替わっている
    3.検索結果自体も「臺灣」表示になってしまう
    本来あるべき挙動
    日本語で使用する新字体で表示。
    実際の挙動
    Web上の日本語サイトの漢字の表示のうち、
    旧字体(繁体?)が存在するものについて旧字体に置き換わる。

    0_1549613641264_new-kanji-font  ー>old-kanji-font.png

    補足情報
    Vivaldi 2.3.1440.41に更新した直後から発生した。
    [設定]-[一般]-[言語]を「日本語」にした場合に発生する。
    その他の言語(中文繁体も含めて)で日本語のサイトを表示しても発生しない。
    また、FirefoxやChromeについてもこの問題は発生していない。

    使用拡張機能
    Evernote Web Clipper 7.9.0
    Keepa - Amazon Price Tracker 3.30
    Google 翻訳 2.0.7
    Session Buddy 3.6.3
    LastPass: Free Password Manager 4.24.0
    Save to Pocket 3.0.5.2
    uBlock Origin 1.18.2


  • Vivaldi Team

    @kant09

    質問ありがとうございます。
    社内で確認をとってみましたが、本挙動は再現ができませんでした。
    拡張機能をご使用とのことですので、一度全ての拡張機能をオフにしていただき、
    同じ挙動が再現できるか確認いただけますか?
    社内でも引き続きモニタリングさせていただきます:)



  • レスポンスありがとうございます。
    拡張機能をオフにし、キャッシュの削除、再起動してみましたが、
    残念ながら症状は改善しませんでした。

    テストの過程で気になる症状があったので、追試のうえ追記したいとおもいます。



  • 原因が特定できたので報告いたします。

    当初、言語を日本語にした場合にのみ発生すると記述しましたが、
    その後のテストの過程で、言語を英語に変更していた場合にも、
    一部同様の症状が発生したので言語の設定が無関係だと判断しました。

    また、明朝体を指定したサイトでは、同様の症状が発生しないことがわかりました。
    以上のことから、ゴシック系のフォントの設定が原因ではないかと推測しました。

    フォントの設定は[標準]、[ゴシック体]、[明朝体]、[等幅]、[草書体]、[装飾文字]の6箇所ありますが、
    順番に変更していったところ、[ゴシック体]をMaruGoAA-SRにした場合にのみこの症状が発生しました。
    なお、類似のMaruGoR-AAではこの問題は発生しませんでした。
    また、前バージョンの2.1.1337.51 (Stable channel) (64-bit)では、この操作をしてもこの症状は出ないことを確認しました。

    今バージョンからこのフォントとの相性が良くないようです。できれば、前バージョン同様問題が出ないように対応いただけると助かります。


  • Vivaldi Team

    @kant09

    追加報告ありがとうございます。
    念の為確認です、フォント MaruGoAA-SR をご使用中とのことですが、
    このフォントはご自身でダウンロードしたものになりますでしょうか?



  • そうですね。
    だいぶ以前に、WEB上から無くなる前にダウンロードしたものです。
    たしかその後、ライセンスがらみでWEBからなくなったと記憶しています。


  • Vivaldi Team

    @kant09

    ご回答ありがとうございます。
    該当となるフォントをもちあわせていないため再現にはまだ至っていませんが、
    引き続きモニタリング後、社内にて共有、対応検討とさせていただきますね 😃



  • ありがとうございます。
    ちょっと微妙なフォントでの症状なので、正直門前払いされるかもと思っていました。
    とりあえず、対応するかどうか検討していただける、とのことなので嬉しく思います。
    あとは、なんとかフォントを調達されかし、と🙏🏼



  • 自分も同じような状況になったので調べてみましたkant09さんが使っていた[MaruGoAA-SR]含め
    [MaruGoAA-SR2][MaruGoR-AA]+別Ver [HiramaruAA]を
    拡張機能のStylusで[ font-family: "上記のフォント名" !important;] で指定した所、旧字体が表示されました

    推測ではありますがvivaldiが原因ではなくフォント側のバグだと思われます

    旧字体ではないですがMeiryo-AARを指定すると何故か英数字が90度横向きますw



  • 「MaruGoAA バグ」などで検索すると、他ブラウザでも同様の症状が発生しているようです。
    自分もそのフォントを所持していないので確かなことは言えませんが、フォントファイル側に原因があるものと思われます。


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.