Blocked website in Vivaldi but not in Firefox based browsers: http://RT.com



  • First Post: Be gentle. Love Vivaldi. Used to use Opera, till they lost sight of what they were offering. Vivaldi.... excellent. BUT: One website is blocked in Vivaldi. https://RT.com (The Russia Today news website). [url=https://RT.com]https://RT.com[/url] works in Firefox, Midori, (Used to work in Chromium but now doesn't). I'm using Linux, Fedora 24, In Australia, with on a Cable Internet connection. I don't have a block list installed (as far as I know) and, anyway, https://RT.com works in Firefox. Vivaldi WILL load https://RT.com through a proxy and webunblocker. like [url=https://unblockweb.co/]https://unblockweb.co/[/url] I'm stumped. Why is RT.com blocked in Chrome based browsers but not in Firefox and Midori? It sounds suspect to me. And a little upsetting. If it was my internet connection then it would be blocked in Firefox and Midori as will; but it isn't. Suggestions appreciated. Thank you.



  • RT.com is not blocked for me, so I doubt it is Vivaldi causing the problems.
    I do not use a user agent switcher, so Site blocking certain browsers is not the problem either.
    However, I am NOT in Australia :blink:

    All I can think of is some extension blocking it. Easiest check if you do use extensions is with a clean profile
    https://vivaldi.net/forum/all/14141-refreshing-or-cleaning-your-profile#71738

    I admit that this wouldn't explain how it works using a proxy.


  • Moderator

    No problems with Vivaldi.
    rt.com loads fine from Germany.



  • @ TbGbe… that worked. Resetting (backing up and renaming profile so a new one is generated when Vivaldi starts) worked.

    So... I think it must be a plugin. But why would it also affect Chromium? Do they use the same plugin directory? Also, I disabled the plugins and restarted Vivaldi but the RT.com block continued (maybe it hadn't unloaded from RAM?)

    Anyone know where the plugins directory in Linux is stored?

    Is it possible there is a blocklist in Vivaldi somewhere/



  • G'day ridgie-didge true-blue cobber Spinifex, I'm also in Oz [but no, i don't normally talk like [i]that]

    That site loads properly for me in my primary Mint OS [latest V SS; 1.3.551.28 (Developer Build) dev (64-bit)], & i then fired up my cobwebby ole Win10 [retch] VM & retested it there [an older V SS, but then also the current SS after update]; both versions also correctly loaded.

    Due to my vehement disgust at our crappy misgovernment's mandatory data retention laws, these days i don't touch the web directly through my ISP, but instead via my VPN… including for the tests above. They were done using a Perth server, & just before writing the following words i also tested with a Melbourne server, with same positive results. Who knows, maybe if i went naked, off-VPN, it might be blocked... but i'm unwilling to try that, sorry.

    Oh, i just realised you use Fedora 24, so i also launched my Fedora 24 KDE Plasma5 VM & tested the RT site [still with VPN's Melbourne server]; also loads fine [again, 1.3.551.28 (Developer Build) dev (64-bit)].

    Maybe Mr Metadata is targeting you? :P

    …....................................................................................
    My on-SSD OS = Linux Mint x64 17.3 KDE 4.14.2.



  • @ Steffie … Yeah, maybe Mr Turnbulls 'security agreement with the US' is to blame. But that would also happen if I was using Firefox or Midori.

    No. I think it must be a plugin... but for the life of me I'm not sure what.
    I have Ghostery running inf FF & Vivaldi.
    Have Youtube HD running in FF & Vivaldi.
    Have 'FFS encrypt the web https running int FF but not Vivaldi.
    And a few other extensions.

    Its interesting that RT.com is also blocked in Chromium. That's what got me bugged (pun intended). Do Chrome & Vivaldi use the same plugins / extension path?

    PS: What VPN do you use? I'm after a cheap 'good' one if you want to pm me.



  • Hi Spini [which rude contraction of mine segues to [i]Spiny, which reminds me of Spiny Norman, but depending on your age & comedic preferences you might not understand or appreciate my Monty Python allusion, so probably best i leave it]. BTW my Brandis dig was me just having a go at that clown; i did realise the logical inconsistency.

    I also suspect it might be an incompatible Extension, as even though V now works well with a pretty large suite of the Google Chrome Store Extensions, many users frequently report various hassles with various individual Extensions. That said, it would surprise me much if any Extension from that store also buggered Chrome itself &/or Chromium, & only for [apparently] one specific site, but who knows?

    The quick & dirty [albeit useful] test would be the usual caper many of us here frequently advise V-newbies, when V does unexpected stuff; close V, copy or rename your profile's Default folder, relaunch V to create a clean virgin Default, then without doing anything else retry that site. If it works, then you know it was an Extension, or otherwise a corrupted Default, to blame, for which in the narrowing down you need to get forensic (i could guide you on that, but it'd depend on your time availability & patience].

    Happy to chat offline re VPNs.

    …....................................................................................
    My on-SSD OS = Linux Mint x64 17.3 KDE 4.14.2.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.